summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2005-06-06 12:45:39 +0000
committerHeinrich Wendel <lanius@gentoo.org>2005-06-06 12:45:39 +0000
commit9eda4d71f5b0512c6e5a10230fc08a98f08391a9 (patch)
tree66c371f4b150f6373a23007965129c32f16e59b0 /dev-util/debootstrap/debootstrap-0.2.45-r1.ebuild
parentStable on x86. (diff)
downloadgentoo-2-9eda4d71f5b0512c6e5a10230fc08a98f08391a9.tar.gz
gentoo-2-9eda4d71f5b0512c6e5a10230fc08a98f08391a9.tar.bz2
gentoo-2-9eda4d71f5b0512c6e5a10230fc08a98f08391a9.zip
version bump
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-util/debootstrap/debootstrap-0.2.45-r1.ebuild')
-rw-r--r--dev-util/debootstrap/debootstrap-0.2.45-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-util/debootstrap/debootstrap-0.2.45-r1.ebuild b/dev-util/debootstrap/debootstrap-0.2.45-r1.ebuild
new file mode 100644
index 000000000000..7c3b2f240681
--- /dev/null
+++ b/dev-util/debootstrap/debootstrap-0.2.45-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/debootstrap/debootstrap-0.2.45-r1.ebuild,v 1.1 2005/06/06 12:45:39 lanius Exp $
+
+MY_PV=${PV}-0.2
+DESCRIPTION="Debian bootstrap scripts"
+HOMEPAGE="http://packages.qa.debian.org/d/debootstrap.html"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ~sparc amd64 ppc"
+SRC_URI="mirror://debian/pool/main/d/debootstrap/debootstrap_${MY_PV}.tar.gz
+ mirror://gentoo/devices.tar.gz"
+DEPEND="sys-devel/binutils
+ net-misc/wget
+ app-arch/dpkg"
+IUSE=""
+S=${WORKDIR}/${PN}-${PV}
+
+src_unpack() {
+ unpack debootstrap_${MY_PV}.tar.gz
+ cp ${DISTDIR}/devices.tar.gz ${S}
+}
+
+src_compile() {
+ sed -i -e "s/chown/#chown/" Makefile
+ make pkgdetails debootstrap-arch
+}
+
+src_install() {
+ make DESTDIR=${D} install
+}