summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-08-10 08:23:58 +0000
committerJeroen Roovers <jer@gentoo.org>2014-08-10 08:23:58 +0000
commit9be27ce82bc121eac7ccdfe2514aa13c01fa63fc (patch)
tree7481b6d593d0f917d79e263719f1a1787a10d4a6 /dev-util/debhelper
parentFix shebang of rebase-helper (bug #519514), optimize python modules in non-st... (diff)
downloadgentoo-2-9be27ce82bc121eac7ccdfe2514aa13c01fa63fc.tar.gz
gentoo-2-9be27ce82bc121eac7ccdfe2514aa13c01fa63fc.tar.bz2
gentoo-2-9be27ce82bc121eac7ccdfe2514aa13c01fa63fc.zip
Version bump.
(Portage version: 2.2.11-r1/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'dev-util/debhelper')
-rw-r--r--dev-util/debhelper/ChangeLog7
-rw-r--r--dev-util/debhelper/debhelper-9.20140809.ebuild70
2 files changed, 76 insertions, 1 deletions
diff --git a/dev-util/debhelper/ChangeLog b/dev-util/debhelper/ChangeLog
index a4fa52bb218d..93d4e8d2390e 100644
--- a/dev-util/debhelper/ChangeLog
+++ b/dev-util/debhelper/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/debhelper
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/debhelper/ChangeLog,v 1.106 2014/08/01 11:05:46 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/debhelper/ChangeLog,v 1.107 2014/08/10 08:23:58 jer Exp $
+
+*debhelper-9.20140809 (10 Aug 2014)
+
+ 10 Aug 2014; Jeroen Roovers <jer@gentoo.org> +debhelper-9.20140809.ebuild:
+ Version bump.
01 Aug 2014; Raúl Porcel <armin76@gentoo.org> debhelper-9.20140228.ebuild:
sparc/x86 stable, bug #506100
diff --git a/dev-util/debhelper/debhelper-9.20140809.ebuild b/dev-util/debhelper/debhelper-9.20140809.ebuild
new file mode 100644
index 000000000000..9285a2a40286
--- /dev/null
+++ b/dev-util/debhelper/debhelper-9.20140809.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/debhelper/debhelper-9.20140809.ebuild,v 1.1 2014/08/10 08:23:58 jer Exp $
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Collection of programs that can be used to automate common tasks in debian/rules"
+HOMEPAGE="http://packages.qa.debian.org/d/debhelper.html http://joeyh.name/code/debhelper/"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux"
+IUSE="test"
+DH_LINGUAS=( de es fr )
+IUSE+=" ${DH_LINGUAS[@]/#/linguas_}"
+
+NLS_DEPEND=$(
+ printf "linguas_%s? ( >=app-text/po4a-0.24 )\n" ${DH_LINGUAS[@]}
+)
+
+RDEPEND="
+ >=dev-lang/perl-5.10
+ >=app-arch/dpkg-1.17
+ dev-perl/TimeDate
+ virtual/perl-Getopt-Long
+"
+DEPEND="${RDEPEND}
+ ${NLS_DEPEND}
+ test? ( dev-perl/Test-Pod )
+"
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ tc-export CC
+
+ local LANGS="" USE_NLS=no lingua
+ for lingua in ${DH_LINGUAS[@]}; do
+ if use linguas_${lingua}; then
+ LANGS+=" ${lingua}"
+ USE_NLS=yes
+ fi
+ done
+
+ emake USE_NLS="${USE_NLS}" LANGS="${LANGS}" build
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+ dodoc doc/* debian/changelog
+ docinto examples
+ dodoc examples/*
+ local lingua
+ for manfile in *.1 *.7 ; do
+ for lingua in ${DH_LINGUAS[@]}; do
+ case ${manfile} in
+ *.${lingua}.?)
+ use linguas_${lingua} \
+ && cp ${manfile} "${T}"/${manfile/.${lingua}/} \
+ && doman -i18n=${lingua} "${T}"/${manfile/.${lingua}/}
+ ;;
+ *)
+ doman ${manfile}
+ ;;
+ esac
+ done
+ done
+}