summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeert Bevin <gbevin@gentoo.org>2001-12-05 01:59:11 +0000
committerGeert Bevin <gbevin@gentoo.org>2001-12-05 01:59:11 +0000
commitec9be5a83d4f0afb6e0c4f3dcf4c7c4399e5e170 (patch)
tree66761be1d1e693d7daada69518069c15c5cf69a7 /dev-util/ddd
parentNewer version (diff)
downloadgentoo-2-ec9be5a83d4f0afb6e0c4f3dcf4c7c4399e5e170.tar.gz
gentoo-2-ec9be5a83d4f0afb6e0c4f3dcf4c7c4399e5e170.tar.bz2
gentoo-2-ec9be5a83d4f0afb6e0c4f3dcf4c7c4399e5e170.zip
Initial portage version of the GNU visual debugger.
Diffstat (limited to 'dev-util/ddd')
-rw-r--r--dev-util/ddd/ddd-3.3.1.ebuild36
-rw-r--r--dev-util/ddd/files/digest-ddd-3.3.12
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-util/ddd/ddd-3.3.1.ebuild b/dev-util/ddd/ddd-3.3.1.ebuild
new file mode 100644
index 000000000000..5c341ce9d788
--- /dev/null
+++ b/dev-util/ddd/ddd-3.3.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Geert Bevin <gbevin@theleaf.be>
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ddd/ddd-3.3.1.ebuild,v 1.1 2001/12/05 01:59:11 gbevin Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GNU DDD is a graphical front-end for command-line debuggers"
+SRC_URI="ftp://ftp.easynet.be/gnu/ddd/${P}.tar.gz \
+ ftp://ftp.easynet.be/gnu/ddd/${P}-html-manual.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/ddd"
+
+DEPEND="virtual/glibc
+ virtual/x11
+ >=sys-devel/gdb-4.16
+ motif? ( >=x11-libs/openmotif-2.1.30 )"
+
+src_compile() {
+ try ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+
+ try emake
+}
+
+src_install () {
+ try make DESTDIR=${D} install
+
+ mv ${S}/doc/README ${S}/doc/README-DOC
+ dodoc ANNOUNCE AUTHORS BUGS COPYING* CREDITS INSTALL NEWS* NICKNAMES \
+ OPENBUGS PROBLEMS README* TIPS TODO doc/README-DOC
+
+ rm ${S}/doc/README-DOC
+ mv ${S}/doc/* ${D}/usr/share/doc/${PF}
+}
+
diff --git a/dev-util/ddd/files/digest-ddd-3.3.1 b/dev-util/ddd/files/digest-ddd-3.3.1
new file mode 100644
index 000000000000..72555eddaad2
--- /dev/null
+++ b/dev-util/ddd/files/digest-ddd-3.3.1
@@ -0,0 +1,2 @@
+MD5 e74807d11ae6caaa2f3ef82791384ce0 ddd-3.3.1-html-manual.tar.gz 5132288
+MD5 38589618d7cd02a03d062bb116bbf1d2 ddd-3.3.1.tar.gz 5824512