summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenat Lumpau <rl03@gentoo.org>2005-10-01 16:19:39 +0000
committerRenat Lumpau <rl03@gentoo.org>2005-10-01 16:19:39 +0000
commita44438c28c7206523ccff70ea7f31770ca17a815 (patch)
treeb44ffcb622390a61185b976c5a7c9df9caeecc66 /dev-util/cvsweb/cvsweb-3.0.6.ebuild
parentFixed variable casing in pkg_postinst to restore make.globals updating (diff)
downloadgentoo-2-a44438c28c7206523ccff70ea7f31770ca17a815.tar.gz
gentoo-2-a44438c28c7206523ccff70ea7f31770ca17a815.tar.bz2
gentoo-2-a44438c28c7206523ccff70ea7f31770ca17a815.zip
Version bump
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'dev-util/cvsweb/cvsweb-3.0.6.ebuild')
-rw-r--r--dev-util/cvsweb/cvsweb-3.0.6.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-util/cvsweb/cvsweb-3.0.6.ebuild b/dev-util/cvsweb/cvsweb-3.0.6.ebuild
new file mode 100644
index 000000000000..d6743bf21af9
--- /dev/null
+++ b/dev-util/cvsweb/cvsweb-3.0.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cvsweb/cvsweb-3.0.6.ebuild,v 1.1 2005/10/01 16:19:39 rl03 Exp $
+
+inherit webapp
+
+KEYWORDS="~x86 ~sparc ~ppc"
+LICENSE="BSD"
+DESCRIPTION="WWW interface to a CVS tree"
+SRC_URI="ftp://ftp.freebsd.org/pub/FreeBSD/ports/local-distfiles/scop/${P}.tar.gz"
+HOMEPAGE="http://www.freebsd.org/projects/cvsweb.html"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=dev-lang/perl-5.8
+ >=dev-util/cvs-1.11
+ >=app-text/rcs-5.7
+ >=dev-perl/URI-1.28
+ dev-perl/IPC-Run
+ dev-perl/MIME-Types
+ dev-perl/String-Ediff
+ >=dev-util/cvsgraph-1.4.0
+ >=app-text/enscript-1.6.3
+"
+
+src_install() {
+ webapp_src_preinst
+
+ cp cvsweb.conf ${D}/${MY_HOSTROOTDIR}
+ cp css/cvsweb.css ${D}/${MY_HTDOCSDIR}
+ exeinto ${MY_CGIBINDIR}
+ doexe cvsweb.cgi
+ chmod +x ${D}/${MY_CGIBINDIR}/cvsweb.cgi
+
+ dodoc README TODO NEWS ChangeLog
+
+ webapp_hook_script ${FILESDIR}/reconfig
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+ webapp_src_install
+}