summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2006-09-30 23:22:30 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2006-09-30 23:22:30 +0000
commit76e27f2fc10666dab0a456b0dea34e97b74f5a43 (patch)
tree07681be35585daffb4845426eb10a8405ac3de89 /dev-util/cvs
parentMasking upcoming version of pythonmagick since it depends on masked dev-libs/... (diff)
downloadgentoo-2-76e27f2fc10666dab0a456b0dea34e97b74f5a43.tar.gz
gentoo-2-76e27f2fc10666dab0a456b0dea34e97b74f5a43.tar.bz2
gentoo-2-76e27f2fc10666dab0a456b0dea34e97b74f5a43.zip
Version bumps, 1.12.13.1 should now fix the zlib issues from bug 124733.
(Portage version: 2.1.2_pre2)
Diffstat (limited to 'dev-util/cvs')
-rw-r--r--dev-util/cvs/ChangeLog9
-rw-r--r--dev-util/cvs/cvs-1.11.22.1.ebuild57
-rw-r--r--dev-util/cvs/cvs-1.12.13.1.ebuild136
-rw-r--r--dev-util/cvs/files/digest-cvs-1.11.22.112
-rw-r--r--dev-util/cvs/files/digest-cvs-1.12.13.112
5 files changed, 225 insertions, 1 deletions
diff --git a/dev-util/cvs/ChangeLog b/dev-util/cvs/ChangeLog
index 8d8d7f55c998..2066126296b0 100644
--- a/dev-util/cvs/ChangeLog
+++ b/dev-util/cvs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/cvs
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cvs/ChangeLog,v 1.109 2006/08/09 02:04:54 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cvs/ChangeLog,v 1.110 2006/09/30 23:22:30 robbat2 Exp $
+
+*cvs-1.12.13.1 (30 Sep 2006)
+*cvs-1.11.22.1 (30 Sep 2006)
+
+ 30 Sep 2006; Robin H. Johnson <robbat2@gentoo.org> +cvs-1.11.22.1.ebuild,
+ +cvs-1.12.13.1.ebuild:
+ Version bumps, 1.12.13.1 should now fix the zlib issues from bug 124733.
*cvs-1.12.12-r4 (09 Aug 2006)
diff --git a/dev-util/cvs/cvs-1.11.22.1.ebuild b/dev-util/cvs/cvs-1.11.22.1.ebuild
new file mode 100644
index 000000000000..6623ed9caa5a
--- /dev/null
+++ b/dev-util/cvs/cvs-1.11.22.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cvs/cvs-1.11.22.1.ebuild,v 1.1 2006/09/30 23:22:30 robbat2 Exp $
+
+DESCRIPTION="Concurrent Versions System - source code revision control tools"
+HOMEPAGE="http://www.cvshome.org/"
+SRC_URI="mirror://gnu/non-gnu/cvs/source/nightly-snapshots/stable/${P}.tar.bz2
+ doc? ( mirror://gnu/non-gnu/cvs/source/nightly-snapshots/stable/cederqvist-${PV}.html.bz2
+ mirror://gnu/non-gnu/cvs/source/nightly-snapshots/stable/cederqvist-${PV}.pdf
+ mirror://gnu/non-gnu/cvs/source/nightly-snapshots/stable/cederqvist-${PV}.ps )"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc emacs"
+
+DEPEND=">=sys-libs/zlib-1.1.4"
+
+src_unpack() {
+ unpack ${A}
+ # remove a useless binary
+ einfo "Removing a compiled binary"
+ find ${S} -type f -name getdate -exec rm \{} \;
+}
+
+src_compile() {
+ econf --with-tmpdir=/tmp || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die
+
+ insinto /etc/xinetd.d
+ newins ${FILESDIR}/cvspserver.xinetd.d cvspserver || die "newins failed"
+
+ dodoc BUGS ChangeLog* DEVEL* FAQ HACKING \
+ MINOR* NEWS PROJECTS README* TESTS TODO
+
+ if use emacs; then
+ insinto /usr/share/emacs/site-lisp
+ doins cvs-format.el || die "doins failed"
+ fi
+
+ if use doc; then
+ dodoc ${DISTDIR}/cederqvist-${PV}.pdf
+ dodoc ${DISTDIR}/cederqvist-${PV}.ps
+ tar xjf ${DISTDIR}/cederqvist-${PV}.html.tar.bz2
+ dohtml -r cederqvist-${PV}.html/*
+ cd ${D}/usr/share/doc/${PF}/html/
+ ln -s cvs.html index.html
+ fi
+}
+
+src_test() {
+ einfo "FEATURES=\"maketest\" has been disabled for dev-util/cvs"
+}
diff --git a/dev-util/cvs/cvs-1.12.13.1.ebuild b/dev-util/cvs/cvs-1.12.13.1.ebuild
new file mode 100644
index 000000000000..91936bff2bcf
--- /dev/null
+++ b/dev-util/cvs/cvs-1.12.13.1.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cvs/cvs-1.12.13.1.ebuild,v 1.1 2006/09/30 23:22:30 robbat2 Exp $
+
+inherit eutils pam
+
+DESCRIPTION="Concurrent Versions System - source code revision control tools"
+HOMEPAGE="http://www.nongnu.org/cvs/"
+
+SRC_URI="mirror://gnu/non-gnu/cvs/source/nightly-snapshots/feature/${P}.tar.bz2
+ doc? ( mirror://gnu/non-gnu/cvs/source/nightly-snapshots/feature/cederqvist-${PV}.html.bz2
+ mirror://gnu/non-gnu/cvs/source/nightly-snapshots/feature/cederqvist-${PV}.pdf
+ mirror://gnu/non-gnu/cvs/source/nightly-snapshots/feature/cederqvist-${PV}.ps )"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+
+IUSE="crypt doc emacs kerberos nls pam server"
+
+DEPEND=">=sys-libs/zlib-1.1.4
+ kerberos? ( virtual/krb5 )
+ pam? ( virtual/pam )"
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+ use doc && unpack cederqvist-${PV}.html.bz2
+ EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/${PN}-1.12.13-cvsbug-tmpfix.patch
+ # both of these are already done by upstream
+ # EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/${PN}-1.12.13-openat.patch
+ # EPATCH_OPTS="-p0 -d ${S}" epatch ${FILESDIR}/${PN}-1.12.13-zlib.patch
+
+ # 1.
+ # this testcase was not updated
+ #sed -i.orig -e '/unrecognized keyword.*BogusOption/s,98,73,g' \
+ # ${S}/src/sanity.sh
+ # this one fails when the testpath path contains '.'
+ # 2.
+ # make the test output verbose by default
+ sed -i.orig \
+ -e '/newfile config3/s,a-z,a-z.,g' \
+ -e '/^verbose=false$/s,false,true,g' \
+ ${S}/src/sanity.sh
+}
+
+src_compile() {
+ local myconf
+ # the tests need the server and proxy
+ if has test $FEATURES; then
+ use server || \
+ ewarn "The server and proxy code are enabled as they are required for tests."
+ myconf="--enable-server --enable-proxy"
+ fi
+ econf \
+ --with-external-zlib \
+ --with-tmpdir=/tmp \
+ $(use_enable crypt encryption) \
+ $(use_with kerberos gssapi) \
+ $(use_enable nls) \
+ $(use_enable pam) \
+ $(use_enable server) \
+ $(use_enable server proxy) \
+ ${myconf} \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die
+
+ if use server; then
+ insinto /etc/xinetd.d
+ newins ${FILESDIR}/cvspserver.xinetd.d cvspserver || die "newins failed"
+ fi
+
+ dodoc BUGS ChangeLog* DEVEL* FAQ HACKING \
+ MINOR* NEWS PROJECTS README* TESTS TODO
+
+ if use emacs; then
+ insinto /usr/share/emacs/site-lisp
+ doins cvs-format.el || die "doins failed"
+ fi
+
+ if use doc; then
+ dodoc ${DISTDIR}/cederqvist-${PV}.pdf
+ dodoc ${DISTDIR}/cederqvist-${PV}.ps
+ tar xjf ${DISTDIR}/cederqvist-${PV}.html.tar.bz2
+ dohtml -r cederqvist-${PV}.html/*
+ cd ${D}/usr/share/doc/${PF}/html/
+ ln -s cvs.html index.html
+ fi
+
+ newpamd ${FILESDIR}/cvs.pam-include-1.12.12 cvs
+}
+
+src_test() {
+ einfo "If you want to see realtime status, or check out a failure,"
+ einfo "please look at ${S}/src/check.log*"
+ if [ -n "$TEST_REMOTE_AND_PROXY" ]; then
+ einfo "local, remote, and proxy tests enabled."
+ else
+ einfo "Only testing local mode. Please see ebuild for other modes."
+ fi
+
+ cd ${S}/src
+ export TESTDIR="${T}/tests/local"
+ mkdir -p "${TESTDIR}"
+ # 0755 does NOT work, it leaves the mode as 2755
+ chmod u=rwx,g=rwx,o=rx,a-s "${T}/tests" "${TESTDIR}"
+ ls -la "${TESTDIR}"
+ # we only do the local tests by default
+ make localcheck || die "Some local test failed."
+ mv -f check.log check.log-local
+
+ # if you want to test the remote and proxy modes, things get a little bit
+ # complicated. You need to set up a SSH config file at ~portage/.ssh/config
+ # that allows the portage user to login without any authentication, and also
+ # set up the ~portage/.ssh/known_hosts file for your machine.
+ # We do not do this by default, as it is unsafe from a security point of
+ # view, and requires root level ssh changes.
+ if [ -n "$TEST_REMOTE_AND_PROXY" ]; then
+ cd ${S}/src
+ export TESTDIR="${T}/tests/remote"
+ mkdir -p "$TESTDIR"
+ chmod u=rwx,g=rwx,o=rx,a-s "${T}/tests" "${TESTDIR}"
+ make remotecheck || die "Some remote test failed."
+ mv -f check.log check.log-remote
+
+ cd ${S}/src
+ export TESTDIR="${T}/tests/proxy"
+ mkdir -p "$TESTDIR"
+ chmod u=rwx,g=rwx,o=rx,a-s "${T}/tests" "${TESTDIR}"
+ make proxycheck || die "Some proxy test failed."
+ mv -f check.log check.log-proxy
+ fi
+}
diff --git a/dev-util/cvs/files/digest-cvs-1.11.22.1 b/dev-util/cvs/files/digest-cvs-1.11.22.1
new file mode 100644
index 000000000000..736cd77de405
--- /dev/null
+++ b/dev-util/cvs/files/digest-cvs-1.11.22.1
@@ -0,0 +1,12 @@
+MD5 56fc68d81eca0be49ac51bd9b5b4730f cederqvist-1.11.22.1.html.bz2 107756
+RMD160 71097b684f70da383c0ea304362397c77060f1c9 cederqvist-1.11.22.1.html.bz2 107756
+SHA256 7341279a3643417730f0459e7ce3af6ffbec483dc497f8823639c741ef4f12c1 cederqvist-1.11.22.1.html.bz2 107756
+MD5 fa2fe630b3861655d19cec3a3a5cf7a9 cederqvist-1.11.22.1.pdf 1109762
+RMD160 8239082132f6dd21b6e14725eb59ae399dd07788 cederqvist-1.11.22.1.pdf 1109762
+SHA256 94f42f25366d3d294c9880b1c0ab7d2dc6f03192831f08481aea818a50d1b78b cederqvist-1.11.22.1.pdf 1109762
+MD5 1bce3cd3c0709aca354f5c4acc8c6417 cederqvist-1.11.22.1.ps 1102300
+RMD160 876b35c99d98cb937146dde6c8efc4d43b183804 cederqvist-1.11.22.1.ps 1102300
+SHA256 01c9707b9a398f82eef2aa5cbc00e7a4f668d2ae6c8e4d8c152f22955b6df9f4 cederqvist-1.11.22.1.ps 1102300
+MD5 2bb74a5c7b495e4254d5aa036c9d16e5 cvs-1.11.22.1.tar.bz2 2952428
+RMD160 2377c94833ea34edc88ba5e1d1860cac4300e4f0 cvs-1.11.22.1.tar.bz2 2952428
+SHA256 f5244d31176dfd1f8ff29fa1903baee3e1949aa88c348bb37a475a3187354045 cvs-1.11.22.1.tar.bz2 2952428
diff --git a/dev-util/cvs/files/digest-cvs-1.12.13.1 b/dev-util/cvs/files/digest-cvs-1.12.13.1
new file mode 100644
index 000000000000..900144759d35
--- /dev/null
+++ b/dev-util/cvs/files/digest-cvs-1.12.13.1
@@ -0,0 +1,12 @@
+MD5 07fbdacae6997fd9426a1b76c8d52ec8 cederqvist-1.12.13.1.html.bz2 138038
+RMD160 a714b25d408e4558c9ac0fe4b40df59a6adf2dde cederqvist-1.12.13.1.html.bz2 138038
+SHA256 873d6323c4d3bdfdca9abdd894f167bd15df24d5a76de5a26fc7e385cac08b71 cederqvist-1.12.13.1.html.bz2 138038
+MD5 760a08dcdb0e9d2d52cc818c335f1d4c cederqvist-1.12.13.1.pdf 1352456
+RMD160 ff4bcfa30bc2afc772f9a1efd2fc92a586a85533 cederqvist-1.12.13.1.pdf 1352456
+SHA256 3748b298acbb93c79e296e3157d1cf7d4a2e6b1ba6e8e9152245e77936940873 cederqvist-1.12.13.1.pdf 1352456
+MD5 a617dc78fe3746a28e5258bb357027a9 cederqvist-1.12.13.1.ps 1324162
+RMD160 2ee0556e4488d4c0a00b108aca06cc89bed6f283 cederqvist-1.12.13.1.ps 1324162
+SHA256 39398c41e571488f6406d5905ad4a446d41dc5326c8c46a97899e64c57fc3137 cederqvist-1.12.13.1.ps 1324162
+MD5 cfd07b224956daaed53fb3063bece1bf cvs-1.12.13.1.tar.bz2 4075630
+RMD160 7e281fe8f63805c2fa76dad18b2c537e77cea8b2 cvs-1.12.13.1.tar.bz2 4075630
+SHA256 de7f374d8c4ac414c04e8d44ce9a5d3da919825a6a332d747e299dc7a80c2218 cvs-1.12.13.1.tar.bz2 4075630