summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2007-12-14 14:22:32 +0000
committerDoug Goldstein <cardoe@gentoo.org>2007-12-14 14:22:32 +0000
commitba7132149bee43a7ea1d0293046af91941ae8e82 (patch)
treeef977fd9c7bcc434af1a3908fb9ff89bb53cf8ef /dev-util/cvs2svn/cvs2svn-1.5.1.ebuild
parentFix mounting smb shares (diff)
downloadgentoo-2-ba7132149bee43a7ea1d0293046af91941ae8e82.tar.gz
gentoo-2-ba7132149bee43a7ea1d0293046af91941ae8e82.tar.bz2
gentoo-2-ba7132149bee43a7ea1d0293046af91941ae8e82.zip
add new version requested from bug #202233. remove old version
(Portage version: 2.1.4_rc9)
Diffstat (limited to 'dev-util/cvs2svn/cvs2svn-1.5.1.ebuild')
-rw-r--r--dev-util/cvs2svn/cvs2svn-1.5.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-util/cvs2svn/cvs2svn-1.5.1.ebuild b/dev-util/cvs2svn/cvs2svn-1.5.1.ebuild
new file mode 100644
index 000000000000..a42162c6f3ce
--- /dev/null
+++ b/dev-util/cvs2svn/cvs2svn-1.5.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cvs2svn/cvs2svn-1.5.1.ebuild,v 1.1 2007/12/14 14:22:31 cardoe Exp $
+
+inherit distutils
+
+FILEVER="36129"
+
+DESCRIPTION="Convert a CVS repository to a Subversion repository"
+HOMEPAGE="http://cvs2svn.tigris.org/"
+SRC_URI="http://cvs2svn.tigris.org/files/documents/1462/${FILEVER}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="dev-lang/python
+ >=dev-util/subversion-1.0.9"
+RDEPEND="${DEPEND}
+ app-text/rcs"
+
+src_install() {
+ distutils_src_install
+ insinto "/usr/share/${PN}"
+ doins -r contrib cvs2svn-example.options {profile-repos,show-db,verify-cvs2svn}.py
+ doman cvs2svn.1
+}
+
+pkg_postinst() {
+ elog "Additional scripts and examples have been installed to:"
+ elog " ${ROOT}usr/share/${PN}/"
+}
+
+src_test() {
+ # Need this because subversion is localized, but the tests aren't
+ export LC_ALL=C
+ python run-tests.py || die "tests failed"
+}