summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-11-18 08:57:25 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-11-18 08:57:25 +0000
commitd9f844f3ddbe371952f38ac166340a8f9aead78d (patch)
tree67d501156d5e01ff5ceaab54de65a9ff3255b2fb /dev-util/cscope
parentresurrect openmotif-2.1.30-r4.ebuild for mips (Manifest recommit) (diff)
downloadgentoo-2-d9f844f3ddbe371952f38ac166340a8f9aead78d.tar.gz
gentoo-2-d9f844f3ddbe371952f38ac166340a8f9aead78d.tar.bz2
gentoo-2-d9f844f3ddbe371952f38ac166340a8f9aead78d.zip
*** empty log message ***
Diffstat (limited to 'dev-util/cscope')
-rw-r--r--dev-util/cscope/ChangeLog9
-rw-r--r--dev-util/cscope/Manifest15
-rw-r--r--dev-util/cscope/cscope-15.5-r1.ebuild67
-rw-r--r--dev-util/cscope/files/15.5-noclobber-tempfile-rexotec.patch31
-rw-r--r--dev-util/cscope/files/digest-cscope-15.5-r11
5 files changed, 111 insertions, 12 deletions
diff --git a/dev-util/cscope/ChangeLog b/dev-util/cscope/ChangeLog
index 688b73f975ae..38f671ad75f3 100644
--- a/dev-util/cscope/ChangeLog
+++ b/dev-util/cscope/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/cscope
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cscope/ChangeLog,v 1.30 2004/10/11 14:50:24 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cscope/ChangeLog,v 1.31 2004/11/18 08:57:25 mkennedy Exp $
+
+*cscope-15.5-r1 (18 Nov 2004)
+
+ 18 Nov 2004; Matthew Kenendy <mkennedy@gentoo.org>
+ +files/15.5-noclobber-tempfile-rexotec.patch, +cscope-15.5-r1.ebuild:
+ Resolves Bug #71595: race condition on temporary file; Correct webscope
+ installation path.
11 Oct 2004; Ciaran McCreesh <ciaranm@gentoo.org> -cscope-15.3.ebuild,
-cscope-15.4-r1.ebuild, -cscope-15.4.ebuild:
diff --git a/dev-util/cscope/Manifest b/dev-util/cscope/Manifest
index 6b47065869e1..e88ef48b06d8 100644
--- a/dev-util/cscope/Manifest
+++ b/dev-util/cscope/Manifest
@@ -1,15 +1,8 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 869061a38def437a61db9ba85c261cf0 ChangeLog 4126
MD5 3c56dcf0da026c9a6ef0e7c204419785 cscope-15.5.ebuild 1417
+MD5 30bec4e6f63e214a702d4fe6f156c29d ChangeLog 4378
MD5 79094d1585cb050b3855fbfe440f22b9 metadata.xml 790
+MD5 bdb27b8f93948afdfc3d67d6bf2762e0 cscope-15.5-r1.ebuild 1599
MD5 28ddc553966bf7045758be324600f5c8 files/50xcscope-gentoo.el 95
MD5 25ad9fe446a7cabf4c482bbe150c7eaa files/digest-cscope-15.5 63
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.6 (GNU/Linux)
-
-iD8DBQFBapy0LLFUmVNQ7rkRAjRYAKCXBxoR8vePI5OAwr5yR2ViSUow6wCgumUa
-MnM03vayzxV/vj21ewD9+wI=
-=g7FI
------END PGP SIGNATURE-----
+MD5 25ad9fe446a7cabf4c482bbe150c7eaa files/digest-cscope-15.5-r1 63
+MD5 22e8d669b78f301c45e9075e2793dfd3 files/15.5-noclobber-tempfile-rexotec.patch 1055
diff --git a/dev-util/cscope/cscope-15.5-r1.ebuild b/dev-util/cscope/cscope-15.5-r1.ebuild
new file mode 100644
index 000000000000..3bf3f058d24b
--- /dev/null
+++ b/dev-util/cscope/cscope-15.5-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cscope/cscope-15.5-r1.ebuild,v 1.1 2004/11/18 08:57:25 mkennedy Exp $
+
+inherit gnuconfig elisp-common eutils
+
+DESCRIPTION="Interactively examine a C program"
+HOMEPAGE="http://cscope.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cscope/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ia64 s390 ppc64"
+IUSE="emacs"
+
+RDEPEND=">=sys-libs/ncurses-5.2"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ sys-devel/bison
+ emacs? ( virtual/emacs )"
+
+SITEFILE=50xcscope-gentoo.el
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # Gentoo Bug #71595, http://www.rexotec.com/advisory/RX171104.html
+ epatch ${FILESDIR}/${PV}-noclobber-tempfile-rexotec.patch || die
+}
+
+src_compile() {
+ gnuconfig_update
+
+ # This fix is no longer needed as of cscope-15.5 which now should
+ # work with bison directly. (04 Feb 2004 agriffis)
+ #sed -i -e "s:={:{:" src/egrep.y
+
+ econf || die
+ make clean || die
+ emake || die
+
+ if use emacs ; then
+ cd ${S}/contrib/xcscope || die
+ elisp-compile *.el || die
+ fi
+}
+
+src_install() {
+ einstall || die
+ dodoc NEWS AUTHORS TODO ChangeLog INSTALL README* || die
+
+ if use emacs ; then
+ cd ${S}/contrib/xcscope || die
+ elisp-install xcscope *.el *.elc || die
+ elisp-site-file-install ${FILESDIR}/${SITEFILE} xcscope || die
+ dobin cscope-indexer || die
+ fi
+ cp -r ${S}/contrib/webcscope ${D}/usr/share/doc/${PF}/ || die
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-util/cscope/files/15.5-noclobber-tempfile-rexotec.patch b/dev-util/cscope/files/15.5-noclobber-tempfile-rexotec.patch
new file mode 100644
index 000000000000..38bd9ec3cd89
--- /dev/null
+++ b/dev-util/cscope/files/15.5-noclobber-tempfile-rexotec.patch
@@ -0,0 +1,31 @@
+diff -Naurp src/build.c src/build.c
+--- src/build.c 2003-03-05 11:43:59.000000000 +0100
++++ src/build.c 2004-11-17 15:01:01.000000000 +0100
+@@ -333,7 +333,7 @@ build(void)
+ (void) fprintf(stderr, "cscope: cannot open file %s\n", reffile);
+ myexit(1);
+ }
+- if (invertedindex == YES && (postings = myfopen(temp1, "wb")) == NULL) {
++ if (invertedindex == YES && (postings = myfopen(temp1, "w+xb")) == NULL) {
+ cannotwrite(temp1);
+ cannotindex();
+ }
+diff -Naurp src_old/display.c src/display.c
+--- src/display.c 2003-09-04 17:54:02.000000000 +0200
++++ src/display.c 2004-11-17 15:01:01.000000000 +0100
+@@ -754,13 +754,13 @@ BOOL
+ writerefsfound(void)
+ {
+ if (refsfound == NULL) {
+- if ((refsfound = myfopen(temp1, "wb")) == NULL) {
++ if ((refsfound = myfopen(temp1, "w+xb")) == NULL) {
+ cannotopen(temp1);
+ return(NO);
+ }
+ } else {
+ (void) fclose(refsfound);
+- if ( (refsfound = myfopen(temp1, "wb")) == NULL) {
++ if ( (refsfound = myfopen(temp1, "w+xb")) == NULL) {
+ postmsg("Cannot reopen temporary file");
+ return(NO);
+ }
diff --git a/dev-util/cscope/files/digest-cscope-15.5-r1 b/dev-util/cscope/files/digest-cscope-15.5-r1
new file mode 100644
index 000000000000..99cb973ef8e3
--- /dev/null
+++ b/dev-util/cscope/files/digest-cscope-15.5-r1
@@ -0,0 +1 @@
+MD5 beb6032a301bb11524aec74bfb5e4840 cscope-15.5.tar.gz 243793