summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2007-01-06 18:30:51 +0000
committerChristian Faulhammer <opfer@gentoo.org>2007-01-06 18:30:51 +0000
commitc5d7ed1a94d80591b533d2bc99e7951c1a9b4e07 (patch)
tree6b717ab843438f5cba9abe646c656e037897bdb6 /dev-util/cscope
parentAdded IUSE=debug, which was dropped when \'inherit debug\' was removed from x... (diff)
downloadgentoo-2-c5d7ed1a94d80591b533d2bc99e7951c1a9b4e07.tar.gz
gentoo-2-c5d7ed1a94d80591b533d2bc99e7951c1a9b4e07.tar.bz2
gentoo-2-c5d7ed1a94d80591b533d2bc99e7951c1a9b4e07.zip
added patch with warning when using web frontend because it may be a security risk, see bug #158831
(Portage version: 2.1.1-r2)
Diffstat (limited to 'dev-util/cscope')
-rw-r--r--dev-util/cscope/ChangeLog9
-rw-r--r--dev-util/cscope/cscope-15.6-r1.ebuild64
-rw-r--r--dev-util/cscope/files/cscope-158831-warning_webscope.patch16
-rw-r--r--dev-util/cscope/files/digest-cscope-15.6-r13
4 files changed, 91 insertions, 1 deletions
diff --git a/dev-util/cscope/ChangeLog b/dev-util/cscope/ChangeLog
index c99e33e83a3d..4eb26d6be898 100644
--- a/dev-util/cscope/ChangeLog
+++ b/dev-util/cscope/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/cscope
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cscope/ChangeLog,v 1.80 2007/01/05 07:51:05 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cscope/ChangeLog,v 1.81 2007/01/06 18:30:51 opfer Exp $
+
+*cscope-15.6-r1 (06 Jan 2007)
+
+ 06 Jan 2007; Christian Faulhammer <opfer@gentoo.org>
+ +files/cscope-158831-warning_webscope.patch, +cscope-15.6-r1.ebuild:
+ added patch with warning when using web frontend because it may be a
+ security risk, see bug #158831
05 Jan 2007; Diego Pettenò <flameeyes@gentoo.org> cscope-15.5-r6.ebuild,
cscope-15.5.20060927.ebuild, cscope-15.5.20060927-r1.ebuild:
diff --git a/dev-util/cscope/cscope-15.6-r1.ebuild b/dev-util/cscope/cscope-15.6-r1.ebuild
new file mode 100644
index 000000000000..7d077001b308
--- /dev/null
+++ b/dev-util/cscope/cscope-15.6-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cscope/cscope-15.6-r1.ebuild,v 1.1 2007/01/06 18:30:51 opfer Exp $
+
+inherit elisp-common eutils
+
+DESCRIPTION="Interactively examine a C program"
+HOMEPAGE="http://cscope.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cscope/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="emacs"
+
+RDEPEND=">=sys-libs/ncurses-5.2"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ sys-devel/bison
+ >=sys-devel/autoconf-2.60
+ emacs? ( virtual/emacs )"
+
+SITEFILE=50xcscope-gentoo.el
+
+src_unpack() {
+ unpack ${A}
+
+ # warn users of insecure web frontend, see bug #158831
+ epatch "${FILESDIR}/${PN}-158831-warning_webscope.patch"
+}
+
+src_compile() {
+ STRIP="no"
+
+ econf || die
+ make clean || die
+ emake || die
+
+ if use emacs ; then
+ cd "${S}"/contrib/xcscope || die
+ elisp-compile *.el || die
+ fi
+}
+
+src_install() {
+ einstall || die
+ dodoc NEWS AUTHORS TODO ChangeLog INSTALL README* || die
+
+ if use emacs ; then
+ cd ${S}/contrib/xcscope || die
+ elisp-install xcscope *.el *.elc || die
+ elisp-site-file-install ${FILESDIR}/${SITEFILE} xcscope || die
+ dobin cscope-indexer || die
+ fi
+ cp -r ${S}/contrib/webcscope ${D}/usr/share/doc/${PF}/ || die
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-util/cscope/files/cscope-158831-warning_webscope.patch b/dev-util/cscope/files/cscope-158831-warning_webscope.patch
new file mode 100644
index 000000000000..5b2305283349
--- /dev/null
+++ b/dev-util/cscope/files/cscope-158831-warning_webscope.patch
@@ -0,0 +1,16 @@
+--- /tmp/cscope 2007-01-06 19:11:10.000000000 +0100
++++ cscope 2007-01-06 19:15:16.000000000 +0100
+@@ -1,4 +1,4 @@
+-#!/bin/perl
++#!/usr/bin/perl
+
+ # $Id: cscope-158831-warning_webscope.patch,v 1.1 2007/01/06 18:30:51 opfer Exp $
+ #
+@@ -375,6 +375,7 @@
+ print &HtmlTop ("Web-CScope");
+
+ print <<ENDOFTEXTA;
++<p style="color:red">Be aware that this webfrontend is insecure and allows viewing ALL apache readable files, including your configuration!</p>
+ Select an operation below and enter a symbol, function or text to search in
+ the database. The active version is $version. Input is case-sensitive,
+ so if your search returns no results, check the case and the symbol name.<hr>
diff --git a/dev-util/cscope/files/digest-cscope-15.6-r1 b/dev-util/cscope/files/digest-cscope-15.6-r1
new file mode 100644
index 000000000000..01c0b5205907
--- /dev/null
+++ b/dev-util/cscope/files/digest-cscope-15.6-r1
@@ -0,0 +1,3 @@
+MD5 db87833f90d8267b1fc0c419cfc4d219 cscope-15.6.tar.gz 391223
+RMD160 b93238d3c91782d032e028abcfde3c2a7491a9c9 cscope-15.6.tar.gz 391223
+SHA256 6d6461ef402a1d6e42e1cd40e7524c4ed19e79eacef1d83ba4ed680f7bcac5ca cscope-15.6.tar.gz 391223