summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-05-02 10:01:04 +0000
committerUlrich Müller <ulm@gentoo.org>2009-05-02 10:01:04 +0000
commit3b325cbfed176c343e738e700f4d1417ea147b09 (patch)
treeafd82ba6e49083353975f4970e5fd256cc97a5e3 /dev-util/cscope
parentFix dependencies (diff)
downloadgentoo-2-3b325cbfed176c343e738e700f4d1417ea147b09.tar.gz
gentoo-2-3b325cbfed176c343e738e700f4d1417ea147b09.tar.bz2
gentoo-2-3b325cbfed176c343e738e700f4d1417ea147b09.zip
Version bump for security bug 263023.
(Portage version: 2.2_rc31/cvs/Linux i686)
Diffstat (limited to 'dev-util/cscope')
-rw-r--r--dev-util/cscope/ChangeLog9
-rw-r--r--dev-util/cscope/cscope-15.7a.ebuild61
2 files changed, 68 insertions, 2 deletions
diff --git a/dev-util/cscope/ChangeLog b/dev-util/cscope/ChangeLog
index c9fe93c7c125..08d7647cc2a7 100644
--- a/dev-util/cscope/ChangeLog
+++ b/dev-util/cscope/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/cscope
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cscope/ChangeLog,v 1.109 2009/04/14 16:38:47 jer Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cscope/ChangeLog,v 1.110 2009/05/02 10:01:04 ulm Exp $
+
+*cscope-15.7a (02 May 2009)
+
+ 02 May 2009; Ulrich Mueller <ulm@gentoo.org> +cscope-15.7a.ebuild:
+ Version bump for security bug 263023.
14 Apr 2009; Jeroen Roovers <jer@gentoo.org> cscope-15.7.ebuild:
Stable for HPPA (bug #264509).
diff --git a/dev-util/cscope/cscope-15.7a.ebuild b/dev-util/cscope/cscope-15.7a.ebuild
new file mode 100644
index 000000000000..9806cacf8791
--- /dev/null
+++ b/dev-util/cscope/cscope-15.7a.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cscope/cscope-15.7a.ebuild,v 1.1 2009/05/02 10:01:04 ulm Exp $
+
+inherit elisp-common eutils
+
+DESCRIPTION="Interactively examine a C program"
+HOMEPAGE="http://cscope.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cscope/${P}.tar.bz2"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="emacs"
+
+RDEPEND=">=sys-libs/ncurses-5.2"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ sys-devel/bison
+ >=sys-devel/autoconf-2.60
+ emacs? ( virtual/emacs )"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ STRIP="no"
+
+ econf || die "econf failed"
+ make clean || die "make clean failed"
+ emake || die "emake failed"
+
+ if use emacs ; then
+ cd "${S}"/contrib/xcscope || die
+ elisp-compile *.el || die
+ fi
+}
+
+src_install() {
+ einstall || die "einstall failed"
+ dodoc AUTHORS ChangeLog NEWS README* TODO || die "dodoc failed"
+
+ if use emacs ; then
+ cd "${S}"/contrib/xcscope || die
+ elisp-install ${PN} *.el *.elc || die
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ dobin cscope-indexer || die "dobin failed"
+ fi
+
+ cd "${S}"/contrib/webcscope || die
+ docinto webcscope
+ dodoc INSTALL TODO cgi-lib.pl cscope hilite.c || die "dodoc failed"
+ insinto /usr/share/doc/${PF}/webcscope/icons; doins icons/*.gif
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}