summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2013-11-15 09:16:19 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2013-11-15 09:16:19 +0000
commit95aac7ae4cc4260900444eebea2ebd5271dfeb62 (patch)
tree5566b41432129482f8f45c9b1406070c1e8e9889 /dev-util/cppunit
parentRemove old (diff)
downloadgentoo-2-95aac7ae4cc4260900444eebea2ebd5271dfeb62.tar.gz
gentoo-2-95aac7ae4cc4260900444eebea2ebd5271dfeb62.tar.bz2
gentoo-2-95aac7ae4cc4260900444eebea2ebd5271dfeb62.zip
Version bump to latest cppunit fixes dll checking and few other trivs.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 8EEE3BE8)
Diffstat (limited to 'dev-util/cppunit')
-rw-r--r--dev-util/cppunit/ChangeLog8
-rw-r--r--dev-util/cppunit/cppunit-1.13.2.ebuild (renamed from dev-util/cppunit/cppunit-1.13.0.ebuild)24
-rw-r--r--dev-util/cppunit/cppunit-9999.ebuild8
3 files changed, 30 insertions, 10 deletions
diff --git a/dev-util/cppunit/ChangeLog b/dev-util/cppunit/ChangeLog
index 252eafbef69d..462f6c46f38e 100644
--- a/dev-util/cppunit/ChangeLog
+++ b/dev-util/cppunit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/cppunit
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cppunit/ChangeLog,v 1.90 2013/11/14 07:02:50 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cppunit/ChangeLog,v 1.91 2013/11/15 09:16:19 scarabeus Exp $
+
+*cppunit-1.13.2 (15 Nov 2013)
+
+ 15 Nov 2013; Tomáš Chvátal <scarabeus@gentoo.org> +cppunit-1.13.2.ebuild,
+ -cppunit-1.13.0.ebuild, cppunit-9999.ebuild:
+ Version bump to latest cppunit fixes dll checking and few other trivs.
14 Nov 2013; Matt Turner <mattst88@gentoo.org> cppunit-9999.ebuild:
Drop -O0 CFLAG replacement on alpha.
diff --git a/dev-util/cppunit/cppunit-1.13.0.ebuild b/dev-util/cppunit/cppunit-1.13.2.ebuild
index dedda3a3900a..f67158fe8f8b 100644
--- a/dev-util/cppunit/cppunit-1.13.0.ebuild
+++ b/dev-util/cppunit/cppunit-1.13.2.ebuild
@@ -1,28 +1,37 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cppunit/cppunit-1.13.0.ebuild,v 1.9 2013/06/17 07:38:23 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cppunit/cppunit-1.13.2.ebuild,v 1.1 2013/11/15 09:16:19 scarabeus Exp $
-EAPI=4
+EAPI=5
+EGIT_REPO_URI="git://anongit.freedesktop.org/libreoffice/cppunit"
+[[ ${PV} = 9999 ]] && inherit git-2 autotools
inherit eutils flag-o-matic
DESCRIPTION="C++ port of the famous JUnit framework for unit testing"
HOMEPAGE="http://www.freedesktop.org/wiki/Software/cppunit"
-SRC_URI="http://dev-www.libreoffice.org/src/${P}.tar.gz"
+[[ ${PV} = 9999 ]] || SRC_URI="http://dev-www.libreoffice.org/src/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+# Don't move KEYWORDS on the previous line or ekeyword won't work # 399061
+[[ ${PV} = 9999 ]] || \
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="doc examples static-libs"
RDEPEND=""
DEPEND="${RDEPEND}
doc? (
- app-doc/doxygen
+ app-doc/doxygen[dot]
media-gfx/graphviz
)"
-DOCS=( AUTHORS ChangeLog BUGS NEWS README THANKS TODO doc/FAQ )
+DOCS=( AUTHORS BUGS NEWS README THANKS TODO doc/FAQ )
+[[ ${PV} = 9999 ]] || DOCS+=( ChangeLog )
+
+src_prepare() {
+ [[ ${PV} = 9999 ]] && eautoreconf
+}
src_configure() {
# Anything else than -O0 breaks on alpha
@@ -32,6 +41,7 @@ src_configure() {
$(use_enable static-libs static) \
$(use_enable doc doxygen) \
$(use_enable doc dot) \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
--htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
--disable-silent-rules
}
@@ -39,7 +49,7 @@ src_configure() {
src_install() {
default
- find "${ED}" -name '*.la' -exec rm -f {} +
+ prune_libtool_files --all
if use examples ; then
find examples -iname "*.o" -delete
diff --git a/dev-util/cppunit/cppunit-9999.ebuild b/dev-util/cppunit/cppunit-9999.ebuild
index 4fc70d590060..49b13efb9147 100644
--- a/dev-util/cppunit/cppunit-9999.ebuild
+++ b/dev-util/cppunit/cppunit-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cppunit/cppunit-9999.ebuild,v 1.5 2013/11/14 07:02:50 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cppunit/cppunit-9999.ebuild,v 1.6 2013/11/15 09:16:19 scarabeus Exp $
EAPI=5
@@ -34,12 +34,16 @@ src_prepare() {
}
src_configure() {
+ # Anything else than -O0 breaks on alpha
+ use alpha && replace-flags "-O?" -O0
+
econf \
$(use_enable static-libs static) \
$(use_enable doc doxygen) \
$(use_enable doc dot) \
--docdir="${EPREFIX}"/usr/share/doc/${PF} \
- --htmldir="${EPREFIX}"/usr/share/doc/${PF}/html
+ --htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
+ --disable-silent-rules
}
src_install() {