summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2011-04-10 03:05:55 +0000
committerJonathan Callen <abcd@gentoo.org>2011-04-10 03:05:55 +0000
commit905a1bbd7975ba2b5b3407543a019e88e8d8aba7 (patch)
tree9726b90432591f2c88002dfe03d6094b0c8cabf7 /dev-util/colorgcc
parentAdd prefix support, bump EAPI to 3, add prefix keywords (diff)
downloadgentoo-2-905a1bbd7975ba2b5b3407543a019e88e8d8aba7.tar.gz
gentoo-2-905a1bbd7975ba2b5b3407543a019e88e8d8aba7.tar.bz2
gentoo-2-905a1bbd7975ba2b5b3407543a019e88e8d8aba7.zip
Add prefix support, bump EAPI to 3, add prefix keywords
(Portage version: 2.2.0_alpha29_p11/cvs/Linux i686)
Diffstat (limited to 'dev-util/colorgcc')
-rw-r--r--dev-util/colorgcc/ChangeLog5
-rw-r--r--dev-util/colorgcc/colorgcc-1.3.2-r5.ebuild13
2 files changed, 11 insertions, 7 deletions
diff --git a/dev-util/colorgcc/ChangeLog b/dev-util/colorgcc/ChangeLog
index f9d9f720bddf..f618608a0f45 100644
--- a/dev-util/colorgcc/ChangeLog
+++ b/dev-util/colorgcc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-util/colorgcc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/colorgcc/ChangeLog,v 1.28 2011/01/06 16:47:34 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/colorgcc/ChangeLog,v 1.29 2011/04/10 03:05:55 abcd Exp $
+
+ 10 Apr 2011; Jonathan Callen <abcd@gentoo.org> colorgcc-1.3.2-r5.ebuild:
+ Add prefix support, bump EAPI to 3, add prefix keywords
06 Jan 2011; Justin Lecher <jlec@gentoo.org> colorgcc-1.3.2-r4.ebuild,
colorgcc-1.3.2-r5.ebuild:
diff --git a/dev-util/colorgcc/colorgcc-1.3.2-r5.ebuild b/dev-util/colorgcc/colorgcc-1.3.2-r5.ebuild
index 73a186e3e8cc..d8644801778a 100644
--- a/dev-util/colorgcc/colorgcc-1.3.2-r5.ebuild
+++ b/dev-util/colorgcc/colorgcc-1.3.2-r5.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/colorgcc/colorgcc-1.3.2-r5.ebuild,v 1.3 2011/01/06 16:48:22 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/colorgcc/colorgcc-1.3.2-r5.ebuild,v 1.4 2011/04/10 03:05:55 abcd Exp $
+EAPI=3
inherit eutils
DESCRIPTION="Adds color to gcc output"
@@ -10,21 +11,21 @@ SRC_URI="mirror://gentoo/${P}.tar.gz"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE=""
DEPEND="dev-lang/perl"
RDEPEND="${DEPEND}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch \
"${FILESDIR}"/${P}-gentoo-one.patch \
"${FILESDIR}"/${P}-gentoo-two.patch \
"${FILESDIR}"/${P}-note.patch
}
+src_configure() { :; }
+
src_compile() { :; }
src_install() {
@@ -60,5 +61,5 @@ pkg_postinst() {
echo
# portage won't delete the old symlinks for users that are upgrading
# because the old symlinks still point to /usr/bin/colorgcc which exists...
- [ -d "${ROOT}"/usr/bin/wrappers ] && rm -fr "${ROOT}"/usr/bin/wrappers
+ [ -d "${EROOT}"/usr/bin/wrappers ] && rm -fr "${EROOT}"/usr/bin/wrappers
}