summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando J. Pereda <ferdy@gentoo.org>2006-05-05 06:57:11 +0000
committerFernando J. Pereda <ferdy@gentoo.org>2006-05-05 06:57:11 +0000
commit716b29e3a4cf82f1d28a7ea9c873c2d2035566c8 (patch)
tree0554adaacc1a52402c51a9a3974dbfe154a6c1e2 /dev-util/cogito
parentFix for gcc-4.1 (diff)
downloadgentoo-2-716b29e3a4cf82f1d28a7ea9c873c2d2035566c8.tar.gz
gentoo-2-716b29e3a4cf82f1d28a7ea9c873c2d2035566c8.tar.bz2
gentoo-2-716b29e3a4cf82f1d28a7ea9c873c2d2035566c8.zip
New upstream version.
(Portage version: 2203-svn)
Diffstat (limited to 'dev-util/cogito')
-rw-r--r--dev-util/cogito/ChangeLog8
-rw-r--r--dev-util/cogito/Manifest3
-rw-r--r--dev-util/cogito/cogito-0.17.2.ebuild59
-rw-r--r--dev-util/cogito/files/cogito-test-fix-0.17.2.patch25
-rw-r--r--dev-util/cogito/files/digest-cogito-0.17.22
5 files changed, 96 insertions, 1 deletions
diff --git a/dev-util/cogito/ChangeLog b/dev-util/cogito/ChangeLog
index 6c656a7c1ea4..59e4d6507345 100644
--- a/dev-util/cogito/ChangeLog
+++ b/dev-util/cogito/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/cogito
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cogito/ChangeLog,v 1.36 2006/03/20 09:21:09 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cogito/ChangeLog,v 1.37 2006/05/05 06:57:11 ferdy Exp $
+
+*cogito-0.17.2 (05 May 2006)
+
+ 05 May 2006; Fernando J. Pereda <ferdy@gentoo.org>
+ +files/cogito-test-fix-0.17.2.patch, +cogito-0.17.2.ebuild:
+ New upstream version.
20 Mar 2006; Markus Rothe <corsair@gentoo.org> cogito-0.16.4.ebuild:
Stable on ppc64
diff --git a/dev-util/cogito/Manifest b/dev-util/cogito/Manifest
index 45b3f16e5e2f..f2dd9903d7d8 100644
--- a/dev-util/cogito/Manifest
+++ b/dev-util/cogito/Manifest
@@ -1,8 +1,11 @@
MD5 d2e8f270d5e335b7614dc21ee6cea1cc ChangeLog 5201
MD5 d13cf5e2e705b821a491c6b87b8350f9 cogito-0.16.2.ebuild 1376
MD5 1d39d2eefa4b7ca29704a3440306754a cogito-0.16.4.ebuild 1380
+MD5 2168bb46eddf0097f32ed4c592d5a605 cogito-0.17.2.ebuild 1410
MD5 8ef6037403f61a16fb9f4d630fc55438 cogito-0.17.ebuild 1382
+MD5 4031a3ab922981d0a804a4f1f7c19d41 files/cogito-test-fix-0.17.2.patch 805
MD5 c82decb331106478b2376c484e35456d files/digest-cogito-0.16.2 65
MD5 1f23887eed821c21d22e41b3581299ac files/digest-cogito-0.16.4 65
MD5 94cd21dd91172d27497c7e7dfabfac50 files/digest-cogito-0.17 63
+MD5 636476a44311285df64df1522b92aa95 files/digest-cogito-0.17.2 134
MD5 263b796501be2aea2d5fb2ebc7609cb5 metadata.xml 313
diff --git a/dev-util/cogito/cogito-0.17.2.ebuild b/dev-util/cogito/cogito-0.17.2.ebuild
new file mode 100644
index 000000000000..14d3c978218e
--- /dev/null
+++ b/dev-util/cogito/cogito-0.17.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cogito/cogito-0.17.2.ebuild,v 1.1 2006/05/05 06:57:11 ferdy Exp $
+
+inherit eutils
+
+MY_PV=${PV//_/}
+
+DESCRIPTION="The GIT scripted toolkit"
+HOMEPAGE="http://kernel.org/pub/software/scm/cogito/"
+SRC_URI="http://kernel.org/pub/software/scm/cogito/${PN}-${MY_PV}.tar.bz2
+ mirror://gentoo/${PN}-doc-${MY_PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-libs/openssl
+ sys-libs/zlib
+ >=dev-util/git-1.2.0"
+
+RDEPEND="net-misc/rsync
+ app-text/rcs
+ net-misc/curl"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+SDOC=${WORKDIR}/${PN}-doc-${MY_PV}
+
+src_unpack() {
+ unpack ${A} ; cd "${S}"
+
+ # t9300-seek won't work under the sandbox
+ rm t/t9300-seek.sh
+
+ epatch "${FILESDIR}"/${PN}-test-fix-${MY_PV}.patch
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" prefix="/usr" || die "install failed"
+ dodoc README* VERSION COPYING
+
+ doman "${SDOC}"/man?/*
+
+ dodir /usr/share/doc/${PF}/{,html,contrib}
+ cp "${SDOC}"/html/* "${D}"/usr/share/doc/${PF}/html
+ cp "${S}"/contrib/* "${D}"/usr/share/doc/${PF}/contrib
+}
+
+src_test() {
+ # 'make test' from the root runs the tutorial-script which executes
+ # other commands such as 'gpg' and creates stuff in portage's $HOME.
+ cd "${S}"
+ make -C t/
+}
diff --git a/dev-util/cogito/files/cogito-test-fix-0.17.2.patch b/dev-util/cogito/files/cogito-test-fix-0.17.2.patch
new file mode 100644
index 000000000000..a59c57f52661
--- /dev/null
+++ b/dev-util/cogito/files/cogito-test-fix-0.17.2.patch
@@ -0,0 +1,25 @@
+diff --git a/Documentation/tutorial-script/script.sh b/Documentation/tutorial-script/script.sh
+index f07dfc1..5b7fc6d 100755
+--- a/Documentation/tutorial-script/script.sh
++++ b/Documentation/tutorial-script/script.sh
+@@ -30,6 +30,7 @@ trap 'echo >&2 "Unexpected error $? on l
+
+ ### Set up playground
+ sh 0000-playground.sh
++export PATH=$(pwd)/../..:$PATH # Use the local Cogito version
+ TOP=$(pwd)
+ ALICE=$TOP/Playground/Alice
+ BOB=$TOP/Playground/Bob
+diff --git a/t/test-lib.sh b/t/test-lib.sh
+index f97f8eb..5c2cb72 100755
+--- a/t/test-lib.sh
++++ b/t/test-lib.sh
+@@ -142,7 +142,7 @@ test_done () {
+
+ # Test the binaries we have just built. The tests are kept in
+ # t/ subdirectory and are run in trash subdirectory.
+-PATH=$(pwd)/..:$PATH
++export PATH=$(pwd)/..:$PATH
+
+ # Test repository
+ test=trash
diff --git a/dev-util/cogito/files/digest-cogito-0.17.2 b/dev-util/cogito/files/digest-cogito-0.17.2
new file mode 100644
index 000000000000..b58a366ca9d6
--- /dev/null
+++ b/dev-util/cogito/files/digest-cogito-0.17.2
@@ -0,0 +1,2 @@
+MD5 bdaa2dfc22f7fc561eb7a4a24aedf2e9 cogito-0.17.2.tar.bz2 95514
+MD5 ff19bcea784fbfa0152ba8c5b26e83be cogito-doc-0.17.2.tar.bz2 52986