summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJurek Bartuszek <jurek@gentoo.org>2007-12-15 12:26:30 +0000
committerJurek Bartuszek <jurek@gentoo.org>2007-12-15 12:26:30 +0000
commitd6f522bcd9adf54d688200d9c8b986c853f4da8e (patch)
tree21892498f9161c77811e97288a356e1733c190bb /dev-util/codeblocks
parentAdded >=dev-util/codeblocks-1.0_pre20071215 to package.mask (diff)
downloadgentoo-2-d6f522bcd9adf54d688200d9c8b986c853f4da8e.tar.gz
gentoo-2-d6f522bcd9adf54d688200d9c8b986c853f4da8e.tar.bz2
gentoo-2-d6f522bcd9adf54d688200d9c8b986c853f4da8e.zip
dev-util/codeblocks-1.0_pre20071215: version bump
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-util/codeblocks')
-rw-r--r--dev-util/codeblocks/codeblocks-1.0_pre20071215.ebuild60
-rw-r--r--dev-util/codeblocks/files/digest-codeblocks-1.0_pre200712153
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-util/codeblocks/codeblocks-1.0_pre20071215.ebuild b/dev-util/codeblocks/codeblocks-1.0_pre20071215.ebuild
new file mode 100644
index 000000000000..e8e63117c8e1
--- /dev/null
+++ b/dev-util/codeblocks/codeblocks-1.0_pre20071215.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/codeblocks/codeblocks-1.0_pre20071215.ebuild,v 1.1 2007/12/15 12:26:29 jurek Exp $
+
+inherit eutils autotools wxwidgets
+
+#needed for wxwidgets.eclass
+WX_GTK_VER="2.8"
+
+DESCRIPTION="Code::Blocks - a free cross-platform C/C++ IDE"
+HOMEPAGE="http://www.codeblocks.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="unicode contrib debug"
+
+RDEPEND="=x11-libs/wxGTK-${WX_GTK_VER}*"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/autoconf-2.5
+ >=sys-devel/automake-1.7
+ >=sys-devel/libtool-1.4
+ app-arch/zip"
+
+pkg_setup() {
+ if use unicode; then
+ #check for gtk2-unicode
+ need-wxwidgets unicode
+ else
+ #check for gtk2-ansi
+ need-wxwidgets gtk2
+ fi
+}
+
+src_compile() {
+ export WANT_AUTOCONF=2.5
+ export WANT_AUTOMAKE=1.7
+
+ local TMP
+
+ TMP="/usr/share/aclocal/libtool.m4"
+ einfo "Running ./bootstrap"
+ if [ -e "$TMP" ]; then
+ cp "$TMP" aclocal.m4 || die "cp failed"
+ fi
+ ./bootstrap || die "boostrap failed"
+
+ econf --with-wx-config="${WX_CONFIG}" \
+ $(use_enable contrib) \
+ $(use_enable debug) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "make install failed"
+}
diff --git a/dev-util/codeblocks/files/digest-codeblocks-1.0_pre20071215 b/dev-util/codeblocks/files/digest-codeblocks-1.0_pre20071215
new file mode 100644
index 000000000000..21cfaf6eccd7
--- /dev/null
+++ b/dev-util/codeblocks/files/digest-codeblocks-1.0_pre20071215
@@ -0,0 +1,3 @@
+MD5 11ffdccfcbd558d4641206836ad2395a codeblocks-1.0_pre20071215.tar.bz2 11131352
+RMD160 e8a43ff768512b79072c53d276cbe37badfe07bb codeblocks-1.0_pre20071215.tar.bz2 11131352
+SHA256 66f42142675ca80f5e50717aa9cb46ba2dc5bd8a1d4e8d1259514a64b9a67e9e codeblocks-1.0_pre20071215.tar.bz2 11131352