summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2011-05-09 21:14:09 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2011-05-09 21:14:09 +0000
commitbc208fe2f12e441c4bfa4381207cdf53da7f55cb (patch)
tree4d2c4382cf367db104d3a6ce19d06a62f42792cd /dev-util/coccinelle
parentInitial version. Draw pretty sequence diagrams of D-Bus traffic. Ebuild provi... (diff)
downloadgentoo-2-bc208fe2f12e441c4bfa4381207cdf53da7f55cb.tar.gz
gentoo-2-bc208fe2f12e441c4bfa4381207cdf53da7f55cb.tar.bz2
gentoo-2-bc208fe2f12e441c4bfa4381207cdf53da7f55cb.zip
Fixed missing runtime depend on findlib as found out Jakub Zawadzki in bug #366553. Added USE=ocaml for ocaml scripting support.
(Portage version: 2.1.9.48/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/coccinelle')
-rw-r--r--dev-util/coccinelle/ChangeLog9
-rw-r--r--dev-util/coccinelle/coccinelle-0.2.5-r1.ebuild (renamed from dev-util/coccinelle/coccinelle-0.2.5.ebuild)14
2 files changed, 18 insertions, 5 deletions
diff --git a/dev-util/coccinelle/ChangeLog b/dev-util/coccinelle/ChangeLog
index 146d1f93da84..cbb49a02e3fa 100644
--- a/dev-util/coccinelle/ChangeLog
+++ b/dev-util/coccinelle/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/coccinelle
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/coccinelle/ChangeLog,v 1.6 2011/05/08 21:09:48 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/coccinelle/ChangeLog,v 1.7 2011/05/09 21:14:09 slyfox Exp $
+
+*coccinelle-0.2.5-r1 (09 May 2011)
+
+ 09 May 2011; Sergei Trofimovich <slyfox@gentoo.org> -coccinelle-0.2.5.ebuild,
+ +coccinelle-0.2.5-r1.ebuild:
+ Fixed missing runtime depend on findlib as found out Jakub Zawadzki in bug
+ #366553. Added USE=ocaml for ocaml scripting support.
*coccinelle-0.2.5 (08 May 2011)
diff --git a/dev-util/coccinelle/coccinelle-0.2.5.ebuild b/dev-util/coccinelle/coccinelle-0.2.5-r1.ebuild
index 5e578266b3aa..be3a5e7bffc7 100644
--- a/dev-util/coccinelle/coccinelle-0.2.5.ebuild
+++ b/dev-util/coccinelle/coccinelle-0.2.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/coccinelle/coccinelle-0.2.5.ebuild,v 1.1 2011/05/08 21:09:48 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/coccinelle/coccinelle-0.2.5-r1.ebuild,v 1.1 2011/05/09 21:14:09 slyfox Exp $
EAPI="2"
@@ -13,13 +13,18 @@ SRC_URI="http://coccinelle.lip6.fr/distrib/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="doc +ocamlopt python"
+IUSE="doc +ocamlopt python ocaml"
+# ocaml enables ocaml scripting (uses findlib)
RDEPEND="python? ( dev-lang/python )
- >=dev-lang/ocaml-3.10[ocamlopt?]"
+ >=dev-lang/ocaml-3.10[ocamlopt?]
+ ocaml? ( dev-ml/findlib )"
+
+# dev-texlive/texlive-fontsextra contains 'ifsym.sty'
DEPEND="${RDEPEND}
doc? ( virtual/latex-base
- || ( dev-texlive/texlive-latexextra app-text/ptex ) )"
+ || ( dev-texlive/texlive-latexextra app-text/ptex )
+ dev-texlive/texlive-fontsextra )"
src_configure() {
# non-autoconf
@@ -27,6 +32,7 @@ src_configure() {
--prefix=/usr \
$(use ocamlopt || echo "--no-opt") \
$(use_with python) \
+ $(use_with ocaml) \
|| die
sed -i "s:^LIBDIR=.*:LIBDIR=/usr/$(get_libdir)/ocaml/stublibs/:" Makefile.config
sed -i "s:^SHAREDIR=.*:SHAREDIR=/usr/libexec/${PN}/:" Makefile.config