summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-04-24 05:58:22 +0000
committerTim Harder <radhermit@gentoo.org>2013-04-24 05:58:22 +0000
commitb7de600e9f41da9cc4a4146809ad51f0554dfa37 (patch)
treec0ada7d7396d0cfa5e0973e0c0519ae11835a95d /dev-util/coccinelle
parentFix -Wp,MMD test failure with gcc-4.8 and correct patch name. (diff)
downloadgentoo-2-b7de600e9f41da9cc4a4146809ad51f0554dfa37.tar.gz
gentoo-2-b7de600e9f41da9cc4a4146809ad51f0554dfa37.tar.bz2
gentoo-2-b7de600e9f41da9cc4a4146809ad51f0554dfa37.zip
Version bump, migrate to python-single-r1.
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-util/coccinelle')
-rw-r--r--dev-util/coccinelle/ChangeLog9
-rw-r--r--dev-util/coccinelle/coccinelle-1.0.0_rc17.ebuild129
2 files changed, 136 insertions, 2 deletions
diff --git a/dev-util/coccinelle/ChangeLog b/dev-util/coccinelle/ChangeLog
index 700866738b19..5e41791dc643 100644
--- a/dev-util/coccinelle/ChangeLog
+++ b/dev-util/coccinelle/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/coccinelle
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/coccinelle/ChangeLog,v 1.27 2012/12/13 22:12:25 radhermit Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/coccinelle/ChangeLog,v 1.28 2013/04/24 05:58:22 radhermit Exp $
+
+*coccinelle-1.0.0_rc17 (24 Apr 2013)
+
+ 24 Apr 2013; Tim Harder <radhermit@gentoo.org> +coccinelle-1.0.0_rc17.ebuild:
+ Version bump, migrate to python-single-r1.
13 Dec 2012; Tim Harder <radhermit@gentoo.org> -coccinelle-1.0.0_rc14.ebuild,
-coccinelle-1.0.0_rc15.ebuild:
diff --git a/dev-util/coccinelle/coccinelle-1.0.0_rc17.ebuild b/dev-util/coccinelle/coccinelle-1.0.0_rc17.ebuild
new file mode 100644
index 000000000000..f9b3afd3f4d8
--- /dev/null
+++ b/dev-util/coccinelle/coccinelle-1.0.0_rc17.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/coccinelle/coccinelle-1.0.0_rc17.ebuild,v 1.1 2013/04/24 05:58:22 radhermit Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+inherit multilib eutils python-single-r1 bash-completion-r1 elisp-common autotools
+
+MY_P="${P/_/-}"
+DESCRIPTION="Program matching and transformation engine"
+HOMEPAGE="http://coccinelle.lip6.fr/"
+SRC_URI="http://coccinelle.lip6.fr/distrib/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc emacs ocaml +ocamlopt pcre python test vim-syntax"
+
+# ocaml enables ocaml scripting (uses findlib)
+CDEPEND=">=dev-lang/ocaml-3.10[ocamlopt?]
+ dev-ml/sexplib
+ emacs? ( virtual/emacs )
+ ocaml? ( dev-ml/findlib )
+ pcre? ( dev-ml/pcre-ocaml )
+ python? ( ${PYTHON_DEPS} )"
+
+RDEPEND="${CDEPEND}
+ vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )"
+
+# dev-texlive/texlive-fontsextra contains 'ifsym.sty'
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ doc? (
+ virtual/latex-base
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-fontsextra
+ )"
+
+REQUIRED_USE="test? ( ocaml python )"
+
+DOCS=( authors.txt bugs.txt changes.txt credits.txt readme.txt )
+
+S=${WORKDIR}/${MY_P}
+
+SITEFILE=50coccinelle-gentoo.el
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ if use python ; then
+ # fix python install location
+ sed -e "s:\$(SHAREDIR)/python:$(python_get_sitedir):" \
+ -e "s:PYTHON_TARGET:PYTHON_INSTALL_TARGET:" \
+ -i Makefile || die
+ fi
+
+ sed -i "s:^SHAREDIR=.*:SHAREDIR=/usr/$(get_libdir)/ocaml/${PN}/:" scripts/spatch.sh.in || die
+
+ epatch "${FILESDIR}"/${PN}-1.0.0_rc16-findtool.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable python) \
+ $(use_enable ocaml) \
+ $(use_enable pcre) \
+ $(use_enable pcre pcre-syntax)
+
+ sed -e "s:^LIBDIR=.*:LIBDIR=/usr/$(get_libdir)/ocaml/stublibs/:" \
+ -e "s:^SHAREDIR=.*:SHAREDIR=/usr/$(get_libdir)/ocaml/${PN}/:" \
+ -i Makefile.config || die
+}
+
+src_compile() {
+ emake depend
+ emake
+
+ use ocamlopt && emake opt
+
+ if use doc ; then
+ VARTEXFONTS="${T}"/fonts emake docs
+ fi
+
+ if use emacs ; then
+ elisp-compile editors/emacs/cocci.el || die
+ fi
+}
+
+src_test() {
+ source env.sh # needed for built in-place python plugin
+ ./spatch standard.h -parse_c -dir tests/ || die
+ yes | ./spatch -iso_file standard.iso -macro_file_builtins standard.h -testall || die
+ if use ocamlopt ; then
+ ./spatch.opt -iso_file standard.iso -macro_file_builtins standard.h -testall || die
+ fi
+}
+
+src_install() {
+ default
+
+ use doc && dodoc docs/manual/*.pdf
+ newbashcomp scripts/spatch.bash_completion spatch
+
+ if use emacs ; then
+ elisp-install ${PN} editors/emacs/*
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+ fi
+
+ if use vim-syntax ; then
+ newdoc editors/vim/README README-vim
+ rm editors/vim/README || die
+ insinto /usr/share/vim/vimfiles
+ doins -r editors/vim/*
+ fi
+
+ export STRIP_MASK='*/coccinelle/spatch'
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}