summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-06-26 19:45:57 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-06-26 19:45:57 +0000
commitb6be1bc596710b5740efe40acd2066c7a023497a (patch)
treecfdd743dad71c079990c641901c59bc4a9444a32 /dev-util/coccinelle
parentSync sitefile support from elisp-common.eclass. XEmacs can now use the same m... (diff)
downloadgentoo-2-b6be1bc596710b5740efe40acd2066c7a023497a.tar.gz
gentoo-2-b6be1bc596710b5740efe40acd2066c7a023497a.tar.bz2
gentoo-2-b6be1bc596710b5740efe40acd2066c7a023497a.zip
it depends on sexplib, not keyworded on x86, drop keywords
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/coccinelle')
-rw-r--r--dev-util/coccinelle/ChangeLog8
-rw-r--r--dev-util/coccinelle/coccinelle-0.2.5-r2.ebuild68
2 files changed, 75 insertions, 1 deletions
diff --git a/dev-util/coccinelle/ChangeLog b/dev-util/coccinelle/ChangeLog
index cbb49a02e3fa..0dca82f9b430 100644
--- a/dev-util/coccinelle/ChangeLog
+++ b/dev-util/coccinelle/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/coccinelle
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/coccinelle/ChangeLog,v 1.7 2011/05/09 21:14:09 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/coccinelle/ChangeLog,v 1.8 2011/06/26 19:45:57 aballier Exp $
+
+*coccinelle-0.2.5-r2 (26 Jun 2011)
+
+ 26 Jun 2011; Alexis Ballier <aballier@gentoo.org>
+ +coccinelle-0.2.5-r2.ebuild:
+ it depends on sexplib, not keyworded on x86, drop keywords
*coccinelle-0.2.5-r1 (09 May 2011)
diff --git a/dev-util/coccinelle/coccinelle-0.2.5-r2.ebuild b/dev-util/coccinelle/coccinelle-0.2.5-r2.ebuild
new file mode 100644
index 000000000000..12375a323e3d
--- /dev/null
+++ b/dev-util/coccinelle/coccinelle-0.2.5-r2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/coccinelle/coccinelle-0.2.5-r2.ebuild,v 1.1 2011/06/26 19:45:57 aballier Exp $
+
+EAPI="2"
+
+inherit multilib
+
+DESCRIPTION="Program matching and transformation engine"
+HOMEPAGE="http://coccinelle.lip6.fr/"
+SRC_URI="http://coccinelle.lip6.fr/distrib/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc +ocamlopt python ocaml"
+
+# ocaml enables ocaml scripting (uses findlib)
+RDEPEND="python? ( dev-lang/python )
+ >=dev-lang/ocaml-3.10[ocamlopt?]
+ dev-ml/sexplib
+ ocaml? ( dev-ml/findlib )"
+
+# dev-texlive/texlive-fontsextra contains 'ifsym.sty'
+DEPEND="${RDEPEND}
+ doc? ( virtual/latex-base
+ || ( dev-texlive/texlive-latexextra app-text/ptex )
+ dev-texlive/texlive-fontsextra )"
+
+src_configure() {
+ # non-autoconf
+ ./configure \
+ --prefix=/usr \
+ $(use ocamlopt || echo "--no-opt") \
+ $(use_with python) \
+ $(use_with ocaml) \
+ || die
+ sed -i "s:^LIBDIR=.*:LIBDIR=/usr/$(get_libdir)/ocaml/stublibs/:" Makefile.config
+ sed -i "s:^SHAREDIR=.*:SHAREDIR=/usr/libexec/${PN}/:" Makefile.config
+ sed -i "s:^MANDIR=.*:MANDIR=/usr/share/man/:" Makefile.config
+}
+
+src_compile() {
+ emake depend || die
+ emake || die
+ if use doc ; then
+ VARTEXFONTS="${T}"/fonts emake docs || die
+ fi
+ if use ocamlopt ; then
+ emake opt || die
+ fi
+}
+
+src_test() {
+ source env.sh # needed for built in-place python plugin
+ ./spatch standard.h -parse_c -dir tests/ || die
+ yes | ./spatch -iso_file standard.iso -macro_file_builtins standard.h -testall || die
+ if use ocamlopt ; then
+ ./spatch.opt -iso_file standard.iso -macro_file_builtins standard.h -testall || die
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc authors.txt bugs.txt changes.txt credits.txt readme.txt
+ use doc && dodoc docs/manual/*.pdf
+ export STRIP_MASK='*/coccinelle/spatch'
+}