summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-07-18 09:03:45 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-07-18 09:03:45 +0000
commit69d086965b877a228028b18a906dca849460ea91 (patch)
treed08193a2f00d9ec001c48384ec2588a47a9edfa2 /dev-util/cmake
parentppc/ppc64 stable wrt #349496 (diff)
downloadgentoo-2-69d086965b877a228028b18a906dca849460ea91.tar.gz
gentoo-2-69d086965b877a228028b18a906dca849460ea91.tar.bz2
gentoo-2-69d086965b877a228028b18a906dca849460ea91.zip
Patch FindBLAS and FindLAPACK to try PkgConfig first and skip all other tests if that succeeds; prepare for additional eclass feature of automated cmake module removal in $S, which should NOT happen in the cmake ebuild itself.
(Portage version: 2.1.10.5/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/cmake')
-rw-r--r--dev-util/cmake/ChangeLog11
-rw-r--r--dev-util/cmake/cmake-2.8.4-r1.ebuild3
-rw-r--r--dev-util/cmake/cmake-2.8.5-r2.ebuild165
-rw-r--r--dev-util/cmake/cmake-2.8.5.ebuild3
-rw-r--r--dev-util/cmake/files/cmake-2.8.5-FindBLAS.patch35
-rw-r--r--dev-util/cmake/files/cmake-2.8.5-FindLAPACK.patch34
6 files changed, 248 insertions, 3 deletions
diff --git a/dev-util/cmake/ChangeLog b/dev-util/cmake/ChangeLog
index b90040d0ce31..f59a87e22a01 100644
--- a/dev-util/cmake/ChangeLog
+++ b/dev-util/cmake/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-util/cmake
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.169 2011/07/11 16:50:44 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.170 2011/07/18 09:03:45 dilfridge Exp $
+
+*cmake-2.8.5-r2 (18 Jul 2011)
+
+ 18 Jul 2011; Andreas K. Huettel <dilfridge@gentoo.org> cmake-2.8.4-r1.ebuild,
+ cmake-2.8.5.ebuild, +cmake-2.8.5-r2.ebuild,
+ +files/cmake-2.8.5-FindBLAS.patch, +files/cmake-2.8.5-FindLAPACK.patch:
+ Patch FindBLAS and FindLAPACK to try PkgConfig first and skip all other tests
+ if that succeeds; prepare for additional eclass feature of automated cmake
+ module removal in $S, which should NOT happen in the cmake ebuild itself.
*cmake-2.8.5 (11 Jul 2011)
diff --git a/dev-util/cmake/cmake-2.8.4-r1.ebuild b/dev-util/cmake/cmake-2.8.4-r1.ebuild
index 67a64b74320c..df724da84157 100644
--- a/dev-util/cmake/cmake-2.8.4-r1.ebuild
+++ b/dev-util/cmake/cmake-2.8.4-r1.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.8.4-r1.ebuild,v 1.4 2011/05/07 16:52:33 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.8.4-r1.ebuild,v 1.5 2011/07/18 09:03:45 dilfridge Exp $
EAPI=4
+CMAKE_REMOVE_MODULES="no"
inherit elisp-common toolchain-funcs eutils versionator flag-o-matic base cmake-utils virtualx
MY_P="${PN}-$(replace_version_separator 3 - ${MY_PV})"
diff --git a/dev-util/cmake/cmake-2.8.5-r2.ebuild b/dev-util/cmake/cmake-2.8.5-r2.ebuild
new file mode 100644
index 000000000000..d360cd3b890a
--- /dev/null
+++ b/dev-util/cmake/cmake-2.8.5-r2.ebuild
@@ -0,0 +1,165 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.8.5-r2.ebuild,v 1.1 2011/07/18 09:03:45 dilfridge Exp $
+
+EAPI=4
+
+CMAKE_REMOVE_MODULES="no"
+inherit elisp-common toolchain-funcs eutils versionator flag-o-matic base cmake-utils virtualx
+
+MY_P="${PN}-$(replace_version_separator 3 - ${MY_PV})"
+
+DESCRIPTION="Cross platform Make"
+HOMEPAGE="http://www.cmake.org/"
+SRC_URI="http://www.cmake.org/files/v$(get_version_component_range 1-2)/${MY_P}.tar.gz"
+
+LICENSE="CMake"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE="emacs ncurses qt4 vim-syntax"
+
+DEPEND="
+ >=app-arch/libarchive-2.8.0
+ >=net-misc/curl-7.20.0-r1[ssl]
+ >=dev-libs/expat-2.0.1
+ dev-util/pkgconfig
+ sys-libs/zlib
+ ncurses? ( sys-libs/ncurses )
+ qt4? ( x11-libs/qt-gui:4 )
+"
+RDEPEND="${DEPEND}
+ emacs? ( virtual/emacs )
+ vim-syntax? (
+ || (
+ app-editors/vim
+ app-editors/gvim
+ )
+ )
+"
+
+SITEFILE="50${PN}-gentoo.el"
+VIMFILE="${PN}.vim"
+
+S="${WORKDIR}/${MY_P}"
+
+CMAKE_BINARY="${S}/Bootstrap.cmk/cmake"
+
+# Fixme:
+# Boost patchset is foobared and should respect eselect / slotting
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.6.3-darwin-bundle.patch
+ "${FILESDIR}"/${PN}-2.6.3-no-duplicates-in-rpath.patch
+ "${FILESDIR}"/${PN}-2.6.3-fix_broken_lfs_on_aix.patch
+ "${FILESDIR}"/${PN}-2.8.0-darwin-default-install_name.patch
+ "${FILESDIR}"/${PN}-2.8.1-libform.patch
+ "${FILESDIR}"/${PN}-2.8.4-FindPythonLibs.patch
+ "${FILESDIR}"/${PN}-2.8.4-FindPythonInterp.patch
+ "${FILESDIR}"/${PN}-2.8.3-more-no_host_paths.patch
+ "${FILESDIR}"/${PN}-2.8.3-ruby_libname.patch
+ "${FILESDIR}"/${PN}-2.8.4-FindBoost.patch
+ "${FILESDIR}"/${PN}-2.8.5-FindBLAS.patch
+ "${FILESDIR}"/${PN}-2.8.5-FindLAPACK.patch
+)
+cmake_src_bootstrap() {
+ # Cleanup args to extract only JOBS.
+ # Because bootstrap does not know anything else.
+ echo ${MAKEOPTS} | egrep -o '(\-j|\-\-jobs)(=?|[[:space:]]*)[[:digit:]]+' > /dev/null
+ if [ $? -eq 0 ]; then
+ par_arg=$(echo ${MAKEOPTS} | egrep -o '(\-j|\-\-jobs)(=?|[[:space:]]*)[[:digit:]]+' | egrep -o '[[:digit:]]+')
+ par_arg="--parallel=${par_arg}"
+ else
+ par_arg="--parallel=1"
+ fi
+
+ tc-export CC CXX LD
+
+ ./bootstrap \
+ --prefix="${T}/cmakestrap/" \
+ ${par_arg} \
+ || die "Bootstrap failed"
+}
+
+cmake_src_test() {
+ # fix OutDir test
+ # this is altered thanks to our eclass
+ sed -i -e 's:#IGNORE ::g' "${S}"/Tests/OutDir/CMakeLists.txt || die
+ pushd "${CMAKE_BUILD_DIR}" > /dev/null
+ # Excluded tests:
+ # BootstrapTest: we actualy bootstrap it every time so why test it.
+ # SimpleCOnly_sdcc: sdcc choke on global cflags so just skip the test
+ # as it was never intended to be used this way.
+ "${CMAKE_BUILD_DIR}"/bin/ctest \
+ -E BootstrapTest SimpleCOnly_sdcc \
+ || die "Tests failed"
+ popd > /dev/null
+}
+
+src_prepare() {
+ base_src_prepare
+
+ # disable running of cmake in boostrap command
+ sed -i \
+ -e '/"${cmake_bootstrap_dir}\/cmake"/s/^/#DONOTRUN /' \
+ bootstrap || die "sed failed"
+
+ # Add gcc libs to the default link paths
+ sed -i \
+ -e "s|@GENTOO_PORTAGE_GCCLIBDIR@|${EPREFIX}/usr/${CHOST}/lib/|g" \
+ -e "s|@GENTOO_PORTAGE_EPREFIX@|${EPREFIX}/|g" \
+ Modules/Platform/{UnixPaths,Darwin}.cmake || die "sed failed"
+
+ cmake_src_bootstrap
+}
+
+src_configure() {
+ # make things work with gentoo java setup
+ # in case java-config cannot be run, the variable just becomes unset
+ # per bug #315229
+ export JAVA_HOME=$(java-config -g JAVA_HOME 2> /dev/null)
+
+ local mycmakeargs=(
+ -DCMAKE_USE_SYSTEM_LIBRARIES=ON
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}"/usr
+ -DCMAKE_DOC_DIR=/share/doc/${PF}
+ -DCMAKE_MAN_DIR=/share/man
+ -DCMAKE_DATA_DIR=/share/${PN}
+ $(cmake-utils_use_build ncurses CursesDialog)
+ $(cmake-utils_use_build qt4 QtDialog)
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ use emacs && elisp-compile Docs/cmake-mode.el
+}
+
+src_test() {
+ VIRTUALX_COMMAND="cmake_src_test" virtualmake
+}
+
+src_install() {
+ cmake-utils_src_install
+ if use emacs; then
+ elisp-install ${PN} Docs/cmake-mode.el Docs/cmake-mode.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins Docs/cmake-syntax.vim
+
+ insinto /usr/share/vim/vimfiles/indent
+ doins Docs/cmake-indent.vim
+
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins "${FILESDIR}/${VIMFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-util/cmake/cmake-2.8.5.ebuild b/dev-util/cmake/cmake-2.8.5.ebuild
index d628d8d26ab8..7cde15514fd7 100644
--- a/dev-util/cmake/cmake-2.8.5.ebuild
+++ b/dev-util/cmake/cmake-2.8.5.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.8.5.ebuild,v 1.1 2011/07/11 16:50:44 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.8.5.ebuild,v 1.2 2011/07/18 09:03:45 dilfridge Exp $
EAPI=4
+CMAKE_REMOVE_MODULES="no"
inherit elisp-common toolchain-funcs eutils versionator flag-o-matic base cmake-utils virtualx
MY_P="${PN}-$(replace_version_separator 3 - ${MY_PV})"
diff --git a/dev-util/cmake/files/cmake-2.8.5-FindBLAS.patch b/dev-util/cmake/files/cmake-2.8.5-FindBLAS.patch
new file mode 100644
index 000000000000..2ffa2d2a3ec0
--- /dev/null
+++ b/dev-util/cmake/files/cmake-2.8.5-FindBLAS.patch
@@ -0,0 +1,35 @@
+diff -ruN cmake-2.8.5.orig/Modules/FindBLAS.cmake cmake-2.8.5/Modules/FindBLAS.cmake
+--- cmake-2.8.5.orig/Modules/FindBLAS.cmake 2011-07-08 14:21:44.000000000 +0200
++++ cmake-2.8.5/Modules/FindBLAS.cmake 2011-07-17 17:34:45.384557963 +0200
+@@ -1,3 +1,9 @@
++#
++# Version modified for Gentoo Linux
++# If a valid PkgConfig configuration for blas is found, this overrides and cancels
++# all further checks.
++#
++
+ # - Find BLAS library
+ # This module finds an installed fortran library that implements the BLAS
+ # linear-algebra interface (see http://www.netlib.org/blas/).
+@@ -39,6 +45,14 @@
+ # (To distribute this file outside of CMake, substitute the full
+ # License text for the above reference.)
+
++#
++# first, try PkgConfig
++#
++find_package(PkgConfig REQUIRED)
++pkg_check_modules(BLAS blas)
++if(NOT BLAS_FOUND)
++message(STATUS "No PkgConfig configuration for BLAS found; starting more extensive search.")
++
+ include(CheckFunctionExists)
+ include(CheckFortranFunctionExists)
+
+@@ -559,3 +573,6 @@
+ endif(BLAS_FOUND)
+ endif(NOT BLAS_FIND_QUIETLY)
+ endif(BLA_F95)
++
++
++endif(NOT BLAS_FOUND)
diff --git a/dev-util/cmake/files/cmake-2.8.5-FindLAPACK.patch b/dev-util/cmake/files/cmake-2.8.5-FindLAPACK.patch
new file mode 100644
index 000000000000..6a159a9a840a
--- /dev/null
+++ b/dev-util/cmake/files/cmake-2.8.5-FindLAPACK.patch
@@ -0,0 +1,34 @@
+diff -ruN cmake-2.8.5.orig/Modules/FindLAPACK.cmake cmake-2.8.5/Modules/FindLAPACK.cmake
+--- cmake-2.8.5.orig/Modules/FindLAPACK.cmake 2011-07-08 14:21:44.000000000 +0200
++++ cmake-2.8.5/Modules/FindLAPACK.cmake 2011-07-17 19:46:57.865560858 +0200
+@@ -1,3 +1,9 @@
++#
++# Version modified for Gentoo Linux
++# If a valid PkgConfig configuration is found, this overrides and cancels
++# all further checks.
++#
++
+ # - Find LAPACK library
+ # This module finds an installed fortran library that implements the LAPACK
+ # linear-algebra interface (see http://www.netlib.org/lapack/).
+@@ -36,6 +42,14 @@
+ # (To distribute this file outside of CMake, substitute the full
+ # License text for the above reference.)
+
++#
++# first, try PkgConfig
++#
++find_package(PkgConfig REQUIRED)
++pkg_check_modules(LAPACK lapack)
++if(NOT LAPACK_FOUND)
++message(STATUS "No PkgConfig configuration for LAPACK found; starting more extensive search.")
++
+ get_property(_LANGUAGES_ GLOBAL PROPERTY ENABLED_LANGUAGES)
+ if (NOT _LANGUAGES_ MATCHES Fortran)
+ include(CheckFunctionExists)
+@@ -300,3 +314,5 @@
+ endif(LAPACK_FOUND)
+ endif(NOT LAPACK_FIND_QUIETLY)
+ endif(BLA_F95)
++
++endif(NOT LAPACK_FOUND)