summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-04-23 17:27:20 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-04-23 17:27:20 +0000
commitc0d7ed2a83a4b7be267f510722780e1fd2229046 (patch)
tree09ae5399a24e70c337c866b16e1611a3bfcf9147 /dev-util/checkstyle
parentpackage.use.mask test for ~dev-util/checkstyle-4.3 because they require virtu... (diff)
downloadgentoo-2-c0d7ed2a83a4b7be267f510722780e1fd2229046.tar.gz
gentoo-2-c0d7ed2a83a4b7be267f510722780e1fd2229046.tar.bz2
gentoo-2-c0d7ed2a83a4b7be267f510722780e1fd2229046.zip
Version bump. Test suite works only with virtual/jdk-1.6.
(Portage version: 2.1.2.4)
Diffstat (limited to 'dev-util/checkstyle')
-rw-r--r--dev-util/checkstyle/ChangeLog8
-rw-r--r--dev-util/checkstyle/checkstyle-4.3.ebuild102
-rw-r--r--dev-util/checkstyle/files/digest-checkstyle-4.33
3 files changed, 112 insertions, 1 deletions
diff --git a/dev-util/checkstyle/ChangeLog b/dev-util/checkstyle/ChangeLog
index f361ff902848..6f221e302373 100644
--- a/dev-util/checkstyle/ChangeLog
+++ b/dev-util/checkstyle/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/checkstyle
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/checkstyle/ChangeLog,v 1.23 2007/02/03 23:01:27 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/checkstyle/ChangeLog,v 1.24 2007/04/23 17:27:20 betelgeuse Exp $
+
+*checkstyle-4.3 (23 Apr 2007)
+
+ 23 Apr 2007; Petteri Räty <betelgeuse@gentoo.org> +checkstyle-4.3.ebuild:
+ Version bump. Test suite works only with virtual/jdk-1.6.
03 Feb 2007; Steve Dibb <beandog@gentoo.org> checkstyle-4.2.ebuild:
add ~amd64, bug 161618
@@ -53,6 +58,7 @@
cleanup, removed old revision with a dependency to regexp.
*checkstyle-3.4-r3 (27 Mar 2005)
+*checkstyle-3.3-r1 (27 Mar 2005)
27 Mar 2005; Jan Brinkmann <luckyduck@gentoo.org> +checkstyle-3.3-r1.ebuild,
-checkstyle-3.4-r2.ebuild, +checkstyle-3.4-r3.ebuild:
diff --git a/dev-util/checkstyle/checkstyle-4.3.ebuild b/dev-util/checkstyle/checkstyle-4.3.ebuild
new file mode 100644
index 000000000000..70d149525c12
--- /dev/null
+++ b/dev-util/checkstyle/checkstyle-4.3.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/checkstyle/checkstyle-4.3.ebuild,v 1.1 2007/04/23 17:27:20 betelgeuse Exp $
+
+WANT_ANT_TASKS="ant-antlr ant-nodeps"
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+MY_P="${PN}-src-${PV}"
+DESCRIPTION="A development tool to help programmers write Java code that adheres to a coding standard."
+HOMEPAGE="http://checkstyle.sourceforge.net"
+SRC_URI="mirror://sourceforge/checkstyle/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+COMMON_DEP="dev-java/antlr
+ =dev-java/commons-beanutils-1.7*
+ =dev-java/commons-cli-1*
+ dev-java/commons-logging
+ dev-java/commons-collections"
+
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+
+# Tests are a bit buggy and fail with 1.5 in one case
+# Should be fixed in the next release
+DEPEND="!test? ( >=virtual/jdk-1.4 )
+ test? ( =virtual/jdk-1.6* )
+ ${COMMON_DEP}
+ test? (
+ dev-java/ant-junit
+ dev-java/ant-trax
+ dev-java/emma
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+# So that we can generate 1.4 bytecode for dist
+# and 1.5 for tests
+JAVA_PKG_BSFIX="off"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}/lib"
+ rm -v *.jar || die
+ java-pkg_jar-from antlr
+ java-pkg_jar-from commons-beanutils-1.7
+ java-pkg_jar-from commons-cli-1
+ java-pkg_jar-from commons-logging
+ java-pkg_jar-from commons-collections
+}
+
+src_compile() {
+ eant compile.checkstyle $(use_doc)
+ jar cfm ${PN}.jar config/manifest.mf -C target/checkstyle . || die "jar failed"
+}
+
+src_test() {
+ # 1.6 on ppc. Remember to remove from package.use.mask when 1.6 is out
+ if use !ppc; then
+ cd "${S}/lib"
+ java-pkg_jar-from --build-only junit
+ java-pkg_jar-from --build-only emma
+ cd "${S}"
+ ANT_TASKS="emma ant-nodeps ant-junit ant-trax" eant run.tests
+ fi
+}
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+
+ dodoc README RIGHTS.antlr || die
+ use doc && java-pkg_dojavadoc target/docs/api
+ use source && java-pkg_dosrc src/${PN}/com
+
+ # Install check files
+ insinto /usr/share/checkstyle/checks
+ for file in *.xml; do
+ [[ "${file}" != build.xml ]] && doins ${file}
+ done
+
+ # Install extra files
+ insinto /usr/share/checkstyle/contrib
+ doins -r contrib/*
+
+ java-pkg_dolauncher ${PN} \
+ --main com.puppycrawl.tools.checkstyle.Main
+
+ java-pkg_dolauncher ${PN}-gui \
+ --main com.puppycrawl.tools.checkstyle.gui.Main
+
+ # Make the ant tasks available to ant
+ java-pkg_register-ant-task
+}
+
+pkg_postinst() {
+ elog "Checkstyle is located at /usr/bin/checkstyle"
+ elog "Check files are located in /usr/share/checkstyle/checks/"
+}
diff --git a/dev-util/checkstyle/files/digest-checkstyle-4.3 b/dev-util/checkstyle/files/digest-checkstyle-4.3
new file mode 100644
index 000000000000..d80a7d967ad3
--- /dev/null
+++ b/dev-util/checkstyle/files/digest-checkstyle-4.3
@@ -0,0 +1,3 @@
+MD5 ca03b9f809b578aa98bbd70d0f2cadf1 checkstyle-src-4.3.tar.gz 2566968
+RMD160 476ce17adbf869f17a287c232f9b5c6e9b056266 checkstyle-src-4.3.tar.gz 2566968
+SHA256 ba6b106b1ecbe3686687cb8e069d3935a37a58bb1b0e1dfa6af9bf052b093b97 checkstyle-src-4.3.tar.gz 2566968