summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Nichols <nichoj@gentoo.org>2005-12-19 05:56:41 +0000
committerJoshua Nichols <nichoj@gentoo.org>2005-12-19 05:56:41 +0000
commita5527af5255827ae48236160765a23b3803f563a (patch)
treeebd6e7fb19017f8f8d02ba211ae99afb897b0efd /dev-util/checkstyle
parentRemove usage of preplib. (diff)
downloadgentoo-2-a5527af5255827ae48236160765a23b3803f563a.tar.gz
gentoo-2-a5527af5255827ae48236160765a23b3803f563a.tar.bz2
gentoo-2-a5527af5255827ae48236160765a23b3803f563a.zip
Version bump (bug #115986).
(Portage version: 2.1_pre1)
Diffstat (limited to 'dev-util/checkstyle')
-rw-r--r--dev-util/checkstyle/ChangeLog7
-rw-r--r--dev-util/checkstyle/Manifest14
-rw-r--r--dev-util/checkstyle/checkstyle-4.1.ebuild83
-rw-r--r--dev-util/checkstyle/files/digest-checkstyle-4.11
4 files changed, 93 insertions, 12 deletions
diff --git a/dev-util/checkstyle/ChangeLog b/dev-util/checkstyle/ChangeLog
index c6c467811edc..e0cdf46e6d1e 100644
--- a/dev-util/checkstyle/ChangeLog
+++ b/dev-util/checkstyle/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/checkstyle
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/checkstyle/ChangeLog,v 1.17 2005/10/04 08:25:21 sejo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/checkstyle/ChangeLog,v 1.18 2005/12/19 05:56:41 nichoj Exp $
+
+*checkstyle-4.1 (19 Dec 2005)
+
+ 19 Dec 2005; Joshua Nichols <nichoj@gentoo.org> +checkstyle-4.1.ebuild:
+ Version bump (bug #115986).
04 Oct 2005; Jochen Maes <sejo@gentoo.org> checkstyle-3.5.ebuild:
Fixing the ant-tasks depend
diff --git a/dev-util/checkstyle/Manifest b/dev-util/checkstyle/Manifest
index 4d522f48dc07..eaa54e88ab60 100644
--- a/dev-util/checkstyle/Manifest
+++ b/dev-util/checkstyle/Manifest
@@ -1,16 +1,8 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 3d053bdf0542d27618e225aa0be87051 ChangeLog 2774
MD5 b7f56015d5fe69a08534451836fbb5e1 checkstyle-3.4-r4.ebuild 2031
-MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
MD5 14f9c2074e82e234d500f7aeee453d38 checkstyle-3.5.ebuild 2118
+MD5 4b27abde255be1d72dc907e48bbf9d5f checkstyle-4.1.ebuild 2277
MD5 ee7955e25b09c5307250330d16910077 files/digest-checkstyle-3.4-r4 71
MD5 33db541757525575ba7e6d18913875f1 files/digest-checkstyle-3.5 71
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFDQjyIMXMsRNMHhmARAlVrAKCSJ5+30f3yGiSNn/eZYAPy8MKqWACfZOs2
-PziSWPi3occDhi2PP02l4Q8=
-=dR01
------END PGP SIGNATURE-----
+MD5 3183a4b489590ca780b18277ded5a526 files/digest-checkstyle-4.1 71
+MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
diff --git a/dev-util/checkstyle/checkstyle-4.1.ebuild b/dev-util/checkstyle/checkstyle-4.1.ebuild
new file mode 100644
index 000000000000..000e6c49c4f2
--- /dev/null
+++ b/dev-util/checkstyle/checkstyle-4.1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/checkstyle/checkstyle-4.1.ebuild,v 1.1 2005/12/19 05:56:41 nichoj Exp $
+
+inherit java-pkg
+
+MY_P="${PN}-src-${PV}"
+DESCRIPTION="A development tool to help programmers write Java code that adheres to a coding standard."
+HOMEPAGE="http://checkstyle.sourceforge.net"
+SRC_URI="mirror://sourceforge/checkstyle/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="doc jikes"
+
+RDEPEND=">=virtual/jre-1.3
+ dev-java/antlr
+ =dev-java/commons-beanutils-1.7*
+ =dev-java/commons-cli-1*
+ dev-java/commons-collections
+ dev-java/commons-logging
+ =dev-java/jakarta-regexp-1.3*"
+DEPEND=">=virtual/jdk-1.4
+ ${RDEPEND}
+ dev-java/ant-core
+ dev-java/ant-tasks
+ jikes? ( dev-java/jikes )"
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/lib
+ rm *.jar
+ java-pkg_jar-from antlr
+ java-pkg_jar-from commons-beanutils-1.7
+ java-pkg_jar-from commons-cli-1
+ java-pkg_jar-from commons-collections
+ java-pkg_jar-from commons-logging
+ java-pkg_jar-from jakarta-regexp-1.3 jakarta-regexp.jar jakarta-regexp-1.3.jar
+}
+
+src_compile() {
+ local antflags="compile.checkstyle"
+ use doc && antflags="${antflags} javadoc"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ ant ${antflags} || die "ant failed"
+
+ jar cfm ${PN}.jar config/manifest.mf -C target/checkstyle . || die "jar failed"
+}
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+
+ dodoc README RIGHTS.antlr TODO
+ use doc && java-pkg_dohtml -r docs/*
+
+ # Install check files
+ insinto /usr/share/checkstyle/checks
+ doins checkstyle_checks.xml sun_checks.xml
+
+ # Install extra files
+ insinto /usr/share/checkstyle/contrib
+ doins -r contrib/*
+
+ # Make and install a wrapper script
+ cat > checkstyle <<-END
+#!/bin/bash
+classpath=\$(java-config -p checkstyle,antlr,commons-beanutils-1.7,commons-cli-1,commons-collections,commons-logging,jakarta-regexp-1.3)
+class=com.puppycrawl.tools.checkstyle.Main
+exec \$(java-config --java) -cp \$classpath \$class "\$@"
+END
+ dobin checkstyle
+
+ # Make the ant tasks available to ant
+ dodir /usr/share/ant-core/lib
+ dosym /usr/share/${PN}/lib/${PN}.jar /usr/share/ant-core/lib/
+}
+
+pkg_postinst() {
+ einfo "Checkstyle is located at /usr/bin/checkstyle"
+ einfo "Check files are located in /usr/share/checkstyle/checks/"
+}
diff --git a/dev-util/checkstyle/files/digest-checkstyle-4.1 b/dev-util/checkstyle/files/digest-checkstyle-4.1
new file mode 100644
index 000000000000..bababbc30bb3
--- /dev/null
+++ b/dev-util/checkstyle/files/digest-checkstyle-4.1
@@ -0,0 +1 @@
+MD5 96b430fe5087b4f62fa78804475ee2ea checkstyle-src-4.1.tar.gz 2877441