summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Holm <dholm@gentoo.org>2004-11-10 08:42:06 +0000
committerDavid Holm <dholm@gentoo.org>2004-11-10 08:42:06 +0000
commitd4fa795bb505e0713c6b8606e49ca3a9f534e9fe (patch)
treea18e575f8503d89e61124045806a5d86eb8f77af /dev-util/ccmalloc
parentadded notes to package.mask (diff)
downloadgentoo-2-d4fa795bb505e0713c6b8606e49ca3a9f534e9fe.tar.gz
gentoo-2-d4fa795bb505e0713c6b8606e49ca3a9f534e9fe.tar.bz2
gentoo-2-d4fa795bb505e0713c6b8606e49ca3a9f534e9fe.zip
Initial import
Diffstat (limited to 'dev-util/ccmalloc')
-rw-r--r--dev-util/ccmalloc/ChangeLog11
-rw-r--r--dev-util/ccmalloc/Manifest4
-rw-r--r--dev-util/ccmalloc/ccmalloc-0.4.0.ebuild27
-rw-r--r--dev-util/ccmalloc/files/digest-ccmalloc-0.4.01
-rw-r--r--dev-util/ccmalloc/metadata.xml11
5 files changed, 54 insertions, 0 deletions
diff --git a/dev-util/ccmalloc/ChangeLog b/dev-util/ccmalloc/ChangeLog
new file mode 100644
index 000000000000..c7ad6eae0005
--- /dev/null
+++ b/dev-util/ccmalloc/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-util/ccmalloc
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ccmalloc/ChangeLog,v 1.1 2004/11/10 08:42:06 dholm Exp $
+
+*ccmalloc-0.4.0 (10 Nov 2004)
+
+ 10 Nov 2004; David Holm <dholm@gentoo.org> +metadata.xml,
+ +ccmalloc-0.4.0.ebuild:
+ Ebuild submitted by Darryl Bleau <darrylbleau (at) submersion (dot) com>
+ (bug #34546)
+
diff --git a/dev-util/ccmalloc/Manifest b/dev-util/ccmalloc/Manifest
new file mode 100644
index 000000000000..a4cdc052c208
--- /dev/null
+++ b/dev-util/ccmalloc/Manifest
@@ -0,0 +1,4 @@
+MD5 d9fbf5fad9d92f36f021acd3b3c44585 metadata.xml 698
+MD5 e94affbec5be71860cf5a3ced278bd74 ccmalloc-0.4.0.ebuild 779
+MD5 071c92cf602927b57a6fc44c09b0405b ChangeLog 326
+MD5 c5da0db1c55878a6487dd3401d6bb9a2 files/digest-ccmalloc-0.4.0 65
diff --git a/dev-util/ccmalloc/ccmalloc-0.4.0.ebuild b/dev-util/ccmalloc/ccmalloc-0.4.0.ebuild
new file mode 100644
index 000000000000..0e15fbd003eb
--- /dev/null
+++ b/dev-util/ccmalloc/ccmalloc-0.4.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ccmalloc/ccmalloc-0.4.0.ebuild,v 1.1 2004/11/10 08:42:06 dholm Exp $
+
+inherit eutils
+
+DESCRIPTION="A easy-to-use memory debugging library"
+HOMEPAGE="http://www.inf.ethz.ch/personal/biere/projects/ccmalloc/"
+SRC_URI="http://www.inf.ethz.ch/personal/biere/projects/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE="debug"
+DEPEND="sys-devel/gcc sys-apps/sed"
+RDEPEND="virtual/libc"
+
+src_compile() {
+ local myconf
+ use debug && ${myconf} = "${myconf} --debug"
+ ./configure --prefix=/usr ${myconf} || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall PREFIX=${D}/usr || die "einstall failed"
+ dodoc BUGS FEATURES NEWS README TODO USAGE VERSION
+}
diff --git a/dev-util/ccmalloc/files/digest-ccmalloc-0.4.0 b/dev-util/ccmalloc/files/digest-ccmalloc-0.4.0
new file mode 100644
index 000000000000..3dd24a3c07af
--- /dev/null
+++ b/dev-util/ccmalloc/files/digest-ccmalloc-0.4.0
@@ -0,0 +1 @@
+MD5 b90d955149569bbc6e801739f099db3d ccmalloc-0.4.0.tar.gz 57917
diff --git a/dev-util/ccmalloc/metadata.xml b/dev-util/ccmalloc/metadata.xml
new file mode 100644
index 000000000000..5003172ad246
--- /dev/null
+++ b/dev-util/ccmalloc/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>dholm@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ If you want to remove memory leaks from your C or C++ programs or you experience strange bugs, probably due to pointer access to freed data, then ccmalloc may be the right tool for you. In general it can help you to track down memory related problems with C and C++ programs. It does not replace more sophistacted tools such as purify or valgrind, since it can not detect illegal memory reads, at least not all type of memory reads.
+ </longdescription>
+</pkgmetadata>