summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-08-22 00:23:19 +0000
committerMike Frysinger <vapier@gentoo.org>2011-08-22 00:23:19 +0000
commitd2498c2841c89c43833732c41fd2cba9181b7432 (patch)
treec376e02eecb4f12854192408fcff98d29c2a9d74 /dev-util/ccache
parentRemove old (diff)
downloadgentoo-2-d2498c2841c89c43833732c41fd2cba9181b7432.tar.gz
gentoo-2-d2498c2841c89c43833732c41fd2cba9181b7432.tar.bz2
gentoo-2-d2498c2841c89c43833732c41fd2cba9181b7432.zip
Version bump.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/ccache')
-rw-r--r--dev-util/ccache/ChangeLog7
-rw-r--r--dev-util/ccache/ccache-3.1.6.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/dev-util/ccache/ChangeLog b/dev-util/ccache/ChangeLog
index f62639c6a1cd..8a0e28c32f95 100644
--- a/dev-util/ccache/ChangeLog
+++ b/dev-util/ccache/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/ccache
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ChangeLog,v 1.81 2011/05/29 16:32:27 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ChangeLog,v 1.82 2011/08/22 00:23:19 vapier Exp $
+
+*ccache-3.1.6 (22 Aug 2011)
+
+ 22 Aug 2011; Mike Frysinger <vapier@gentoo.org> +ccache-3.1.6.ebuild:
+ Version bump.
*ccache-3.1.5 (29 May 2011)
diff --git a/dev-util/ccache/ccache-3.1.6.ebuild b/dev-util/ccache/ccache-3.1.6.ebuild
new file mode 100644
index 000000000000..794d526615bf
--- /dev/null
+++ b/dev-util/ccache/ccache-3.1.6.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ccache-3.1.6.ebuild,v 1.1 2011/08/22 00:23:19 vapier Exp $
+
+inherit multilib
+
+DESCRIPTION="fast compiler cache"
+HOMEPAGE="http://ccache.samba.org/"
+SRC_URI="http://samba.org/ftp/ccache/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # make sure we always use system zlib
+ rm -rf zlib
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc AUTHORS.txt MANUAL.txt NEWS.txt README.txt
+
+ dobin "${FILESDIR}"/ccache-config || die
+ dosed "/^LIBDIR=/s:lib:$(get_libdir):" /usr/bin/ccache-config
+
+ diropts -m0700
+ dodir /root/.ccache
+ keepdir /root/.ccache
+}
+
+pkg_postinst() {
+ "${ROOT}"/usr/bin/ccache-config --install-links
+ "${ROOT}"/usr/bin/ccache-config --install-links ${CHOST}
+
+ # nuke broken symlinks from previous versions that shouldn't exist
+ rm -f "${ROOT}/usr/$(get_libdir)/ccache/bin/${CHOST}-cc"
+ [[ -d "${ROOT}/usr/$(get_libdir)/ccache.backup" ]] && \
+ rm -rf "${ROOT}/usr/$(get_libdir)/ccache.backup"
+
+ elog "To use ccache with **non-Portage** C compiling, add"
+ elog "/usr/$(get_libdir)/ccache/bin to the beginning of your path, before /usr/bin."
+ elog "Portage 2.0.46-r11+ will automatically take advantage of ccache with"
+ elog "no additional steps. If this is your first install of ccache, type"
+ elog "something like this to set a maximum cache size of 2GB:"
+ elog "# ccache -M 2G"
+ elog
+ elog "If you are upgrading from an older version than 3.x you should clear"
+ elog "all of your caches like so:"
+ elog "# CCACHE_DIR='${CCACHE_DIR:-${PORTAGE_TMPDIR}/ccache}' ccache -C"
+}