summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTilman Klar <phoenix@gentoo.org>2002-07-12 06:14:29 +0000
committerTilman Klar <phoenix@gentoo.org>2002-07-12 06:14:29 +0000
commit55af78332b8e56794db99266333d1ec18fc410c5 (patch)
tree1fd622b5c656df165fb9479199b0b09df35eac47 /dev-util/ccache
parentstop the screen clearing (diff)
downloadgentoo-2-55af78332b8e56794db99266333d1ec18fc410c5.tar.gz
gentoo-2-55af78332b8e56794db99266333d1ec18fc410c5.tar.bz2
gentoo-2-55af78332b8e56794db99266333d1ec18fc410c5.zip
New revision: added checks for the symlinks.
Diffstat (limited to 'dev-util/ccache')
-rw-r--r--dev-util/ccache/ChangeLog14
-rw-r--r--dev-util/ccache/ccache-1.9-r1.ebuild74
-rw-r--r--dev-util/ccache/ccache-1.9.ebuild4
-rw-r--r--dev-util/ccache/files/digest-ccache-1.9-r11
4 files changed, 91 insertions, 2 deletions
diff --git a/dev-util/ccache/ChangeLog b/dev-util/ccache/ChangeLog
index 61267bd60279..6a84ebc0a365 100644
--- a/dev-util/ccache/ChangeLog
+++ b/dev-util/ccache/ChangeLog
@@ -1,9 +1,21 @@
# ChangeLog for dev-util/ccache
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ChangeLog,v 1.3 2002/07/10 00:44:03 gerk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ChangeLog,v 1.4 2002/07/12 06:14:29 phoenix Exp $
+
+
+*ccache-1.9 (12 July 2002)
+
+ 12 Jul 2002; phoen][x <phoenix@gentoo.org> ccache-1.9-r1.ebuild,
+ files/digest-ccache-1.9-r1 :
+
+ New revision: Added a check before symlinking in pkg_postinst().
+ That way, the ebuild wont create symlinks for compiler which arent installed.
*ccache-1.9 (09 Jul 2002)
+ 12 Jul 2002; phoen][x <phoenix@gentoo.org> ccache-1.9-r1.ebuild,
+ Added LICENSE, SLOT.
+
09 Jul 2002; Mark Guertin <gerk@gentoo.org> : tested and added
ppc to KEYWORDS
diff --git a/dev-util/ccache/ccache-1.9-r1.ebuild b/dev-util/ccache/ccache-1.9-r1.ebuild
new file mode 100644
index 000000000000..855fd7ed3c7b
--- /dev/null
+++ b/dev-util/ccache/ccache-1.9-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ccache-1.9-r1.ebuild,v 1.1 2002/07/12 06:14:29 phoenix Exp $
+
+DESCRIPTION="ccache is a fast compiler cache. It is used as a front end to your
+compiler to safely cache compilation output. When the same code is compiled
+again the cached output is used giving a significant speedup."
+SRC_URI="http://ccache.samba.org/ftp/ccache/${P}.tar.gz"
+HOMEPAGE="http://ccache.samba.org/"
+KEYWORDS="x86 ppc"
+LICENSE="GPL-2"
+SLOT="0"
+
+# Note: this version is designed to be auto-detected and used if you happen to have Portage
+# 2.0.6+ installed.
+
+src_compile() {
+ ./configure --prefix=${D}/usr || die
+ make || die
+}
+
+src_install () {
+ exeinto /usr/bin/ccache
+ doexe ccache
+ doman ccache.1
+ dodoc COPYING README
+
+}
+
+pkg_postinst() {
+ cd /usr/bin/ccache
+
+ if([ -e /usr/bin/gcc ]) then
+ ln -s ccache gcc
+ fi
+
+ if([ -e /usr/bin/cc ]) then
+ ln -s ccache cc
+ fi
+
+ if([ -e /usr/bin/c++ ]) then
+ ln -s ccache c++
+ fi
+
+ if([ -e /usr/bin/g++ ]) then
+ ln -s ccache g++
+ fi
+
+ if([ -e /usr/bin/${CHOST}-gcc ]) then
+ ln -s ccache ${CHOST}-gcc
+ fi
+
+ if([ -e /usr/bin/${CHOST}-c++ ]) then
+ ln -s ccache ${CHOST}-c++
+ fi
+
+ if([ -e /usr/bin/${CHOST}-g++ ]) then
+ ln -s ccache ${CHOST}-g++
+ fi
+
+ if [ ! -d ${ROOT}root/.ccache ]
+ then
+ install -d -m0700 ${ROOT}root/.ccache
+ fi
+
+
+ einfo "To use ccache, add /usr/bin/ccache to your path before /usr/bin."
+ einfo "Portage 2.0.6+ will automatically take advantage of ccache with no additional steps."
+ einfo "If this is your first install of ccache, type something like this to set a maximum"
+ einfo "cache size of 2GB (or whatever you desire):"
+ einfo "# /usr/bin/ccache/ccache -M 2G"
+}
+
+
diff --git a/dev-util/ccache/ccache-1.9.ebuild b/dev-util/ccache/ccache-1.9.ebuild
index 5b89e4e351dd..eac0ac6606e4 100644
--- a/dev-util/ccache/ccache-1.9.ebuild
+++ b/dev-util/ccache/ccache-1.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ccache-1.9.ebuild,v 1.2 2002/07/10 00:44:03 gerk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ccache-1.9.ebuild,v 1.3 2002/07/12 06:14:29 phoenix Exp $
DESCRIPTION="ccache is a fast compiler cache. It is used as a front end to your
compiler to safely cache compilation output. When the same code is compiled
@@ -8,6 +8,8 @@ again the cached output is used giving a significant speedup."
SRC_URI="http://ccache.samba.org/ftp/ccache/${P}.tar.gz"
HOMEPAGE="http://ccache.samba.org/"
KEYWORDS="x86 ppc"
+LICENSE="GPL-2"
+SLOT="0"
# Note: this version is designed to be auto-detected and used if you happen to have Portage
# 2.0.6+ installed.
diff --git a/dev-util/ccache/files/digest-ccache-1.9-r1 b/dev-util/ccache/files/digest-ccache-1.9-r1
new file mode 100644
index 000000000000..a561ea71b898
--- /dev/null
+++ b/dev-util/ccache/files/digest-ccache-1.9-r1
@@ -0,0 +1 @@
+MD5 8e73f607accc13da52934303140d555e ccache-1.9.tar.gz 62583