summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Harring <ferringb@gentoo.org>2005-03-09 09:54:51 +0000
committerBrian Harring <ferringb@gentoo.org>2005-03-09 09:54:51 +0000
commite6383b0451bc54dbe50961ef33fcf13df5d2028a (patch)
treea70e75ad08414ef0beb5bc5f574d4a9a5cbeb8d6 /dev-util/ccache/ccache-2.4.ebuild
parent79192, 79195, 79197 (diff)
downloadgentoo-2-e6383b0451bc54dbe50961ef33fcf13df5d2028a.tar.gz
gentoo-2-e6383b0451bc54dbe50961ef33fcf13df5d2028a.tar.bz2
gentoo-2-e6383b0451bc54dbe50961ef33fcf13df5d2028a.zip
version bump to 2.4
(Portage version: 1.584-cvs)
Diffstat (limited to 'dev-util/ccache/ccache-2.4.ebuild')
-rw-r--r--dev-util/ccache/ccache-2.4.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/dev-util/ccache/ccache-2.4.ebuild b/dev-util/ccache/ccache-2.4.ebuild
new file mode 100644
index 000000000000..1acfebd204e8
--- /dev/null
+++ b/dev-util/ccache/ccache-2.4.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ccache-2.4.ebuild,v 1.1 2005/03/09 09:54:51 ferringb Exp $
+
+DESCRIPTION="fast compiler cache"
+HOMEPAGE="http://ccache.samba.org/"
+SRC_URI="http://ccache.samba.org/ftp/ccache/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-macos"
+IUSE=""
+
+DEPEND="virtual/libc"
+
+# Note: this version is designed to be auto-detected and used if
+# you happen to have Portage 2.0.X+ installed.
+
+src_install() {
+ dobin ccache || die
+ doman ccache.1
+ dodoc README
+ dohtml web/*.html
+
+ diropts -m0755
+ dodir /usr/lib/ccache/bin
+ keepdir /usr/lib/ccache/bin
+
+ exeinto /usr/bin
+ doexe ${FILESDIR}/ccache-config
+
+ diropts -m0700
+ dodir /root/.ccache
+ keepdir /root/.ccache
+}
+
+pkg_preinst() {
+ # Portage doesn't handle replacing a non-empty dir with a file!
+ [[ -e ${ROOT}/usr/bin/ccache ]] && rm -r "${ROOT}"/usr/bin/ccache
+ [[ -e ${ROOT}/usr/bin/ccache.backup ]] && rm -r "${ROOT}"/usr/bin/ccache.backup
+}
+
+pkg_postinst() {
+ if [[ ${ROOT} = "/" ]] ; then
+ einfo "Scanning for compiler front-ends..."
+ /usr/bin/ccache-config --install-links
+ /usr/bin/ccache-config --install-links ${CHOST}
+ else
+ ewarn "Install is incomplete; you must run the following commands:"
+ ewarn " # ccache-config --install-links"
+ ewarn " # ccache-config --install-links ${CHOST}"
+ ewarn "after booting or chrooting to ${ROOT} to complete installation."
+ fi
+
+ einfo "To use ccache with **non-Portage** C compiling, add"
+ einfo "/usr/lib/ccache/bin to the beginning of your path, before /usr/bin."
+ einfo "Portage 2.0.46-r11+ will automatically take advantage of ccache with"
+ einfo "no additional steps. If this is your first install of ccache, type"
+ einfo "something like this to set a maximum cache size of 2GB:"
+ einfo "# ccache -M 2G"
+}