summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2014-11-18 15:58:39 +0000
committerIan Stakenvicius <axs@gentoo.org>2014-11-18 15:58:39 +0000
commit502f3190bdc7a9052449c41673765fc188683cab (patch)
tree6f956adc26d71130a91964b21573c4fd45e93015 /dev-util/catfish
parentOops, commented out one too many DEFS. (diff)
downloadgentoo-2-502f3190bdc7a9052449c41673765fc188683cab.tar.gz
gentoo-2-502f3190bdc7a9052449c41673765fc188683cab.tar.bz2
gentoo-2-502f3190bdc7a9052449c41673765fc188683cab.zip
added missing PYTHON_REQUIRED_USE as is necessary for proper python-single-r1 implementation
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 2B6559ED)
Diffstat (limited to 'dev-util/catfish')
-rw-r--r--dev-util/catfish/ChangeLog7
-rw-r--r--dev-util/catfish/catfish-1.0.2.ebuild4
-rw-r--r--dev-util/catfish/catfish-1.2.1.ebuild3
-rw-r--r--dev-util/catfish/catfish-1.2.2.ebuild3
4 files changed, 13 insertions, 4 deletions
diff --git a/dev-util/catfish/ChangeLog b/dev-util/catfish/ChangeLog
index 70f39daf834a..7e092e6b5aaf 100644
--- a/dev-util/catfish/ChangeLog
+++ b/dev-util/catfish/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/catfish
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catfish/ChangeLog,v 1.22 2014/09/25 11:33:37 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catfish/ChangeLog,v 1.23 2014/11/18 15:58:39 axs Exp $
+
+ 18 Nov 2014; Ian Stakenvicius (_AxS_) <axs@gentoo.org> catfish-1.0.2.ebuild,
+ catfish-1.2.1.ebuild, catfish-1.2.2.ebuild:
+ added missing PYTHON_REQUIRED_USE as is necessary for proper python-single-r1
+ implementation
*catfish-1.2.2 (25 Sep 2014)
diff --git a/dev-util/catfish/catfish-1.0.2.ebuild b/dev-util/catfish/catfish-1.0.2.ebuild
index d15d61ee3249..0ee82af8dfd9 100644
--- a/dev-util/catfish/catfish-1.0.2.ebuild
+++ b/dev-util/catfish/catfish-1.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catfish/catfish-1.0.2.ebuild,v 1.5 2014/08/24 07:52:11 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catfish/catfish-1.0.2.ebuild,v 1.6 2014/11/18 15:58:39 axs Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3} )
@@ -29,6 +29,8 @@ DEPEND="
sys-devel/gettext
"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
pkg_setup() {
python-single-r1_pkg_setup
}
diff --git a/dev-util/catfish/catfish-1.2.1.ebuild b/dev-util/catfish/catfish-1.2.1.ebuild
index 00c98975d5b6..e8d28e0628df 100644
--- a/dev-util/catfish/catfish-1.2.1.ebuild
+++ b/dev-util/catfish/catfish-1.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catfish/catfish-1.2.1.ebuild,v 1.2 2014/08/24 07:52:11 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catfish/catfish-1.2.1.ebuild,v 1.3 2014/11/18 15:58:39 axs Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3} )
@@ -28,6 +28,7 @@ DEPEND="
${COMMON_DEPEND}
sys-devel/gettext
"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
pkg_setup() {
python-single-r1_pkg_setup
diff --git a/dev-util/catfish/catfish-1.2.2.ebuild b/dev-util/catfish/catfish-1.2.2.ebuild
index dc7f76c1b01f..04fcf6853042 100644
--- a/dev-util/catfish/catfish-1.2.2.ebuild
+++ b/dev-util/catfish/catfish-1.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catfish/catfish-1.2.2.ebuild,v 1.1 2014/09/25 11:33:37 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catfish/catfish-1.2.2.ebuild,v 1.2 2014/11/18 15:58:39 axs Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3} )
@@ -28,6 +28,7 @@ DEPEND="
${COMMON_DEPEND}
sys-devel/gettext
"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
pkg_setup() {
python-single-r1_pkg_setup