summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-09-25 11:33:37 +0000
committerJeroen Roovers <jer@gentoo.org>2014-09-25 11:33:37 +0000
commit2f209ac7ccc80dee9b085fd4f819c4b105f92f76 (patch)
tree181051884539475b8e9010a07933b028e35ebde6 /dev-util/catfish
parentMarked ~hppa (bug #523686). (diff)
downloadgentoo-2-2f209ac7ccc80dee9b085fd4f819c4b105f92f76.tar.gz
gentoo-2-2f209ac7ccc80dee9b085fd4f819c4b105f92f76.tar.bz2
gentoo-2-2f209ac7ccc80dee9b085fd4f819c4b105f92f76.zip
Version bump.
(Portage version: 2.2.13/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'dev-util/catfish')
-rw-r--r--dev-util/catfish/ChangeLog7
-rw-r--r--dev-util/catfish/catfish-1.2.2.ebuild63
2 files changed, 69 insertions, 1 deletions
diff --git a/dev-util/catfish/ChangeLog b/dev-util/catfish/ChangeLog
index eaeeba518499..70f39daf834a 100644
--- a/dev-util/catfish/ChangeLog
+++ b/dev-util/catfish/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/catfish
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catfish/ChangeLog,v 1.21 2014/08/24 07:52:11 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catfish/ChangeLog,v 1.22 2014/09/25 11:33:37 jer Exp $
+
+*catfish-1.2.2 (25 Sep 2014)
+
+ 25 Sep 2014; Jeroen Roovers <jer@gentoo.org> +catfish-1.2.2.ebuild:
+ Version bump.
24 Aug 2014; Jeroen Roovers <jer@gentoo.org> catfish-1.0.2.ebuild,
catfish-1.2.1.ebuild:
diff --git a/dev-util/catfish/catfish-1.2.2.ebuild b/dev-util/catfish/catfish-1.2.2.ebuild
new file mode 100644
index 000000000000..dc7f76c1b01f
--- /dev/null
+++ b/dev-util/catfish/catfish-1.2.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catfish/catfish-1.2.2.ebuild,v 1.1 2014/09/25 11:33:37 jer Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3} )
+inherit eutils gnome2-utils python-single-r1
+
+DESCRIPTION="A frontend for find, (s)locate, doodle, tracker, beagle, strigi and pinot"
+HOMEPAGE="http://launchpad.net/catfish-search http://twotoasts.de/index.php/catfish/"
+SRC_URI="http://launchpad.net/${PN}-search/${PV%.*}/${PV}/+download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEPEND="
+ ${PYTHON_DEPS}
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ virtual/freedesktop-icon-theme
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ sys-devel/gettext
+"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ strip-linguas -i po/
+ if ! [[ -z "${LINGUAS}" ]]; then
+ local lang langs=$(find po/ -name '*.po' | sed -e 's|po/||g;s|.po||g')
+ for lang in $langs; do
+ if ! has ${lang} ${LINGUAS}; then
+ rm po/${lang}.po || die
+ fi
+ done
+ fi
+
+ python_fix_shebang .
+ sed -i -e "s:share/doc/\$(APPNAME):share/doc/${PF}:" Makefile.in.in || die
+}
+
+src_configure() {
+ # not autotools based
+ ./configure --prefix=/usr --python="${EPYTHON}" || die
+}
+
+src_install() {
+ default
+ python_optimize "${ED}"/usr/share/${PN}
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }