summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2011-02-09 20:28:25 +0000
committerRaúl Porcel <armin76@gentoo.org>2011-02-09 20:28:25 +0000
commit509810b49e9df99a95167d3a2cdc15c413637cc2 (patch)
treec079fb38883805109942df1d2721e31b0037fb76 /dev-util/catalyst
parentFix a typo. (diff)
downloadgentoo-2-509810b49e9df99a95167d3a2cdc15c413637cc2.tar.gz
gentoo-2-509810b49e9df99a95167d3a2cdc15c413637cc2.tar.bz2
gentoo-2-509810b49e9df99a95167d3a2cdc15c413637cc2.zip
version bump, straight to stable
(Portage version: 2.1.9.25/cvs/Linux ia64, RepoMan options: --force)
Diffstat (limited to 'dev-util/catalyst')
-rw-r--r--dev-util/catalyst/ChangeLog9
-rw-r--r--dev-util/catalyst/catalyst-2.0.6.914.ebuild77
2 files changed, 84 insertions, 2 deletions
diff --git a/dev-util/catalyst/ChangeLog b/dev-util/catalyst/ChangeLog
index f314cfa6a4ce..76bc4f4dbc9b 100644
--- a/dev-util/catalyst/ChangeLog
+++ b/dev-util/catalyst/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/catalyst
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.223 2010/11/01 17:42:10 armin76 Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.224 2011/02/09 20:28:25 armin76 Exp $
+
+*catalyst-2.0.6.914 (09 Feb 2011)
+
+ 09 Feb 2011; Raúl Porcel <armin76@gentoo.org> +catalyst-2.0.6.914.ebuild:
+ version bump, straight to stable
*catalyst-2.0.6.913 (01 Nov 2010)
diff --git a/dev-util/catalyst/catalyst-2.0.6.914.ebuild b/dev-util/catalyst/catalyst-2.0.6.914.ebuild
new file mode 100644
index 000000000000..0ae3e63eb674
--- /dev/null
+++ b/dev-util/catalyst/catalyst-2.0.6.914.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0.6.914.ebuild,v 1.1 2011/02/09 20:28:25 armin76 Exp $
+
+inherit eutils multilib
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://wolf31o2.org/sources/${PN}/${P}.tar.bz2"
+
+DESCRIPTION="release metatool used for creating releases based on Gentoo Linux"
+HOMEPAGE="http://wolf31o2.org/projects/catalyst"
+
+LICENSE="GPL-2"
+SLOT="0"
+#KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+#KEYWORDS=""
+RESTRICT=""
+IUSE="ccache"
+
+DEPEND=""
+RDEPEND="dev-lang/python
+ app-crypt/shash
+ virtual/cdrtools
+ ccache? ( dev-util/ccache )
+ ia64? ( sys-fs/dosfstools )
+ kernel_linux? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )"
+
+pkg_setup() {
+ if use ccache ; then
+ einfo "Enabling ccache support for catalyst."
+ else
+ ewarn "By default, ccache support for catalyst is disabled."
+ ewarn "If this is not what you intended,"
+ ewarn "then you should add ccache to your USE."
+ fi
+ echo
+ einfo "The template spec files are now installed by default. You can find"
+ einfo "them under /usr/share/doc/${PF}/examples"
+ einfo "and they are considered to be the authorative source of information"
+ einfo "on catalyst."
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+}
+
+src_install() {
+ insinto /usr/$(get_libdir)/${PN}
+ exeinto /usr/$(get_libdir)/${PN}
+ doexe catalyst || die "copying catalyst"
+ doins -r arch modules livecd || die "copying files"
+ for x in targets/*; do
+ exeinto /usr/$(get_libdir)/${PN}/$x
+ doexe $x/* || die "copying ${x}"
+ done
+ make_wrapper catalyst /usr/$(get_libdir)/${PN}/catalyst
+ insinto /etc/catalyst
+ doins files/catalyst.conf files/catalystrc || die "copying configuration"
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/* || die
+ dodoc README ChangeLog AUTHORS
+ doman files/catalyst.1
+ # Here is where we actually enable ccache
+ use ccache && \
+ dosed 's:options="autoresume kern:options="autoresume ccache kern:' \
+ /etc/catalyst/catalyst.conf
+ dosed "s:/usr/lib/catalyst:/usr/$(get_libdir)/catalyst:" \
+ /etc/catalyst/catalyst.conf
+}
+
+pkg_postinst() {
+ einfo "You can find more information about catalyst by checking out the"
+ einfo "catalyst project page at:"
+ einfo "http://www.gentoo.org/proj/en/releng/catalyst/index.xml"
+ echo
+}