summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-04-11 23:23:59 +0000
committerMike Frysinger <vapier@gentoo.org>2006-04-11 23:23:59 +0000
commit19335d86e6c41971784f67f002edba012ff9a2fd (patch)
tree2813d3df8e28efd328e6bc0a11d87ba5346c7fc7 /dev-util/catalyst
parentmisc touchups (diff)
downloadgentoo-2-19335d86e6c41971784f67f002edba012ff9a2fd.tar.gz
gentoo-2-19335d86e6c41971784f67f002edba012ff9a2fd.tar.bz2
gentoo-2-19335d86e6c41971784f67f002edba012ff9a2fd.zip
touchups and remove arch cruft
(Portage version: 2.1_pre7-r5)
Diffstat (limited to 'dev-util/catalyst')
-rw-r--r--dev-util/catalyst/catalyst-1.1.10.10.ebuild19
-rw-r--r--dev-util/catalyst/catalyst-2.0_rc41.ebuild27
2 files changed, 17 insertions, 29 deletions
diff --git a/dev-util/catalyst/catalyst-1.1.10.10.ebuild b/dev-util/catalyst/catalyst-1.1.10.10.ebuild
index 6f677ee5b0f3..bcb0d8206867 100644
--- a/dev-util/catalyst/catalyst-1.1.10.10.ebuild
+++ b/dev-util/catalyst/catalyst-1.1.10.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-1.1.10.10.ebuild,v 1.4 2006/04/11 14:28:45 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-1.1.10.10.ebuild,v 1.5 2006/04/11 23:23:59 vapier Exp $
inherit eutils
@@ -15,19 +15,14 @@ IUSE="doc ccache cdr examples"
DEPEND=""
RDEPEND="dev-lang/python
- amd64? (
- sys-apps/setarch )
- ppc64? (
- sys-apps/setarch )
- ccache? (
- dev-util/ccache )
+ amd64? ( sys-apps/setarch )
+ ppc64? ( sys-apps/setarch )
+ ccache? ( dev-util/ccache )
cdr? (
virtual/cdrtools
- !sh? (
- app-misc/zisofs-tools )
- !mips? (
- !sh? (
- >=sys-fs/squashfs-tools-2.1 ) ) )
+ app-misc/zisofs-tools
+ >=sys-fs/squashfs-tools-2.1
+ )
examples? (
dev-util/livecd-kconfigs
dev-util/livecd-specs )"
diff --git a/dev-util/catalyst/catalyst-2.0_rc41.ebuild b/dev-util/catalyst/catalyst-2.0_rc41.ebuild
index fa2c8a44f0fe..88aea60f4897 100644
--- a/dev-util/catalyst/catalyst-2.0_rc41.ebuild
+++ b/dev-util/catalyst/catalyst-2.0_rc41.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0_rc41.ebuild,v 1.2 2006/04/11 14:28:45 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0_rc41.ebuild,v 1.3 2006/04/11 23:23:59 vapier Exp $
inherit eutils
@@ -16,28 +16,21 @@ IUSE="ccache cdr"
DEPEND=""
RDEPEND="dev-lang/python
app-crypt/shash
- amd64? (
- sys-apps/setarch )
- ppc64? (
- sys-apps/setarch )
- ccache? (
- dev-util/ccache )
+ amd64? ( sys-apps/setarch )
+ ppc64? ( sys-apps/setarch )
+ ccache? ( dev-util/ccache )
cdr? (
virtual/cdrtools
- ia64? (
- sys-fs/dosfstools )
- !sh? (
- app-misc/zisofs-tools )
- !mips? (
- !sh? (
- >=sys-fs/squashfs-tools-2.1 ) ) )
+ ia64? ( sys-fs/dosfstools )
+ app-misc/zisofs-tools
+ >=sys-fs/squashfs-tools-2.1
+ )
examples? (
dev-util/livecd-kconfigs
dev-util/livecd-specs )"
pkg_setup() {
- if use ccache
- then
+ if use ccache ; then
einfo "Enabling ccache support for catalyst."
else
ewarn "By default, ccache support for catalyst is disabled."
@@ -53,7 +46,7 @@ pkg_setup() {
src_unpack() {
unpack ${A}
- epatch ${FILESDIR}/${P}-slot.patch
+ epatch "${FILESDIR}"/${P}-slot.patch
}
src_install() {