summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-03-14 20:02:52 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-03-14 20:02:52 +0000
commit085082807b9293e453f564372fad04f28b6cb35c (patch)
treed2723ec0d3f3ad65a4a60da6d0bc0e36ce4926cd /dev-util/catalyst
parentadd warning bout gnome pkgs (diff)
downloadgentoo-2-085082807b9293e453f564372fad04f28b6cb35c.tar.gz
gentoo-2-085082807b9293e453f564372fad04f28b6cb35c.tar.bz2
gentoo-2-085082807b9293e453f564372fad04f28b6cb35c.zip
Removed sed for hash_function and making sure sed for ccache is done behind an if statement.
(Portage version: 2.1_pre6-r2)
Diffstat (limited to 'dev-util/catalyst')
-rw-r--r--dev-util/catalyst/ChangeLog7
-rw-r--r--dev-util/catalyst/catalyst-2.0_rc40.ebuild12
2 files changed, 12 insertions, 7 deletions
diff --git a/dev-util/catalyst/ChangeLog b/dev-util/catalyst/ChangeLog
index 3c244c612173..e79ec19cdb4a 100644
--- a/dev-util/catalyst/ChangeLog
+++ b/dev-util/catalyst/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/catalyst
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.139 2006/03/13 19:45:14 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.140 2006/03/14 20:02:52 wolf31o2 Exp $
+
+ 14 Mar 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+ catalyst-2.0_rc40.ebuild:
+ Removed sed for hash_function and making sure sed for ccache is done behind
+ an if statement.
*catalyst-2.0_rc40 (13 Mar 2006)
diff --git a/dev-util/catalyst/catalyst-2.0_rc40.ebuild b/dev-util/catalyst/catalyst-2.0_rc40.ebuild
index 11ed61028486..78089f3cecd4 100644
--- a/dev-util/catalyst/catalyst-2.0_rc40.ebuild
+++ b/dev-util/catalyst/catalyst-2.0_rc40.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0_rc40.ebuild,v 1.1 2006/03/13 19:45:15 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0_rc40.ebuild,v 1.2 2006/03/14 20:02:52 wolf31o2 Exp $
inherit eutils
@@ -88,12 +88,12 @@ src_install() {
/etc/catalyst2/catalyst2.conf
dosed "s:/var/tmp/catalyst:/var/tmp/catalyst2:" \
/etc/catalyst2/catalyst2.conf
- # This is the dirty hack for missing dev-perl/Archive-Zip
- dosed 's:hash_function="crc32":hash_function="md5":' \
- /etc/catalyst2/catalyst2.conf
# Here is where we actually enable ccache
- dosed 's:options="autoresume kern:options="autoresume ccache kern:' \
- /etc/catalyst2/catalyst2.conf
+ if use ccache
+ then
+ dosed 's:options="autoresume kern:options="autoresume ccache kern:' \
+ /etc/catalyst2/catalyst2.conf
+ fi
}
pkg_postinst() {