summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarien Zwart <marienz@gentoo.org>2006-09-04 15:47:01 +0000
committerMarien Zwart <marienz@gentoo.org>2006-09-04 15:47:01 +0000
commit279a6e79dea93e75dc873692bcce7e30dbebfe61 (patch)
tree66c1359d0b4fff5cab3b7e9b3b2f6c121f01c929 /dev-util/bzr
parentVersion bump. (diff)
downloadgentoo-2-279a6e79dea93e75dc873692bcce7e30dbebfe61.tar.gz
gentoo-2-279a6e79dea93e75dc873692bcce7e30dbebfe61.tar.bz2
gentoo-2-279a6e79dea93e75dc873692bcce7e30dbebfe61.zip
Version bump.
(Portage version: 2.1.1_rc1-r2)
Diffstat (limited to 'dev-util/bzr')
-rw-r--r--dev-util/bzr/ChangeLog8
-rw-r--r--dev-util/bzr/bzr-0.10.ebuild72
-rw-r--r--dev-util/bzr/files/bzr-0.10-fix-manpage-location.patch13
-rw-r--r--dev-util/bzr/files/digest-bzr-0.103
4 files changed, 95 insertions, 1 deletions
diff --git a/dev-util/bzr/ChangeLog b/dev-util/bzr/ChangeLog
index 003576a50c63..477962136d5d 100644
--- a/dev-util/bzr/ChangeLog
+++ b/dev-util/bzr/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/bzr
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/bzr/ChangeLog,v 1.18 2006/08/24 18:46:31 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bzr/ChangeLog,v 1.19 2006/09/04 15:47:01 marienz Exp $
+
+*bzr-0.10 (04 Sep 2006)
+
+ 04 Sep 2006; Marien Zwart <marienz@gentoo.org>
+ +files/bzr-0.10-fix-manpage-location.patch, +bzr-0.10.ebuild:
+ Version bump.
*bzr-0.9 (24 Aug 2006)
diff --git a/dev-util/bzr/bzr-0.10.ebuild b/dev-util/bzr/bzr-0.10.ebuild
new file mode 100644
index 000000000000..54e5275cb2a9
--- /dev/null
+++ b/dev-util/bzr/bzr-0.10.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bzr/bzr-0.10.ebuild,v 1.1 2006/09/04 15:47:01 marienz Exp $
+
+inherit distutils bash-completion elisp-common eutils
+
+DESCRIPTION="next generation distributed version control"
+HOMEPAGE="http://bazaar-vcs.org/"
+SRC_URI="http://bazaar-vcs.org/releases/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86 ~x86-fbsd"
+IUSE="emacs"
+
+DEPEND=">=dev-lang/python-2.4
+ dev-python/celementtree
+ emacs? ( virtual/emacs )
+ >=dev-python/paramiko-1.5"
+
+PYTHON_MODNAME="bzrlib"
+
+DOCS="HACKING NEWS NEWS.developers"
+
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Install the manpage in /usr/share/man instead of /usr/man
+ epatch "${FILESDIR}/${P}-fix-manpage-location.patch"
+}
+
+src_compile() {
+ distutils_src_compile
+ if use emacs; then
+ elisp-compile contrib/emacs/bzr-mode.el || die "Emacs modules failed!"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+ if use emacs; then
+ insinto "${SITELISP}"
+ doins contrib/emacs/bzr-mode.el*
+ elisp-site-file-install "${FILESDIR}/70bzr-gentoo.el"
+ fi
+ insinto /usr/share/zsh/site-functions
+ doins contrib/zsh/_bzr
+ dobashcompletion contrib/bash/bzr
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ use emacs && elisp-site-regen
+ bash-completion_pkg_postinst
+
+ einfo "If you just upgraded from a version of bzr older than 0.9"
+ einfo "you should rename your ~/.bazaar/branches.conf to locations.conf"
+ einfo "(see /usr/share/doc/${PF}/NEWS.gz)"
+}
+
+pkg_postrm() {
+ distutils_pkg_postrm
+ # regenerate site-gentoo if we are merged USE=emacs and unmerged
+ # USE=-emacs
+ has_version virtual/emacs && elisp-site-regen
+}
+
+src_test() {
+ "${python}" bzr --no-plugins selftest || die "bzr selftest failed"
+}
diff --git a/dev-util/bzr/files/bzr-0.10-fix-manpage-location.patch b/dev-util/bzr/files/bzr-0.10-fix-manpage-location.patch
new file mode 100644
index 000000000000..00d1e60e2d83
--- /dev/null
+++ b/dev-util/bzr/files/bzr-0.10-fix-manpage-location.patch
@@ -0,0 +1,13 @@
+=== modified file 'setup.py'
+--- setup.py 2006-09-04 14:46:59 +0000
++++ setup.py 2006-09-04 14:47:28 +0000
+@@ -207,7 +207,7 @@
+ else:
+ # std setup
+ ARGS = {'scripts': ['bzr'],
+- 'data_files': [('man/man1', ['bzr.1'])],
++ 'data_files': [('share/man/man1', ['bzr.1'])],
+ 'cmdclass': {'build': bzr_build,
+ 'install_scripts': my_install_scripts,
+ },
+
diff --git a/dev-util/bzr/files/digest-bzr-0.10 b/dev-util/bzr/files/digest-bzr-0.10
new file mode 100644
index 000000000000..7872ef24a2d2
--- /dev/null
+++ b/dev-util/bzr/files/digest-bzr-0.10
@@ -0,0 +1,3 @@
+MD5 8a21693efe9b06bed04fa4e8a74b7e83 bzr-0.10.tar.gz 950911
+RMD160 046dd9479e516b6e9b526df5f9baa2a7ec185a5b bzr-0.10.tar.gz 950911
+SHA256 4a9b5b2d0b2c33c91dabeb0831b3da660189eb38ad9c28c929ea64b79fecc20f bzr-0.10.tar.gz 950911