summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-02-15 18:16:40 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-02-15 18:16:40 +0000
commit748662d95b16b0220f35882831e823d1df5a3c86 (patch)
tree6f10d075de19dee3e74eb8db0fff6338c9cd83dd /dev-util/bustle
parentFix patch for old versions. bug #369839 (diff)
downloadgentoo-2-748662d95b16b0220f35882831e823d1df5a3c86.tar.gz
gentoo-2-748662d95b16b0220f35882831e823d1df5a3c86.tar.bz2
gentoo-2-748662d95b16b0220f35882831e823d1df5a3c86.zip
Unbroke FEATURES=test (upstream didn't provide all the files) for bug #403741 by Chris Reffett.
(Portage version: 2.2.0_alpha86_p16/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/bustle')
-rw-r--r--dev-util/bustle/ChangeLog6
-rw-r--r--dev-util/bustle/bustle-0.4.0.ebuild18
2 files changed, 20 insertions, 4 deletions
diff --git a/dev-util/bustle/ChangeLog b/dev-util/bustle/ChangeLog
index 7ee071529bee..aa04096805f0 100644
--- a/dev-util/bustle/ChangeLog
+++ b/dev-util/bustle/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/bustle
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/bustle/ChangeLog,v 1.6 2012/01/19 19:14:56 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bustle/ChangeLog,v 1.7 2012/02/15 18:16:40 slyfox Exp $
+
+ 15 Feb 2012; Sergei Trofimovich <slyfox@gentoo.org> bustle-0.4.0.ebuild:
+ Unbroke FEATURES=test (upstream didn't provide all the files) for bug #403741
+ by Chris Reffett.
*bustle-0.4.0 (19 Jan 2012)
diff --git a/dev-util/bustle/bustle-0.4.0.ebuild b/dev-util/bustle/bustle-0.4.0.ebuild
index 6bf834c76349..5e837c3f50f4 100644
--- a/dev-util/bustle/bustle-0.4.0.ebuild
+++ b/dev-util/bustle/bustle-0.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/bustle/bustle-0.4.0.ebuild,v 1.1 2012/01/19 19:14:56 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bustle/bustle-0.4.0.ebuild,v 1.2 2012/02/15 18:16:40 slyfox Exp $
# ebuild generated by hackport 0.2.14
@@ -11,7 +11,7 @@ inherit haskell-cabal toolchain-funcs
DESCRIPTION="Draw pretty sequence diagrams of D-Bus traffic"
HOMEPAGE="http://hackage.haskell.org/package/bustle"
-SRC_URI="http://willthompson.co.uk/${PN}/releases/${PV}/${P}.tar.gz"
+SRC_URI="http://willthompson.co.uk/${PN}/releases/${PV}/${P}.tar.gz http://dev.gentoo.org/~slyfox/bustle-0.4.0-tests.tar.gz"
LICENSE="LGPL-2 GPL-2" # bustle-dbus-monitor.c is GPL-2, rest is LGPL-2
SLOT="0"
@@ -36,7 +36,19 @@ DEPEND="${RDEPEND}
dev-haskell/parsec
dev-haskell/pcap
dev-haskell/text
- >=dev-lang/ghc-6.10.1"
+ >=dev-lang/ghc-6.10.1
+ test? (
+ dev-haskell/gtk
+ dev-haskell/hunit
+ dev-haskell/quickcheck
+ dev-haskell/test-framework
+ dev-haskell/test-framework-hunit
+ )
+"
+
+src_configure() {
+ cabal_src_configure $(use test && use_enable test tests) #395351
+}
src_compile() {
# compile haskell part