summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Felisberto <humpback@gentoo.org>2008-09-26 15:11:46 +0000
committerGustavo Felisberto <humpback@gentoo.org>2008-09-26 15:11:46 +0000
commitff7b14b0a18d007137877b3f00aac92352ddbb6f (patch)
treebedc5dbbc06f69f082e29aaebd630e88b88e62e3 /dev-util/bouml
parentStable for HPPA (bug #238535). (diff)
downloadgentoo-2-ff7b14b0a18d007137877b3f00aac92352ddbb6f.tar.gz
gentoo-2-ff7b14b0a18d007137877b3f00aac92352ddbb6f.tar.bz2
gentoo-2-ff7b14b0a18d007137877b3f00aac92352ddbb6f.zip
After talking to ferdy I bumped this to lattest release
(Portage version: 2.2_rc8/cvs/Linux 2.6.25-tuxonice-r6 i686)
Diffstat (limited to 'dev-util/bouml')
-rw-r--r--dev-util/bouml/bouml-4.6.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-util/bouml/bouml-4.6.1.ebuild b/dev-util/bouml/bouml-4.6.1.ebuild
new file mode 100644
index 000000000000..5a7c267e5052
--- /dev/null
+++ b/dev-util/bouml/bouml-4.6.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bouml/bouml-4.6.1.ebuild,v 1.1 2008/09/26 15:11:46 humpback Exp $
+
+EAPI=1
+
+inherit multilib qt3
+
+MY_P="${PN}_${PV}"
+
+DESCRIPTION="Free UML 2 tool with code generation"
+HOMEPAGE="http://bouml.free.fr/"
+SRC_URI="http://bouml.free.fr/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="x11-libs/qt:3"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ find src/ genplugouts/ -type f -name "*.pro" | while read file; do
+ local subdir="${file%/*}"
+ eqmake3 "${file}" -o "${subdir}"/Makefile
+ emake -C "${subdir}" || die "emake failed in ${subdir}"
+ done
+}
+
+src_install() {
+ emake BOUML_LIB="/usr/$(get_libdir)/bouml" DESTDIR="${D}" install \
+ || die "emake install failed"
+}