summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-24 11:30:08 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-24 11:30:08 +0000
commite3f893ec45e8ee37dcbce43680193bfd9b7bb90c (patch)
tree7710307ff9590ab70f50c84057c8f17c4310e9f3 /dev-util/bouml
parentanother bunch of asm "fixes" (diff)
downloadgentoo-2-e3f893ec45e8ee37dcbce43680193bfd9b7bb90c.tar.gz
gentoo-2-e3f893ec45e8ee37dcbce43680193bfd9b7bb90c.tar.bz2
gentoo-2-e3f893ec45e8ee37dcbce43680193bfd9b7bb90c.zip
Version bump.
(Portage version: 2.1.2_pre3-r6)
Diffstat (limited to 'dev-util/bouml')
-rw-r--r--dev-util/bouml/ChangeLog7
-rw-r--r--dev-util/bouml/bouml-2.18.ebuild33
-rw-r--r--dev-util/bouml/files/digest-bouml-2.183
3 files changed, 42 insertions, 1 deletions
diff --git a/dev-util/bouml/ChangeLog b/dev-util/bouml/ChangeLog
index 8196a7516c2a..3c13756c786c 100644
--- a/dev-util/bouml/ChangeLog
+++ b/dev-util/bouml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/bouml
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/bouml/ChangeLog,v 1.6 2006/10/17 18:37:44 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bouml/ChangeLog,v 1.7 2006/10/24 11:30:08 flameeyes Exp $
+
+*bouml-2.18 (24 Oct 2006)
+
+ 24 Oct 2006; Diego Pettenò <flameeyes@gentoo.org> +bouml-2.18.ebuild:
+ Version bump.
*bouml-2.17.2 (17 Oct 2006)
diff --git a/dev-util/bouml/bouml-2.18.ebuild b/dev-util/bouml/bouml-2.18.ebuild
new file mode 100644
index 000000000000..c48b23e9689b
--- /dev/null
+++ b/dev-util/bouml/bouml-2.18.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bouml/bouml-2.18.ebuild,v 1.1 2006/10/24 11:30:08 flameeyes Exp $
+
+inherit qt3 toolchain-funcs multilib eutils
+
+MY_P="${PN}_${PV}"
+
+DESCRIPTION="Free UML 2 tool box with C++, Java and Idl code generation"
+HOMEPAGE="http://bouml.free.fr/"
+SRC_URI="http://bouml.free.fr/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="$(qt_min_version 3)"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ emake QMAKE="${QTDIR}/bin/qmake" \
+ CC="$(tc-getCC) ${CFLAGS}" \
+ CXX="$(tc-getCXX) ${CXXFLAGS}" \
+ LINK="$(tc-getCXX) ${LDFLAGS}" \
+ || die "emake failed"
+}
+
+src_install() {
+ emake BOUML_LIB="/usr/$(get_libdir)/bouml" DESTDIR="${D}" install || die "emake install failed"
+}
diff --git a/dev-util/bouml/files/digest-bouml-2.18 b/dev-util/bouml/files/digest-bouml-2.18
new file mode 100644
index 000000000000..ff84a75b998f
--- /dev/null
+++ b/dev-util/bouml/files/digest-bouml-2.18
@@ -0,0 +1,3 @@
+MD5 b27eec0273e789829ac20d3b7abaa52a bouml_2.18.tar.gz 2892098
+RMD160 0d0e32c1ab5bd8d27240b4fe22bfceb38b60132f bouml_2.18.tar.gz 2892098
+SHA256 1d7250377e51a3ab4333cc31eead4cd8ba92f5bce390488454ba958373d7f5d1 bouml_2.18.tar.gz 2892098