summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2009-04-04 10:28:08 +0000
committerThilo Bangert <bangert@gentoo.org>2009-04-04 10:28:08 +0000
commit5c0c135fe796df47e3b7be644f10e1c5c8b88d50 (patch)
tree6c69303e6bb00fb1ae55ac69f33e55de1daa5cc9 /dev-util/bouml
parentVersion bump (diff)
downloadgentoo-2-5c0c135fe796df47e3b7be644f10e1c5c8b88d50.tar.gz
gentoo-2-5c0c135fe796df47e3b7be644f10e1c5c8b88d50.tar.bz2
gentoo-2-5c0c135fe796df47e3b7be644f10e1c5c8b88d50.zip
version bump - bug #250092
(Portage version: 2.2_rc26/cvs/Linux i686)
Diffstat (limited to 'dev-util/bouml')
-rw-r--r--dev-util/bouml/ChangeLog7
-rw-r--r--dev-util/bouml/bouml-4.12.1.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-util/bouml/ChangeLog b/dev-util/bouml/ChangeLog
index 479ea85513a7..1db23473b9ca 100644
--- a/dev-util/bouml/ChangeLog
+++ b/dev-util/bouml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/bouml
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/bouml/ChangeLog,v 1.36 2009/03/21 15:42:20 jmbsvicetto Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bouml/ChangeLog,v 1.37 2009/04/04 10:28:08 bangert Exp $
+
+*bouml-4.12.1 (04 Apr 2009)
+
+ 04 Apr 2009; Thilo Bangert <bangert@gentoo.org> +bouml-4.12.1.ebuild:
+ version bump - bug #250092
21 Mar 2009; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
metadata.xml:
diff --git a/dev-util/bouml/bouml-4.12.1.ebuild b/dev-util/bouml/bouml-4.12.1.ebuild
new file mode 100644
index 000000000000..b71a79ad9bd1
--- /dev/null
+++ b/dev-util/bouml/bouml-4.12.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bouml/bouml-4.12.1.ebuild,v 1.1 2009/04/04 10:28:08 bangert Exp $
+
+EAPI=1
+
+inherit multilib qt3
+
+MY_P="${PN}_${PV}"
+
+DESCRIPTION="Free UML 2 tool with code generation"
+HOMEPAGE="http://bouml.free.fr/"
+SRC_URI="http://downloads.sourceforge.net/bouml/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="x11-libs/qt:3"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ find src/ genplugouts/ -type f -name "*.pro" | while read file; do
+ local subdir="${file%/*}"
+ eqmake3 "${file}" -o "${subdir}"/Makefile
+ emake -C "${subdir}" || die "emake failed in ${subdir}"
+ done
+}
+
+src_install() {
+ emake BOUML_LIB="/usr/$(get_libdir)/bouml" DESTDIR="${D}" install \
+ || die "emake install failed"
+}