summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2007-11-28 20:26:26 +0000
committerTiziano Müller <dev-zero@gentoo.org>2007-11-28 20:26:26 +0000
commit084d827e2cb53aa8f613f2857c931e51342503bf (patch)
tree74c512e1814c722d862d4f30a68caf8921980cf6 /dev-util/bouml/bouml-3.3.4.ebuild
parentamd64 stable wrt #196392 (diff)
downloadgentoo-2-084d827e2cb53aa8f613f2857c931e51342503bf.tar.gz
gentoo-2-084d827e2cb53aa8f613f2857c931e51342503bf.tar.bz2
gentoo-2-084d827e2cb53aa8f613f2857c931e51342503bf.zip
Version bump. Dropped old buggy version.
(Portage version: 2.1.4_rc4)
Diffstat (limited to 'dev-util/bouml/bouml-3.3.4.ebuild')
-rw-r--r--dev-util/bouml/bouml-3.3.4.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/bouml/bouml-3.3.4.ebuild b/dev-util/bouml/bouml-3.3.4.ebuild
new file mode 100644
index 000000000000..da7ab5416733
--- /dev/null
+++ b/dev-util/bouml/bouml-3.3.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bouml/bouml-3.3.4.ebuild,v 1.1 2007/11/28 20:26:25 dev-zero Exp $
+
+inherit multilib qt3
+
+MY_P="${PN}_${PV}"
+
+DESCRIPTION="Free UML 2 tool with code generation"
+HOMEPAGE="http://bouml.free.fr/"
+SRC_URI="http://bouml.free.fr/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="$(qt_min_version 3)"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ find src/ genplugouts/ -type f -name "*.pro" | while read file; do
+ local subdir="${file%/*}"
+ eqmake3 "${file}" -o "${subdir}"/Makefile
+ emake -C "${subdir}" || die "emake failed in ${subdir}"
+ done
+}
+
+src_install() {
+ emake BOUML_LIB="/usr/$(get_libdir)/bouml" DESTDIR="${D}" install \
+ || die "emake install failed"
+}