summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2012-08-19 18:22:31 +0000
committerTiziano Müller <dev-zero@gentoo.org>2012-08-19 18:22:31 +0000
commit0afc5eabbf99b03ce9aab9fa109e9a3526f8358e (patch)
tree5ef82dcdef02973655b34be85d81692216dd1b37 /dev-util/boost-build
parentadd williamh as maintainer (diff)
downloadgentoo-2-0afc5eabbf99b03ce9aab9fa109e9a3526f8358e.tar.gz
gentoo-2-0afc5eabbf99b03ce9aab9fa109e9a3526f8358e.tar.bz2
gentoo-2-0afc5eabbf99b03ce9aab9fa109e9a3526f8358e.zip
Fix tests. Fix installation of boost-build python-rewrite and optimize/cleanup installed .py files (bug #324375). Rechecked build regarding LDFLAGS (bug #334467), replaced workaround with a patch and added verbosity flag to the bjam-call.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/boost-build')
-rw-r--r--dev-util/boost-build/ChangeLog12
-rw-r--r--dev-util/boost-build/boost-build-1.50.0-r1.ebuild146
-rw-r--r--dev-util/boost-build/files/boost-build-1.50.0-fix-test.patch11
-rw-r--r--dev-util/boost-build/files/boost-build-1.50.0-respect-c_ld-flags.patch44
4 files changed, 212 insertions, 1 deletions
diff --git a/dev-util/boost-build/ChangeLog b/dev-util/boost-build/ChangeLog
index 52453672b022..3c389a198360 100644
--- a/dev-util/boost-build/ChangeLog
+++ b/dev-util/boost-build/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-util/boost-build
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/ChangeLog,v 1.96 2012/07/21 17:18:50 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/ChangeLog,v 1.97 2012/08/19 18:22:31 dev-zero Exp $
+
+*boost-build-1.50.0-r1 (19 Aug 2012)
+
+ 19 Aug 2012; Tiziano Müller <dev-zero@gentoo.org>
+ +boost-build-1.50.0-r1.ebuild, +files/boost-build-1.50.0-fix-test.patch,
+ +files/boost-build-1.50.0-respect-c_ld-flags.patch:
+ Fix tests. Fix installation of boost-build python-rewrite and optimize/cleanup
+ installed .py files (bug #324375). Rechecked build regarding LDFLAGS (bug
+ #334467), replaced workaround with a patch and added verbosity flag to the
+ bjam-call.
21 Jul 2012; Jeroen Roovers <jer@gentoo.org> boost-build-1.49.0.ebuild:
Stable for HPPA (bug #425354).
diff --git a/dev-util/boost-build/boost-build-1.50.0-r1.ebuild b/dev-util/boost-build/boost-build-1.50.0-r1.ebuild
new file mode 100644
index 000000000000..98357d5efdfb
--- /dev/null
+++ b/dev-util/boost-build/boost-build-1.50.0-r1.ebuild
@@ -0,0 +1,146 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/boost-build-1.50.0-r1.ebuild,v 1.1 2012/08/19 18:22:31 dev-zero Exp $
+
+EAPI="4"
+PYTHON_DEPEND="python? 2"
+
+inherit eutils flag-o-matic python toolchain-funcs versionator
+
+MY_PV=$(replace_all_version_separators _)
+MAJOR_PV="$(replace_all_version_separators _ $(get_version_component_range 1-2))"
+
+DESCRIPTION="A system for large project software construction, which is simple to use and powerful."
+HOMEPAGE="http://www.boost.org/doc/tools/build/index.html"
+SRC_URI="mirror://sourceforge/boost/boost_${MY_PV}.tar.bz2"
+
+LICENSE="Boost-1.0"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="examples python test"
+
+RDEPEND="!<dev-libs/boost-1.34.0
+ !<=dev-util/boost-build-1.35.0-r1"
+DEPEND="${RDEPEND}
+ test? ( =dev-lang/python-2*
+ sys-apps/diffutils )"
+
+S="${WORKDIR}/boost_${MY_PV}/tools/build/v2"
+
+pkg_setup() {
+ if use python ; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_unpack() {
+ tar xjpf "${DISTDIR}/${A}" boost_${MY_PV}/tools/build/v2 || die "unpacking tar failed"
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}/${PN}-1.48.0-support_dots_in_python-buildid.patch" \
+ "${FILESDIR}/${PN}-1.48.0-disable_python_rpath.patch" \
+ "${FILESDIR}/${P}-respect-c_ld-flags.patch" \
+ "${FILESDIR}/${P}-fix-test.patch"
+
+ # Remove stripping option
+ cd "${S}/engine"
+ sed -i -e 's|-s\b||' \
+ build.jam || die "sed failed"
+
+ # Force regeneration
+ rm jambase.c || die
+
+ # This patch allows us to fully control optimization
+ # and stripping flags when bjam is used as build-system
+ # We simply extend the optimization and debug-symbols feature
+ # with empty dummies called 'none'
+ cd "${S}"
+ sed -i \
+ -e 's/\(off speed space\)/\1 none/' \
+ -e 's/\(debug-symbols : on off\)/\1 none/' \
+ tools/builtin.jam || die "sed failed"
+}
+
+src_configure() {
+ # - install versioned tools
+ # - install into versioned directory
+ # - don't install examples
+ sed -i \
+ -e "s|b2|b2-${MAJOR_PV}|" \
+ -e "s|bjam|bjam-${MAJOR_PV}|" \
+ -e "s| boost-build|boost-build-${MAJOR_PV}|" \
+ -e '/$(e2)/d' \
+ Jamroot.jam || die "sed failed"
+
+ # For slotting
+ sed -i \
+ -e "s|/usr/share/boost-build|/usr/share/boost-build-${MAJOR_PV}|" \
+ engine/Jambase || die "sed failed"
+
+ if use python ; then
+ # replace versions by user-selected one (TODO: fix this when slot-op
+ # deps are available to always match the best version available)
+ sed -i \
+ -e "s|2.7 2.6 2.5 2.4 2.3 2.2|${PYTHON_ABI}|" \
+ engine/build.jam || die "sed failed"
+ fi
+}
+
+src_compile() {
+ cd engine
+
+ local toolset
+
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ toolset=darwin
+ else
+ # Using boost's generic toolset here, which respects CC and CFLAGS
+ toolset=cc
+ fi
+
+ CC=$(tc-getCC) ./build.sh ${toolset} -d+2 $(use_with python python /usr) || die "building bjam failed"
+}
+
+src_install() {
+ newbin engine/bin.*/bjam bjam-${MAJOR_PV}
+ newbin engine/bin.*/b2 b2-${MAJOR_PV}
+
+ insinto /usr/share/boost-build-${MAJOR_PV}
+ doins -r boost-build.jam bootstrap.jam build-system.jam site-config.jam user-config.jam *.py \
+ build kernel options tools util || die
+
+ rm "${D}/usr/share/boost-build-${MAJOR_PV}/build/project.ann.py" || die "removing faulty python file failed"
+ use python || find "${D}/usr/share/boost-build-${MAJOR_PV}" -iname "*.py" -delete || die "removing experimental python files failed"
+
+ dodoc changes.txt hacking.txt release_procedure.txt \
+ notes/build_dir_option.txt notes/relative_source_paths.txt
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r example
+ fi
+}
+
+src_test() {
+ cd test
+
+ export TMP="${T}"
+
+ DO_DIFF="${PREFIX}/usr/bin/diff" $(PYTHON -2) test_all.py
+
+ if [ -s test_results.txt ] ; then
+ eerror "At least one test failed: $(<test_results.txt)"
+ die "tests failed"
+ fi
+}
+
+pkg_postinst() {
+ use python && python_mod_optimize /usr/share/boost-build-${MAJOR_PV}/{build,kernel,tools,tools/doxygen,util}
+}
+
+pkg_postrm() {
+ use python && python_mod_cleanup /usr/share/boost-build-${MAJOR_PV}/{build,kernel,tools,tools/doxygen,util}
+}
diff --git a/dev-util/boost-build/files/boost-build-1.50.0-fix-test.patch b/dev-util/boost-build/files/boost-build-1.50.0-fix-test.patch
new file mode 100644
index 000000000000..31f8db2ee104
--- /dev/null
+++ b/dev-util/boost-build/files/boost-build-1.50.0-fix-test.patch
@@ -0,0 +1,11 @@
+--- test/startup_v2.py.orig 2012-08-19 11:48:12.020600368 +0200
++++ test/startup_v2.py 2012-08-19 11:48:28.564516623 +0200
+@@ -14,7 +14,7 @@
+ return re.match(expected,actual,re.DOTALL) != None
+
+ # Test the v1 startup behavior.
+-t = BoostBuild.Tester(match=match_re, boost_build_path='', pass_toolset=0)
++t = BoostBuild.Tester(match=match_re, boost_build_path='/invalid/location', pass_toolset=0)
+
+ t.set_tree('startup')
+
diff --git a/dev-util/boost-build/files/boost-build-1.50.0-respect-c_ld-flags.patch b/dev-util/boost-build/files/boost-build-1.50.0-respect-c_ld-flags.patch
new file mode 100644
index 000000000000..6c60777f71ba
--- /dev/null
+++ b/dev-util/boost-build/files/boost-build-1.50.0-respect-c_ld-flags.patch
@@ -0,0 +1,44 @@
+--- engine/build.jam.orig 2012-08-19 09:47:23.916383518 +0200
++++ engine/build.jam 2012-08-19 09:53:38.011554690 +0200
+@@ -179,10 +179,10 @@
+ if ! $(CC) { CC = cc ; }
+ toolset cc $(CC) : "-o " : -D
+ : $(CFLAGS)
+- [ opt --release : -s -O ]
++ [ opt --release : ]
+ [ opt --debug : -g ]
+ -I$(--python-include) -I$(--extra-include)
+- : $(LIBS) -L$(--python-lib[1]) -l$(--python-lib[2]) ;
++ : $(LDFLAGS) $(LIBS) -L$(--python-lib[1]) -l$(--python-lib[2]) ;
+ ## Comeau C/C++ 4.x
+ toolset como como : "-o " : -D
+ : --c
+@@ -201,11 +201,11 @@
+ ## MacOSX Darwin, using GCC 2.9.x, 3.x
+ toolset darwin cc : "-o " : -D
+ :
+- [ opt --release : -Wl,-x -O3 -finline-functions ]
++ [ opt --release : -Wl,-x -finline-functions ]
+ [ opt --debug : -g -O0 -fno-inline -pg ]
+ [ opt --profile : -Wl,-x -O3 -finline-functions -g -pg ]
+ -I$(--python-include) -I$(--extra-include)
+- : -L$(--python-lib[1]) -l$(--python-lib[2]) ;
++ : $(LDFLAGS) -L$(--python-lib[1]) -l$(--python-lib[2]) ;
+ ## GCC 2.x, 3.x, 4.x
+ toolset gcc gcc : "-o " : -D
+ : -pedantic -fno-strict-aliasing
+--- engine/build.sh.orig 2012-08-19 12:09:56.400780866 +0200
++++ engine/build.sh 2012-08-19 12:10:49.728499203 +0200
+@@ -224,9 +224,9 @@
+ cc)
+ if test -z "$CC" ; then CC=cc ; fi
+ BOOST_JAM_CC=$CC
+- BOOST_JAM_OPT_JAM="$BOOST_JAM_OPT_JAM $CFLAGS $LIBS"
+- BOOST_JAM_OPT_MKJAMBASE="$BOOST_JAM_OPT_MKJAMBASE $CFLAGS $LIBS"
+- BOOST_JAM_OPT_YYACC="$BOOST_JAM_OPT_YYACC $CFLAGS $LIBS"
++ BOOST_JAM_OPT_JAM="$BOOST_JAM_OPT_JAM $CFLAGS $LDFLAGS $LIBS"
++ BOOST_JAM_OPT_MKJAMBASE="$BOOST_JAM_OPT_MKJAMBASE $CFLAGS $LDFLAGS $LIBS"
++ BOOST_JAM_OPT_YYACC="$BOOST_JAM_OPT_YYACC $CFLAGS $LDFLAGS $LIBS"
+ ;;
+
+ qcc)