summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-02-17 04:05:58 +0000
committerMike Frysinger <vapier@gentoo.org>2003-02-17 04:05:58 +0000
commite45aaf0dd46b02e9cf2a9dd12593ec82d08b4f39 (patch)
tree09dd68f5330e7e0796acc088d02b65fda268a43b /dev-util/bitkeeper
parentAdded ~x86. having problems with repoman (diff)
downloadgentoo-2-e45aaf0dd46b02e9cf2a9dd12593ec82d08b4f39.tar.gz
gentoo-2-e45aaf0dd46b02e9cf2a9dd12593ec82d08b4f39.tar.bz2
gentoo-2-e45aaf0dd46b02e9cf2a9dd12593ec82d08b4f39.zip
fix SRC_URI handling
Diffstat (limited to 'dev-util/bitkeeper')
-rw-r--r--dev-util/bitkeeper/ChangeLog5
-rw-r--r--dev-util/bitkeeper/bitkeeper-3.0.1.ebuild54
-rw-r--r--dev-util/bitkeeper/files/digest-bitkeeper-3.0.16
3 files changed, 36 insertions, 29 deletions
diff --git a/dev-util/bitkeeper/ChangeLog b/dev-util/bitkeeper/ChangeLog
index 88c5b2c9d242..46577bb7a5b3 100644
--- a/dev-util/bitkeeper/ChangeLog
+++ b/dev-util/bitkeeper/ChangeLog
@@ -1,9 +1,12 @@
# ChangeLog for dev-util/bitkeeper
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/bitkeeper/ChangeLog,v 1.6 2003/02/12 06:38:52 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bitkeeper/ChangeLog,v 1.7 2003/02/17 04:05:58 vapier Exp $
*bitkeeper-3.0.1 (18 Jan 2003)
+ 16 Feb 2003; Mike Frysinger <vapier@gentoo.org> :
+ Fixed the way SRC_URI/fetching is handled
+
18 Jan 2003; Martin Holzer <mholzer@gentoo.org> bitkeeper-3.0.1.ebuild ChangeLog :
Version bumped since 3.0 is no more available.
diff --git a/dev-util/bitkeeper/bitkeeper-3.0.1.ebuild b/dev-util/bitkeeper/bitkeeper-3.0.1.ebuild
index 77a3492e7872..f4f5c6353716 100644
--- a/dev-util/bitkeeper/bitkeeper-3.0.1.ebuild
+++ b/dev-util/bitkeeper/bitkeeper-3.0.1.ebuild
@@ -1,55 +1,53 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/bitkeeper/bitkeeper-3.0.1.ebuild,v 1.2 2003/02/13 11:47:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bitkeeper/bitkeeper-3.0.1.ebuild,v 1.3 2003/02/17 04:05:58 vapier Exp $
-DESCRIPTION="BitKeeper is a scalable configuration management system."
-SRC_URI=""
-HOMEPAGE="http://www.bitkeeper.com"
+DESCRIPTION="scalable configuration management system"
+HOMEPAGE="http://www.bitkeeper.com/"
+SRC_URI="x86? ( bk-3.0.1-x86-glibc22-linux.bin )
+ ppc? ( bk-3.0.1-powerpc-glibc21-linux.bin )
+ sparc? ( bk-3.0.1-sparc-glibc21-linux.bin )
+ alpha? ( bk-3.0.1-alpha-glibc21-linux.bin )
+ arm? ( bk-3.0.1-arm-glibc21-linux.bin )
+ hppa? ( bk-3.0.1-hppa-glibc22-linux.bin )"
SLOT="0"
LICENSE="BKL"
-KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~arm ~hppa"
-DEPEND=">=virtual/glibc-2.2
- >=dev-lang/tcl-8.3.3
+DEPEND="virtual/glibc"
+RDEPEND=">=dev-lang/tcl-8.3.3
X? ( >=dev-lang/tk-8.3.3 )"
-# I'm not sure what the official way to do this is...
-use 'x86' >/dev/null && A="bk-3.0.1-x86-glibc22-linux.bin"
-use 'ppc' >/dev/null && A="bk-3.0.1-powerpc-glibc21-linux.bin"
-use 'sparc' >/dev/null && A="bk-3.0.1-sparc-glibc21-linux.bin"
-use 'alpha' >/dev/null && A="bk-3.0.1-alpha-glibc21-linux.bin"
-
-pkg_setup() {
- if [ ! -f ${DISTDIR}/${A} ] ; then
- eerror "You need to perform the following steps to install this package:"
- eerror "- Sign up at ${HOMEPAGE}"
- eerror "- Check your mail and visit the download location"
- eerror "- Download ${A} and place it in ${DISTDIR}"
- eerror "- emerge this package again"
- die "package must be downloaded"
- fi
+RESTRICT="fetch"
+
+S=${WORKDIR}
+
+pkg_nofetch() {
+ eerror "You need to perform the following steps to install this package:"
+ eerror " - Sign up at ${HOMEPAGE}"
+ eerror " - Check your mail and visit the download location"
+ eerror " - Download ${A} and place it in ${DISTDIR}"
+ eerror " - emerge this package again"
}
src_unpack() {
- mkdir ${S}
cp ${DISTDIR}/${A} ${S}/${A}
chmod 755 ${S}/${A}
echo 'none' | ${S}/${A} > ${S}/output 2>/dev/null
installer=`sed -n -e "s/Installation script: \(.*\)/\1/p" ${S}/output`
archive=`sed -n -e "s/Gzipped tar archive: \(.*\)/\1/p" ${S}/output`
- mv $installer ${S}/installer
- mv $archive ${S}/archive
+ mv ${installer} ${S}/installer
+ mv ${archive} ${S}/archive
}
src_install() {
dodir /opt /etc/env.d
- cd ${D}/opt && tar -xzpf ${S}/archive
- mv ${D}/opt/bitkeeper ${D}/opt/${P}
+ tar -xzpf ${S}/archive
+ mv bitkeeper ${D}/opt/${P}
chown -R root:root ${D}/opt/${P}
chmod -R u+w,go-w ${D}/opt/${P}
cat <<EOF >${D}/etc/env.d/10bitkeeper
-# Generated by ${P}.ebuild
PATH=/opt/${P}
ROOTPATH=/opt/${P}
MANPATH=/opt/${P}/man
diff --git a/dev-util/bitkeeper/files/digest-bitkeeper-3.0.1 b/dev-util/bitkeeper/files/digest-bitkeeper-3.0.1
new file mode 100644
index 000000000000..9fffe1deae45
--- /dev/null
+++ b/dev-util/bitkeeper/files/digest-bitkeeper-3.0.1
@@ -0,0 +1,6 @@
+MD5 9fb61b5a96a08b3c8066dacb0c20c09d bk-3.0.1-x86-glibc22-linux.bin 1850216
+MD5 10524bb1ff6bc147c983e1530f56d3d8 bk-3.0.1-powerpc-glibc21-linux.bin 2081820
+MD5 c914b595724050a7a0277ea264075ebf bk-3.0.1-sparc-glibc21-linux.bin 2027024
+MD5 5297a4150cce96abce58d243db1b8b5f bk-3.0.1-alpha-glibc21-linux.bin 2791728
+MD5 9c077d7f614092908acffc5347864e63 bk-3.0.1-arm-glibc21-linux.bin 1987560
+MD5 55f6b8d18739563bbc7d1095270e5b32 bk-3.0.1-hppa-glibc22-linux.bin 2060236