summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2009-08-25 18:40:37 +0000
committerVictor Ostorga <vostorga@gentoo.org>2009-08-25 18:40:37 +0000
commitee5669a341160863d77d4e114a82210de71a88b1 (patch)
treee818bbcde10361c4df5091c216cd46433c688c61 /dev-util/biew
parentStable on alpha, bug #268190 (diff)
downloadgentoo-2-ee5669a341160863d77d4e114a82210de71a88b1.tar.gz
gentoo-2-ee5669a341160863d77d4e114a82210de71a88b1.tar.bz2
gentoo-2-ee5669a341160863d77d4e114a82210de71a88b1.zip
Respecting CC, LD, AR, RANLIB variables, bug #243972, Fixing pre-stripped files, bug #255833 , Fixing man page location bug #255835 , Respecting CFLAGS and LDFLAGS , Now builds in ~amd64 , thanks to Diego E.
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'dev-util/biew')
-rw-r--r--dev-util/biew/ChangeLog15
-rw-r--r--dev-util/biew/biew-5.7.0.ebuild17
-rw-r--r--dev-util/biew/files/biew-570-configure-gpm.patch16
-rw-r--r--dev-util/biew/files/biew-570-configure.patch31
-rw-r--r--dev-util/biew/files/biew-570-makefile.patch13
5 files changed, 64 insertions, 28 deletions
diff --git a/dev-util/biew/ChangeLog b/dev-util/biew/ChangeLog
index bde739ae9c49..ded01b64f654 100644
--- a/dev-util/biew/ChangeLog
+++ b/dev-util/biew/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for dev-util/biew
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/biew/ChangeLog,v 1.24 2008/12/26 08:07:23 wormo Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/biew/ChangeLog,v 1.25 2009/08/25 18:40:37 vostorga Exp $
+
+ 25 Aug 2009; Víctor Ostorga <vostorga@gentoo.org> biew-5.7.0.ebuild,
+ +files/biew-570-configure.patch, -files/biew-570-configure-gpm.patch,
+ files/biew-570-makefile.patch:
+ Respecting CC, LD, AR, RANLIB variables, bug #243972
+ Fixing pre-stripped files, bug #255833
+ Fixing man page location, patch thanks to Sandro Bonazzola and Wim Muskee
+ bug #255835
+ Respecting CFLAGS and LDFLAGS
+ Now builds in ~amd64 , thanks to Diego E." Flameeyes" Pettenò
+ <flameeyes@gmail.com>
*biew-5.7.0 (26 Dec 2008)
diff --git a/dev-util/biew/biew-5.7.0.ebuild b/dev-util/biew/biew-5.7.0.ebuild
index a864013a6abc..1544f2448494 100644
--- a/dev-util/biew/biew-5.7.0.ebuild
+++ b/dev-util/biew/biew-5.7.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/biew/biew-5.7.0.ebuild,v 1.1 2008/12/26 08:07:23 wormo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/biew/biew-5.7.0.ebuild,v 1.2 2009/08/25 18:40:37 vostorga Exp $
-inherit eutils
+inherit eutils toolchain-funcs flag-o-matic
DESCRIPTION="A portable viewer of binary files, hexadecimal and disassembler modes."
HOMEPAGE="http://biew.sourceforge.net"
@@ -27,7 +27,7 @@ S=${WORKDIR}/${PN}-${PV//./}
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}"/biew-570-configure-gpm.patch
+ epatch "${FILESDIR}"/biew-570-configure.patch
epatch "${FILESDIR}"/biew-570-makefile.patch
}
@@ -41,8 +41,13 @@ src_compile() {
fi
export _gpm=${enable_gpm}
- econf
- emake
+ append-flags -D_GNU_SOURCE
+
+ econf --cc="$(tc-getCC)" --ld="$(tc-getCC)" \
+ --ar="$(tc-getAR) -rcu" --ranlib="$(tc-getRANLIB)" \
+ --enable-debug
+ emake HOST_CFLAGS="${CFLAGS}" HOST_LDFLAGS="${LDFLAGS}" \
+ || die "make failed"
for i in doc/*.ru doc/file_id.diz doc/biew_ru.txt doc/biew_en.txt
do
if iconv -f cp866 -t utf-8 "$i" > "$i.conv"
diff --git a/dev-util/biew/files/biew-570-configure-gpm.patch b/dev-util/biew/files/biew-570-configure-gpm.patch
deleted file mode 100644
index 61497f80ca89..000000000000
--- a/dev-util/biew/files/biew-570-configure-gpm.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- configure.old 2008-12-24 13:26:59.000000000 -0800
-+++ configure 2008-12-24 13:34:00.000000000 -0800
-@@ -478,8 +478,11 @@
- #include <gpm.h>
- int main(void) {return 0;}
- EOF
-- _gpm=no
-- cc_check -lgpm && _gpm=yes
-+ # _gpm may be forced from command line
-+ if test -z "$_gpm" ; then
-+ _gpm=no
-+ cc_check -lgpm && _gpm=yes
-+ fi
- if test "$_gpm" = yes ; then
- _cdefos="-DHAVE_MOUSE $_cdefos"
- _oslibs="-lgpm $_oslibs"
diff --git a/dev-util/biew/files/biew-570-configure.patch b/dev-util/biew/files/biew-570-configure.patch
new file mode 100644
index 000000000000..428e7d31e7aa
--- /dev/null
+++ b/dev-util/biew/files/biew-570-configure.patch
@@ -0,0 +1,31 @@
+diff -NrU5 biew-570.original/configure biew-570/configure
+--- biew-570.original/configure 2009-08-25 16:18:03.000000000 -0600
++++ biew-570/configure 2009-08-25 16:54:17.000000000 -0600
+@@ -467,21 +467,24 @@
+ qnxnto)
+ _cdefos="-D__QNX6__ -D__UNIX__ -D__OS_NAME__='\"QNX6\"' -D__OS__=\"qnxnto\" -U__QNX__ -U__NTO__ -D_VT100_ -DHAVE_TERMINAL_OUT=1 -D__DISABLE_MMF -DPREFIX=\"$_prefix\" $_cdefos"
+ _oslibs="-lncurses $_oslibs"
+ ;;
+ linux)
+- if test $_ld=gcc ; then
++ if test $_ld = gcc -o $_ld = x86_64-pc-linux-gnu-gcc -o $_ld = i686-pc-linux-gnu-gcc; then
+ _osldef="-m32 $_osldef"
+ fi
+ _cdefos="-D__LINUX__ -D__UNIX__ -D__OS_NAME__='\"Linux\"' -D__OS__=\"linux\" -Ulinux -D_VT100_ -DHAVE_TERMINAL_OUT=1 -DPREFIX=\"$_prefix\" $_cdefos"
+ echocheck "gpm.h"
+ cat > $TMPC << EOF
+ #include <gpm.h>
+ int main(void) {return 0;}
+ EOF
+- _gpm=no
+- cc_check -lgpm && _gpm=yes
++ # _gpm may be forced from command line
++ if test -z "$_gpm" ; then
++ _gpm=no
++ cc_check -lgpm && _gpm=yes
++ fi
+ if test "$_gpm" = yes ; then
+ _cdefos="-DHAVE_MOUSE $_cdefos"
+ _oslibs="-lgpm $_oslibs"
+ fi
+ echores "$_gpm"
diff --git a/dev-util/biew/files/biew-570-makefile.patch b/dev-util/biew/files/biew-570-makefile.patch
index eda929ba33d1..8943da94744d 100644
--- a/dev-util/biew/files/biew-570-makefile.patch
+++ b/dev-util/biew/files/biew-570-makefile.patch
@@ -1,6 +1,9 @@
---- makefile.orig 2008-12-21 12:33:37.001959467 +0100
-+++ makefile 2008-12-21 12:38:56.925669582 +0100
-@@ -271,16 +271,16 @@
+diff -NrU5 biew-570.original/makefile biew-570/makefile
+--- biew-570.original/makefile 2009-08-25 18:45:37.000000000 -0600
++++ biew-570/makefile 2009-08-25 18:47:01.000000000 -0600
+@@ -269,20 +269,20 @@
+ @echo "*** installation. Please download 'fileutils' from ftp://ftp.gnu.org and"
+ @echo "*** install them to have possibility perform autiomatic installation"
@echo "*** of this project"
@exit 1
endif
@@ -15,7 +18,7 @@
- $(INSTALL) -D -c -m 644 bin_rc/xlt/russian/*.xlt $(DATADIR)/xlt/russian
- $(INSTALL) -D -c -m 644 bin_rc/xlt/*.xlt bin_rc/xlt/readme $(DATADIR)/xlt
+ $(INSTALL) -D -m 755 $(TARGET) $(DESTDIR)$(PREFIX)/bin/$(TARGET)
-+ $(INSTALL) -D -c -m 644 doc/biew.1 $(DESTDIR)$(PREFIX)/man/man1/biew.1
++ $(INSTALL) -D -c -m 644 doc/biew.1 $(DESTDIR)$(DATADIR)/man/man1/biew.1
+ $(INSTALL) -D -c -m 644 bin_rc/biew.hlp $(DESTDIR)$(DATADIR)/biew.hlp
+ mkdir --parents $(DESTDIR)$(DATADIR)/skn
+ $(INSTALL) -D -c -m 644 bin_rc/skn/*.skn $(DESTDIR)$(DATADIR)/skn
@@ -27,3 +30,5 @@
uninstall:
$(RM) $(PREFIX)/bin/$(TARGET)
$(RM) $(DATADIR)/skn/*
+ rmdir -p --ignore-fail-on-non-empty $(DATADIR)/skn
+ $(RM) $(DATADIR)/syntax/*