summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2012-03-02 17:26:38 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2012-03-02 17:26:38 +0000
commita80aa243478d1cfc7f1b76f0defa669445bb548d (patch)
treef417538477d386b2437086e94e3f0117698aad0d /dev-util/astyle
parentSupport switching GLES implementations as well, fix bug #406501 (diff)
downloadgentoo-2-a80aa243478d1cfc7f1b76f0defa669445bb548d.tar.gz
gentoo-2-a80aa243478d1cfc7f1b76f0defa669445bb548d.tar.bz2
gentoo-2-a80aa243478d1cfc7f1b76f0defa669445bb548d.zip
Version bump wrt bug #311281 by Arseny Solokha <asolokha@gmx.com>. Use package's build system and helpers instead of rewriting it from scratch. Drop useless debug flag, install docs and build/install static lib conditionally
(Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/astyle')
-rw-r--r--dev-util/astyle/ChangeLog14
-rw-r--r--dev-util/astyle/astyle-2.02.1.ebuild71
-rw-r--r--dev-util/astyle/files/astyle-2.02.1-build_system.patch54
3 files changed, 136 insertions, 3 deletions
diff --git a/dev-util/astyle/ChangeLog b/dev-util/astyle/ChangeLog
index 0114b49d52ef..257d336cfb4b 100644
--- a/dev-util/astyle/ChangeLog
+++ b/dev-util/astyle/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-util/astyle
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/astyle/ChangeLog,v 1.39 2011/01/28 19:17:50 grobian Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/astyle/ChangeLog,v 1.40 2012/03/02 17:26:38 xarthisius Exp $
+
+*astyle-2.02.1 (02 Mar 2012)
+
+ 02 Mar 2012; Kacper Kowalik <xarthisius@gentoo.org> +astyle-2.02.1.ebuild,
+ +files/astyle-2.02.1-build_system.patch:
+ Version bump wrt bug #311281 by Arseny Solokha <asolokha@gmx.com>. Use
+ package's build system and helpers instead of rewriting it from scratch. Drop
+ useless debug flag, install docs and build/install static lib conditionally
28 Jan 2011; Fabian Groffen <grobian@gentoo.org> astyle-1.24.ebuild:
Fix for Prefix, add keywords
@@ -85,7 +93,7 @@
Dropped ppc-macos keyword, see you in prefix
14 Nov 2007; Robin H. Johnson <robbat2@gentoo.org> astyle-1.21.ebuild:
- Fix $Header: /var/cvsroot/gentoo-x86/dev-util/astyle/ChangeLog,v 1.39 2011/01/28 19:17:50 grobian Exp $ string.
+ Fix $Header: /var/cvsroot/gentoo-x86/dev-util/astyle/ChangeLog,v 1.40 2012/03/02 17:26:38 xarthisius Exp $ string.
*astyle-1.21 (07 Oct 2007)
diff --git a/dev-util/astyle/astyle-2.02.1.ebuild b/dev-util/astyle/astyle-2.02.1.ebuild
new file mode 100644
index 000000000000..3b6a747f4a56
--- /dev/null
+++ b/dev-util/astyle/astyle-2.02.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/astyle/astyle-2.02.1.ebuild,v 1.1 2012/03/02 17:26:38 xarthisius Exp $
+
+EAPI=4
+
+inherit eutils java-pkg-opt-2 multilib toolchain-funcs
+
+DESCRIPTION="Artistic Style is a reindenter and reformatter of C++, C and Java source code"
+HOMEPAGE="http://astyle.sourceforge.net/"
+SRC_URI="mirror://sourceforge/astyle/astyle_${PV}_linux.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+
+IUSE="doc java static-libs"
+
+DEPEND="app-arch/xz-utils
+ java? ( >=virtual/jdk-1.6 )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ java-pkg-opt-2_pkg_setup
+ tc-export CXX
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build_system.patch
+ java-pkg-opt-2_src_prepare
+ sed -e "s:^\(JAVAINCS\s*\)=.*$:\1= $(java-pkg_get-jni-cflags):" \
+ -e "s:ar crs:$(tc-getAR) crs:" \
+ -i build/gcc/Makefile || die
+}
+
+src_compile() {
+ local mk_opts="-f ../build/gcc/Makefile -C src"
+ emake ${mk_opts} ${PN}
+ emake ${mk_opts} shared
+ if use java ; then
+ emake ${mk_opts} java
+ fi
+ if use static-libs ; then
+ emake ${mk_opts} static
+ fi
+}
+
+src_install() {
+ insinto /usr/include
+ doins src/${PN}.h
+
+ pushd src/bin &> /dev/null
+ dobin ${PN}
+
+ dolib.so lib${PN}.so.0.0.0
+ dosym lib${PN}.so.0.0.0 /usr/$(get_libdir)/lib${PN}.so.0
+ dosym lib${PN}.so.0.0.0 /usr/$(get_libdir)/lib${PN}.so
+ if use java ; then
+ dolib.so lib${PN}j.so.0.0.0
+ dosym lib${PN}j.so.0.0.0 /usr/$(get_libdir)/lib${PN}j.so.0
+ dosym lib${PN}j.so.0.0.0 /usr/$(get_libdir)/lib${PN}j.so
+ fi
+ if use static-libs ; then
+ dolib lib${PN}.a
+ fi
+ popd &> /dev/null
+
+ use doc && dohtml doc/*
+}
diff --git a/dev-util/astyle/files/astyle-2.02.1-build_system.patch b/dev-util/astyle/files/astyle-2.02.1-build_system.patch
new file mode 100644
index 000000000000..1d63a512e9bc
--- /dev/null
+++ b/dev-util/astyle/files/astyle-2.02.1-build_system.patch
@@ -0,0 +1,54 @@
+--- a/build/gcc/Makefile
++++ b/build/gcc/Makefile
+@@ -34,25 +34,25 @@
+ ipath=$(prefix)/bin
+ CBASEFLAGS = -W -Wall -fno-rtti -fno-exceptions
+ JAVAINCS = -I$(JAVA_HOME)/include
+-CXX = g++
++CXX ?= g++
+ INSTALL=install -o $(USER) -g $(USER)
+
+ ##################################################
+
+ # define compile options for each build
+-ifdef CFLAGS
+- CFLAGSr = -DNDEBUG $(CBASEFLAGS) $(CFLAGS)
+- CFLAGSd = -g $(CBASEFLAGS) $(CFLAGS)
++ifdef CXXFLAGS
++ CFLAGSr = -DNDEBUG $(CBASEFLAGS) $(CXXFLAGS)
++ CFLAGSd = -g $(CBASEFLAGS) $(CXXFLAGS)
+ else
+ CFLAGSr = -DNDEBUG -O3 $(CBASEFLAGS)
+ CFLAGSd = -g $(CBASEFLAGS)
+ endif
+-CFLAGSs = -DASTYLE_LIB -fpic $(CFLAGSr)
+-CFLAGSsd = -DASTYLE_LIB -fpic $(CFLAGSd)
++CFLAGSs = -DASTYLE_LIB -fPIC $(CFLAGSr)
++CFLAGSsd = -DASTYLE_LIB -fPIC $(CFLAGSd)
+ CFLAGSa = -DASTYLE_LIB $(CFLAGSr)
+ CFLAGSad = -DASTYLE_LIB $(CFLAGSd)
+-CFLAGSsj = -DASTYLE_JNI -fpic $(CFLAGSr) $(JAVAINCS)
+-CFLAGSsjd = -DASTYLE_JNI -fpic $(CFLAGSd) $(JAVAINCS)
++CFLAGSsj = -DASTYLE_JNI -fPIC $(CFLAGSr) $(JAVAINCS)
++CFLAGSsjd = -DASTYLE_JNI -fPIC $(CFLAGSd) $(JAVAINCS)
+
+ # define link options
+ ifdef LDFLAGS
+@@ -134,7 +134,7 @@
+ shared: libastyle.so
+ libastyle.so: $(OBJs)
+ @ mkdir -p $(bindir)
+- $(CXX) -shared $(LDFLAGSr) -o $(bindir)/$@ $^
++ $(CXX) -shared -Wl,-soname,$@.0 $(LDFLAGSr) -o $(bindir)/$@.0.0.0 $^
+ @ echo
+
+ shareddebug: libastyled.so
+@@ -158,7 +158,7 @@
+ java: libastylej.so
+ libastylej.so: $(OBJsj)
+ @ mkdir -p $(bindir)
+- $(CXX) -shared $(LDFLAGSr) -o $(bindir)/$@ $^
++ $(CXX) -shared -Wl,-soname,$@.0 $(LDFLAGSr) -o $(bindir)/$@.0.0.0 $^
+ @ echo
+
+ javadebug: libastylejd.so