summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-01-15 17:43:55 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-01-15 17:43:55 +0000
commitfc4d68a3c50bf4d8fbe1fb9f4a058e351423e875 (patch)
treed86cbbee2854edc3100c2744989f6225bd7713f2 /dev-util/aruba
parentalpha/ia64/s390/sparc stable wrt #392813 (diff)
downloadgentoo-2-fc4d68a3c50bf4d8fbe1fb9f4a058e351423e875.tar.gz
gentoo-2-fc4d68a3c50bf4d8fbe1fb9f4a058e351423e875.tar.bz2
gentoo-2-fc4d68a3c50bf4d8fbe1fb9f4a058e351423e875.zip
Version bump; workaround testing with recent childprocess versions (issue open upstream); fix rspec dependency for use with bundler.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/aruba')
-rw-r--r--dev-util/aruba/ChangeLog11
-rw-r--r--dev-util/aruba/aruba-0.4.11.ebuild46
-rw-r--r--dev-util/aruba/files/aruba-0.4.11+childprocess-0.2.4.patch37
3 files changed, 92 insertions, 2 deletions
diff --git a/dev-util/aruba/ChangeLog b/dev-util/aruba/ChangeLog
index 335645974cf6..3f590356d6c2 100644
--- a/dev-util/aruba/ChangeLog
+++ b/dev-util/aruba/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/aruba
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/aruba/ChangeLog,v 1.10 2011/12/25 11:00:43 graaff Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/aruba/ChangeLog,v 1.11 2012/01/15 17:43:55 flameeyes Exp $
+
+*aruba-0.4.11 (15 Jan 2012)
+
+ 15 Jan 2012; Diego E. Pettenò <flameeyes@gentoo.org> +aruba-0.4.11.ebuild,
+ +files/aruba-0.4.11+childprocess-0.2.4.patch:
+ Version bump; workaround testing with recent childprocess versions (issue open
+ upstream); fix rspec dependency for use with bundler.
*aruba-0.4.10 (25 Dec 2011)
diff --git a/dev-util/aruba/aruba-0.4.11.ebuild b/dev-util/aruba/aruba-0.4.11.ebuild
new file mode 100644
index 000000000000..b593d8be8856
--- /dev/null
+++ b/dev-util/aruba/aruba-0.4.11.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/aruba/aruba-0.4.11.ebuild,v 1.1 2012/01/15 17:43:55 flameeyes Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST="cucumber"
+RUBY_FAKEGEM_EXTRADOC="History.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="aruba.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Cucumber steps for driving out command line applications."
+HOMEPAGE="https://github.com/aslakhellesoy/aruba"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE=""
+
+DEPEND="${DEPEND} test? ( sys-devel/bc )"
+RDEPEND="${RDEPEND}"
+
+ruby_add_rdepend "
+ >=dev-ruby/bcat-0.6.1
+ >=dev-ruby/childprocess-0.2.3
+ >=dev-ruby/rspec-2.6
+ >=dev-util/cucumber-1.1.1"
+
+all_ruby_prepare() {
+ # Remove bundler-related code.
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+ rm Gemfile || die
+
+ # fix dependency over rspec for bundler to pick this up properly;
+ # also remove references to git ls-files.
+ sed -i -e '/rspec/s:2\.7\.0:2.6.0:' \
+ -e '/git ls-files/d' \
+ aruba.gemspec || die
+
+ # see https://github.com/cucumber/aruba/issues/106
+ epatch "${FILESDIR}"/${P}+childprocess-0.2.4.patch
+}
diff --git a/dev-util/aruba/files/aruba-0.4.11+childprocess-0.2.4.patch b/dev-util/aruba/files/aruba-0.4.11+childprocess-0.2.4.patch
new file mode 100644
index 000000000000..f5408aaeec1a
--- /dev/null
+++ b/dev-util/aruba/files/aruba-0.4.11+childprocess-0.2.4.patch
@@ -0,0 +1,37 @@
+diff --git a/features/exit_statuses.feature b/features/exit_statuses.feature
+index 5c5dffe..b971152 100644
+--- a/features/exit_statuses.feature
++++ b/features/exit_statuses.feature
+@@ -30,13 +30,3 @@ Feature: exit statuses
+ Scenario: Unsuccessfully run something
+ When I do aruba I successfully run `ruby -e 'exit 10'`
+ Then aruba should fail with "Exit status was 10"
+-
+- @posix
+- Scenario: Try to run something that doesn't exist
+- When I run `does_not_exist`
+- Then the exit status should be 1
+-
+- @posix
+- Scenario: Try to run something that doesn't exist with `
+- When I run `does_not_exist`
+- Then the exit status should be 1
+diff --git a/features/output.feature b/features/output.feature
+index 8af06ca..7eea5a5 100644
+--- a/features/output.feature
++++ b/features/output.feature
+@@ -5,14 +5,6 @@ Feature: Output
+ I want to use the "the output should contain" step
+
+ @posix
+- Scenario: Run unknown command
+- When I run `neverever gonna work`
+- Then the output should contain:
+- """
+- No such file or directory - neverever
+- """
+-
+- @posix
+ Scenario: Detect subset of one-line output
+ When I run `ruby -e 'puts \"hello world\"'`
+ Then the output should contain "hello world"