summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce A. Locke <blocke@gentoo.org>2002-02-14 22:50:55 +0000
committerBruce A. Locke <blocke@gentoo.org>2002-02-14 22:50:55 +0000
commit420aec6b61cd819c6ebc11f6be197c75a9e16ccc (patch)
tree95cc8b3920cd9d9b70c2746fb23076a373d6ee4e /dev-util/arch
parentNew upstream version (diff)
downloadgentoo-2-420aec6b61cd819c6ebc11f6be197c75a9e16ccc.tar.gz
gentoo-2-420aec6b61cd819c6ebc11f6be197c75a9e16ccc.tar.bz2
gentoo-2-420aec6b61cd819c6ebc11f6be197c75a9e16ccc.zip
arch 1.0_pre7 ebuild contributed by kamisama@free.fr (Defresne Sylvain (keiichi))
Diffstat (limited to 'dev-util/arch')
-rw-r--r--dev-util/arch/ChangeLog10
-rw-r--r--dev-util/arch/arch-1.0_pre7.ebuild75
-rw-r--r--dev-util/arch/files/digest-arch-1.0_pre71
3 files changed, 86 insertions, 0 deletions
diff --git a/dev-util/arch/ChangeLog b/dev-util/arch/ChangeLog
new file mode 100644
index 000000000000..4a6c61b4a12d
--- /dev/null
+++ b/dev-util/arch/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-util/arch/ChangeLog,v 1.1 2002/02/14 22:50:54 blocke Exp $
+
+*arch-1.0_pre7 (14 Feb 2002)
+
+ 14 Feb 2002; Bruce A. Locke <blocke@shivan.org> arch-1.0_pre7.ebuild:
+
+ Added Arch 1.0-pre7
+
diff --git a/dev-util/arch/arch-1.0_pre7.ebuild b/dev-util/arch/arch-1.0_pre7.ebuild
new file mode 100644
index 000000000000..04305bcfc406
--- /dev/null
+++ b/dev-util/arch/arch-1.0_pre7.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2.
+# Maintainer: Chris Houser <chouser@gentoo.org>
+# Author: Defresne Sylvain (keiichi) <kamisama@free.fr>, Chris Houser <chouser@gentoo.org>
+
+
+P="${P//_/}"
+S="${WORKDIR}/${P}/src/=build"
+DESCRIPTION="revision control system ideal for widely distributed development"
+SRC_URI="ftp://regexps.com/pub/src/arch/${P}.tar.gz"
+HOMEPAGE="http://www.regexps.com/#arch"
+SLOT="0"
+
+DEPEND="sys-apps/diffutils
+ sys-apps/fileutils
+ sys-apps/findutils
+ sys-apps/gawk
+ sys-apps/sh-utils
+ sys-apps/tar
+ sys-apps/textutils
+ sys-apps/util-linux
+ sys-apps/debianutils
+ sys-devel/make
+ sys-devel/patch"
+
+src_unpack() {
+ local t
+
+ unpack "${A}"
+ mkdir -p "${P}/src/=build"
+
+ # patch arch to install its scripts in /usr/share/arch
+ # instead of /usr/libexec/arch (there is only shareables scripts).
+ t="${P}/src/build-tools/Makefiles/rules.mk"
+
+ cp ${t} ${t}.orig
+ sed 's:/libexec:/share:g' ${t}.orig > ${t} || die "Patch failed for $t"
+}
+
+src_compile() {
+ # configure
+ ../configure --prefix="/usr" \
+ --with-posix-shell="/bin/bash" \
+ --with-sendmail="/usr/sbin/sendmail" || die "configure failed"
+
+ # build
+ emake || die "emake failed"
+}
+
+src_install () {
+ local name
+
+ # install
+ make install prefix="${D}/usr" \
+ || die "make install failed"
+
+ # make symlinks relative instead of absolute
+ for name in ${D}/usr/share/arch/arch/*; do
+ name="`readlink ${name} | sed 's:^.*/usr/share/arch/::'`"
+ if [ "${name}" ]; then
+ ln -sf "../${name}" "${D}/usr/share/arch/arch/${name#*/}"
+ assert "Fixing symlink for ${name} failed"
+ fi
+ done
+
+ # get some docs
+ cd ${WORKDIR}/${P}
+ dodoc =NEWS =README COPYING
+ dohtml docs/html/*
+}
+
+pkg_postinst() {
+ echo "Tom Lord's 'arch' command has been renamed upstream to 'larch'"
+ echo "to stop collision with 'arch' command."
+}
diff --git a/dev-util/arch/files/digest-arch-1.0_pre7 b/dev-util/arch/files/digest-arch-1.0_pre7
new file mode 100644
index 000000000000..022479e1543f
--- /dev/null
+++ b/dev-util/arch/files/digest-arch-1.0_pre7
@@ -0,0 +1 @@
+MD5 7d71fc2d8a661e64635fe8e217dad15c arch-1.0pre7.tar.gz 2460644