summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-12-05 06:02:22 +0000
committerChristoph Junghans <ottxor@gentoo.org>2012-12-05 06:02:22 +0000
commit634704379af240d07eb18fae9a90fcb8492abcb0 (patch)
tree4721ff1e2d6a829875b3ffa33deeee4ed6574455 /dev-util/aap
parentBump, adds Retribution 1.0 updates (bug #446030, thanks to Matthew Marlowe). ... (diff)
downloadgentoo-2-634704379af240d07eb18fae9a90fcb8492abcb0.tar.gz
gentoo-2-634704379af240d07eb18fae9a90fcb8492abcb0.tar.bz2
gentoo-2-634704379af240d07eb18fae9a90fcb8492abcb0.zip
added prefix support + clean up (bug #440356)
(Portage version: 2.2.0_alpha143/cvs/Linux i686, signed Manifest commit with key C2000586)
Diffstat (limited to 'dev-util/aap')
-rw-r--r--dev-util/aap/ChangeLog10
-rw-r--r--dev-util/aap/aap-1.091-r1.ebuild34
2 files changed, 41 insertions, 3 deletions
diff --git a/dev-util/aap/ChangeLog b/dev-util/aap/ChangeLog
index 00bb3ba27d41..8c533d25d0ee 100644
--- a/dev-util/aap/ChangeLog
+++ b/dev-util/aap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/aap
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/aap/ChangeLog,v 1.29 2009/09/12 01:40:42 patrick Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/aap/ChangeLog,v 1.30 2012/12/05 06:02:22 ottxor Exp $
+
+*aap-1.091-r1 (05 Dec 2012)
+
+ 05 Dec 2012; Christoph Junghans <ottxor@gentoo.org> +aap-1.091-r1.ebuild:
+ added prefix support + clean up (bug #440356)
*aap-1.091 (12 Sep 2009)
@@ -107,4 +112,3 @@
23 Jul 2003; Aron Griffis <agriffis@gentoo.org> aap-1.000.ebuild:
New ebuild for Bram Moolenaar's A-A-P
-
diff --git a/dev-util/aap/aap-1.091-r1.ebuild b/dev-util/aap/aap-1.091-r1.ebuild
new file mode 100644
index 000000000000..acaad46d1fae
--- /dev/null
+++ b/dev-util/aap/aap-1.091-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/aap/aap-1.091-r1.ebuild,v 1.1 2012/12/05 06:02:22 ottxor Exp $
+
+EAPI=4
+
+IUSE="doc"
+
+DESCRIPTION="Bram Moolenaar's super-make program"
+HOMEPAGE="http://www.a-a-p.org/"
+SRC_URI="mirror://sourceforge/a-a-p/${P}.zip"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+DEPEND="app-arch/unzip"
+RDEPEND="dev-lang/python"
+S=${WORKDIR}
+
+src_install() {
+ rm doc/*.sgml doc/*.pdf || die
+ use doc && dohtml -r doc/*.html doc/images
+ rm -r doc/*.html doc/images || die
+
+ dodoc doc/*
+ doman aap.1
+ rm -r doc aap.1 || die
+
+ # Move the remainder directly into the dest tree
+ dodir /usr/share/aap
+ cp -R * "${ED}"/usr/share/aap || die
+
+ # Create a symbolic link for the executable
+ dosym ../share/aap/aap /usr/bin/aap
+}