summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-08-26 22:06:16 +0000
committerMichał Górny <mgorny@gentoo.org>2013-08-26 22:06:16 +0000
commit05ffcaf9f8d9aa021566c2d95c8f88e706b92a91 (patch)
treea69b62eece8152bfdf90e795de53a50feaa041f9 /dev-util/aap
parentVersion bump. (diff)
downloadgentoo-2-05ffcaf9f8d9aa021566c2d95c8f88e706b92a91.tar.gz
gentoo-2-05ffcaf9f8d9aa021566c2d95c8f88e706b92a91.tar.bz2
gentoo-2-05ffcaf9f8d9aa021566c2d95c8f88e706b92a91.zip
Convert to python-single-r1. Remove redundant COPYING file, byte-compile Python modules, fix shebang. Acked by radhermit.
(Portage version: 2.2.1_p5/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-util/aap')
-rw-r--r--dev-util/aap/ChangeLog10
-rw-r--r--dev-util/aap/aap-1.091-r2.ebuild42
2 files changed, 50 insertions, 2 deletions
diff --git a/dev-util/aap/ChangeLog b/dev-util/aap/ChangeLog
index 8c533d25d0ee..106a94b4dd9e 100644
--- a/dev-util/aap/ChangeLog
+++ b/dev-util/aap/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/aap
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/aap/ChangeLog,v 1.30 2012/12/05 06:02:22 ottxor Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/aap/ChangeLog,v 1.31 2013/08/26 22:06:16 mgorny Exp $
+
+*aap-1.091-r2 (26 Aug 2013)
+
+ 26 Aug 2013; Michał Górny <mgorny@gentoo.org> +aap-1.091-r2.ebuild:
+ Convert to python-single-r1. Remove redundant COPYING file, byte-compile
+ Python modules, fix shebang. Acked by radhermit.
*aap-1.091-r1 (05 Dec 2012)
diff --git a/dev-util/aap/aap-1.091-r2.ebuild b/dev-util/aap/aap-1.091-r2.ebuild
new file mode 100644
index 000000000000..b8d5fa722b24
--- /dev/null
+++ b/dev-util/aap/aap-1.091-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/aap/aap-1.091-r2.ebuild,v 1.1 2013/08/26 22:06:16 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="Bram Moolenaar's super-make program"
+HOMEPAGE="http://www.a-a-p.org/"
+SRC_URI="mirror://sourceforge/a-a-p/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc"
+
+DEPEND="app-arch/unzip"
+RDEPEND="${PYTHON_DEPS}"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+S=${WORKDIR}
+
+src_install() {
+ rm doc/*.sgml doc/*.pdf COPYING || die
+ use doc && dohtml -r doc/*.html doc/images
+ rm -r doc/*.html doc/images || die
+
+ dodoc doc/*
+ doman aap.1
+ rm -r doc aap.1 || die
+
+ # Move the remainder directly into the dest tree
+ python_moduleinto /usr/share/aap
+ python_domodule .
+
+ # Create a symbolic link for the executable
+ dosym ../share/aap/aap /usr/bin/aap
+ python_fix_shebang "${ED}"/usr/share/aap/aap
+}