summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSandro Bonazzola <sanchan@gentoo.org>2006-01-22 09:23:49 +0000
committerSandro Bonazzola <sanchan@gentoo.org>2006-01-22 09:23:49 +0000
commit87f523cc3ad135012822bdfe1b1c1068a6c06f67 (patch)
treefa0e3a04a0fca114f590613877391af6cb1d221a /dev-tinyos/nesc
parentInitial import of tos ebuild for TinyOS (diff)
downloadgentoo-2-87f523cc3ad135012822bdfe1b1c1068a6c06f67.tar.gz
gentoo-2-87f523cc3ad135012822bdfe1b1c1068a6c06f67.tar.bz2
gentoo-2-87f523cc3ad135012822bdfe1b1c1068a6c06f67.zip
Initial import of nesc.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'dev-tinyos/nesc')
-rw-r--r--dev-tinyos/nesc/ChangeLog11
-rw-r--r--dev-tinyos/nesc/Manifest4
-rw-r--r--dev-tinyos/nesc/files/digest-nesc-1.2.11
-rw-r--r--dev-tinyos/nesc/metadata.xml13
-rw-r--r--dev-tinyos/nesc/nesc-1.2.1.ebuild53
5 files changed, 82 insertions, 0 deletions
diff --git a/dev-tinyos/nesc/ChangeLog b/dev-tinyos/nesc/ChangeLog
new file mode 100644
index 000000000000..a1edd3db6812
--- /dev/null
+++ b/dev-tinyos/nesc/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-tinyos/nesc
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tinyos/nesc/ChangeLog,v 1.1 2006/01/22 09:23:49 sanchan Exp $
+
+*nesc-1.2.1 (22 Jan 2006)
+
+ 22 Jan 2006; Sandro Bonazzola <sanchan@gentoo.org> +metadata.xml,
+ +nesc-1.2.1.ebuild:
+ New ebuild, thanks to Johannes Ballé, Aurélien Francillon and Daniel Black.
+ Close bug #78907.
+
diff --git a/dev-tinyos/nesc/Manifest b/dev-tinyos/nesc/Manifest
new file mode 100644
index 000000000000..c014b3673e29
--- /dev/null
+++ b/dev-tinyos/nesc/Manifest
@@ -0,0 +1,4 @@
+MD5 c8cf26d0ae0b0fe36bf472bd23dba462 ChangeLog 334
+MD5 78f3d0c976b53eed528a108fc7b9fd6a files/digest-nesc-1.2.1 63
+MD5 632afbbaf09dda242cbd6cd6869b58c4 metadata.xml 507
+MD5 5b8e7f89b035272b3af6bfe1149570bc nesc-1.2.1.ebuild 1271
diff --git a/dev-tinyos/nesc/files/digest-nesc-1.2.1 b/dev-tinyos/nesc/files/digest-nesc-1.2.1
new file mode 100644
index 000000000000..da898bee8994
--- /dev/null
+++ b/dev-tinyos/nesc/files/digest-nesc-1.2.1
@@ -0,0 +1 @@
+MD5 1a6e7feb8ae4d092d4f6ae4b8d063891 nesc-1.2.1.tar.gz 1068542
diff --git a/dev-tinyos/nesc/metadata.xml b/dev-tinyos/nesc/metadata.xml
new file mode 100644
index 000000000000..11161a9f7005
--- /dev/null
+++ b/dev-tinyos/nesc/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>dev-embedded</herd>
+<maintainer>
+ <email>sanchan@gentoo.org</email>
+</maintainer>
+ <longdescription>
+ NesC is a new language for programming structured component-based applications.
+ This package provides a gcc frontend for this language. You need a gcc compiler
+ or cross-compiler that can produce executables for your target platforms.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-tinyos/nesc/nesc-1.2.1.ebuild b/dev-tinyos/nesc/nesc-1.2.1.ebuild
new file mode 100644
index 000000000000..6ae7a582b485
--- /dev/null
+++ b/dev-tinyos/nesc/nesc-1.2.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tinyos/nesc/nesc-1.2.1.ebuild,v 1.1 2006/01/22 09:23:49 sanchan Exp $
+
+inherit eutils
+
+DESCRIPTION="An extension to gcc that knows how to compile nesC applications"
+HOMEPAGE="http://nescc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/nescc/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc"
+DEPEND=">=dev-lang/perl-5.8.5-r2
+ >=dev-tinyos/tos-1.1.0"
+
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if [ -z "${TOSDIR}" ]
+ then
+ # best to make an assumption
+ export TOSDIR=/usr/src/tinyos-1.x/tos
+ fi
+
+ if [ ! -d "${TOSDIR}" ]
+ then
+ eerror "In order to compile nesc you have to set the"
+ eerror "\$TOSDIR environment properly."
+ eerror ""
+ eerror "You can achieve this by emerging >=dev-embedded/tos-1.1.14-r1"
+ eerror "or by exporting TOSDIR=\"path to your tinyos dir\""
+ die "Couldn't find a valid TinyOS home"
+ else
+ einfo "Building nesC for ${TOSDIR}"
+ fi
+}
+
+src_compile() {
+ econf --disable-dependency-tracking || die "econf failed"
+ # language setting needed, otherwise gcc version
+ # will sometimes not be detected right
+ LANGUAGE=C emake || die "emake failed"
+}
+
+src_install() {
+ LANGUAGE=C einstall || die "einstall failed"
+ if use doc
+ then
+ dohtml -r -a html,jpg,pdf,txt doc/*
+ fi
+ dodoc README
+}