summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-11-19 09:24:59 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-11-19 09:24:59 +0000
commitf8b3aa07e497d80bc4c69d9e542002a0d84dd418 (patch)
tree2bcb03f7997263a9b44dc507dda72a279e264855 /dev-tex
parentAnd remove the broken version. (diff)
downloadgentoo-2-f8b3aa07e497d80bc4c69d9e542002a0d84dd418.tar.gz
gentoo-2-f8b3aa07e497d80bc4c69d9e542002a0d84dd418.tar.bz2
gentoo-2-f8b3aa07e497d80bc4c69d9e542002a0d84dd418.zip
version bump
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-tex')
-rw-r--r--dev-tex/hevea/ChangeLog7
-rw-r--r--dev-tex/hevea/hevea-2.19.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/dev-tex/hevea/ChangeLog b/dev-tex/hevea/ChangeLog
index f2a53f362c21..c0cf88ec0447 100644
--- a/dev-tex/hevea/ChangeLog
+++ b/dev-tex/hevea/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-tex/hevea
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/hevea/ChangeLog,v 1.50 2014/10/27 08:31:15 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/hevea/ChangeLog,v 1.51 2014/11/19 09:24:59 aballier Exp $
+
+*hevea-2.19 (19 Nov 2014)
+
+ 19 Nov 2014; Alexis Ballier <aballier@gentoo.org> +hevea-2.19.ebuild:
+ version bump
*hevea-2.18 (27 Oct 2014)
diff --git a/dev-tex/hevea/hevea-2.19.ebuild b/dev-tex/hevea/hevea-2.19.ebuild
new file mode 100644
index 000000000000..82f0fec09326
--- /dev/null
+++ b/dev-tex/hevea/hevea-2.19.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/hevea/hevea-2.19.ebuild,v 1.1 2014/11/19 09:24:59 aballier Exp $
+
+EAPI=5
+
+inherit eutils multilib
+
+IUSE="+ocamlopt"
+
+DESCRIPTION="HeVeA is a quite complete and fast LaTeX to HTML translator"
+HOMEPAGE="http://hevea.inria.fr/"
+SRC_URI="http://hevea.inria.fr/distri/${P}.tar.gz"
+
+LICENSE="QPL"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt?]"
+RDEPEND="${DEPEND}
+ dev-texlive/texlive-latexextra"
+
+src_compile() {
+ rm -f config.sh
+ emake PREFIX=/usr DESTDIR="${D}" LIBDIR="/usr/$(get_libdir)/hevea" LATEXLIBDIR="/usr/share/texmf-site/tex/latex/hevea" config.sh || die "Failed to create config.sh"
+ if use ocamlopt; then
+ emake PREFIX=/usr || die "Failed to build native code binaries"
+ else
+ emake PREFIX=/usr TARGET=byte || die "Failed to build bytecode binaries"
+ fi
+}
+
+src_install() {
+ if use ocamlopt; then
+ emake DESTDIR="${D}" PREFIX=/usr install || die "Install failed"
+ else
+ emake DESTDIR="${D}" PREFIX=/usr TARGET=byte install || die "Install failed"
+ fi
+
+ dodoc README CHANGES
+}
+
+# If texmf-update is present this means we have a latex install; update it so
+# that hevea.sty can be found
+# Do not (r)depend on latex though because hevea does not need it itself
+# If latex is installed later, it will see hevea.sty
+
+pkg_postinst() {
+ if [ "$ROOT" = "/" ] && [ -x /usr/sbin/texmf-update ] ; then
+ /usr/sbin/texmf-update
+ fi
+}
+
+pkg_postrm() {
+ if [ "$ROOT" = "/" ] && [ -x /usr/sbin/texmf-update ] ; then
+ /usr/sbin/texmf-update
+ fi
+}