summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-04-08 21:28:32 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-04-08 21:28:32 +0000
commitb4344d3d0bbd574ab33e57a345affd901a4fc3bb (patch)
tree777fd80be691fe92e5456ae1b8422f25fc9f3d1b /dev-tex
parentremove old (diff)
downloadgentoo-2-b4344d3d0bbd574ab33e57a345affd901a4fc3bb.tar.gz
gentoo-2-b4344d3d0bbd574ab33e57a345affd901a4fc3bb.tar.bz2
gentoo-2-b4344d3d0bbd574ab33e57a345affd901a4fc3bb.zip
version bump
(Portage version: 2.1.5_rc2)
Diffstat (limited to 'dev-tex')
-rw-r--r--dev-tex/bibtex2html/ChangeLog10
-rw-r--r--dev-tex/bibtex2html/bibtex2html-1.91.ebuild53
2 files changed, 61 insertions, 2 deletions
diff --git a/dev-tex/bibtex2html/ChangeLog b/dev-tex/bibtex2html/ChangeLog
index 02141fb7f810..3f5c918442a9 100644
--- a/dev-tex/bibtex2html/ChangeLog
+++ b/dev-tex/bibtex2html/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-tex/bibtex2html
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/bibtex2html/ChangeLog,v 1.11 2007/12/08 11:38:06 aballier Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/bibtex2html/ChangeLog,v 1.12 2008/04/08 21:28:32 aballier Exp $
+
+*bibtex2html-1.91 (08 Apr 2008)
+
+ 08 Apr 2008; Alexis Ballier <aballier@gentoo.org>
+ +bibtex2html-1.91.ebuild:
+ version bump
08 Dec 2007; Alexis Ballier <aballier@gentoo.org> metadata.xml:
add ml as fallback herd
diff --git a/dev-tex/bibtex2html/bibtex2html-1.91.ebuild b/dev-tex/bibtex2html/bibtex2html-1.91.ebuild
new file mode 100644
index 000000000000..2d213ee6d5eb
--- /dev/null
+++ b/dev-tex/bibtex2html/bibtex2html-1.91.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/bibtex2html/bibtex2html-1.91.ebuild,v 1.1 2008/04/08 21:28:32 aballier Exp $
+
+inherit eutils
+
+IUSE="doc"
+
+DESCRIPTION="A bibtex to HTML converter"
+SRC_URI="http://www.lri.fr/~filliatr/ftp/bibtex2html/${P}.tar.gz"
+HOMEPAGE="http://www.lri.fr/~filliatr/bibtex2html/"
+
+SLOT="0"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+RESTRICT="test"
+
+RDEPEND=">=dev-lang/ocaml-3.09"
+# With use doc we need a latex compiler to generate manual.ps
+# hevea is used for manual.html
+# manual.tex needs fullpage.sty
+DEPEND="${RDEPEND}
+ doc? ( virtual/latex-base
+ || ( dev-texlive/texlive-latexextra app-text/tetex app-text/ptex )
+ dev-tex/hevea )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-1.88-destdir.patch"
+ # Avoid pre-stripped files
+ sed -i -e "s/strip/true/" Makefile.in
+}
+
+src_compile() {
+ export VARTEXFONTS="${T}/fonts"
+ econf || die "could not configure bibtex2html"
+ emake || die "could not make bibtex2html"
+ if use doc; then
+ emake doc || die "failed to create doc"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "failed to install"
+ dodoc README CHANGES
+ if use doc; then
+ dodoc manual.ps
+ dohtml manual.html
+ fi
+}