summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-08-09 07:05:30 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-08-09 07:05:30 +0000
commit8f27a9fc46fba2cc9c7ef29e5f0468aee0a970a1 (patch)
tree256e906c758fccd010656ad26419e04017a45897 /dev-tex
parentremove old (diff)
downloadgentoo-2-8f27a9fc46fba2cc9c7ef29e5f0468aee0a970a1.tar.gz
gentoo-2-8f27a9fc46fba2cc9c7ef29e5f0468aee0a970a1.tar.bz2
gentoo-2-8f27a9fc46fba2cc9c7ef29e5f0468aee0a970a1.zip
version bump
(Portage version: 2.2_rc6/cvs/Linux 2.6.26-gentoo x86_64)
Diffstat (limited to 'dev-tex')
-rw-r--r--dev-tex/tex4ht/ChangeLog8
-rw-r--r--dev-tex/tex4ht/tex4ht-20080807_p1635.ebuild113
2 files changed, 120 insertions, 1 deletions
diff --git a/dev-tex/tex4ht/ChangeLog b/dev-tex/tex4ht/ChangeLog
index 54e34c566fcc..5f89de0e96e4 100644
--- a/dev-tex/tex4ht/ChangeLog
+++ b/dev-tex/tex4ht/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-tex/tex4ht
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/tex4ht/ChangeLog,v 1.28 2008/08/09 06:57:25 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/tex4ht/ChangeLog,v 1.29 2008/08/09 07:05:30 aballier Exp $
+
+*tex4ht-20080807_p1635 (09 Aug 2008)
+
+ 09 Aug 2008; Alexis Ballier <aballier@gentoo.org>
+ +tex4ht-20080807_p1635.ebuild:
+ version bump
09 Aug 2008; Alexis Ballier <aballier@gentoo.org>
-tex4ht-20080125_p0949.ebuild, -tex4ht-20080510_p2222.ebuild:
diff --git a/dev-tex/tex4ht/tex4ht-20080807_p1635.ebuild b/dev-tex/tex4ht/tex4ht-20080807_p1635.ebuild
new file mode 100644
index 000000000000..f494410ae372
--- /dev/null
+++ b/dev-tex/tex4ht/tex4ht-20080807_p1635.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/tex4ht/tex4ht-20080807_p1635.ebuild,v 1.1 2008/08/09 07:05:30 aballier Exp $
+
+inherit latex-package toolchain-funcs java-pkg-opt-2
+
+IUSE=""
+
+# tex4ht-20050331_p2350 -> tex4ht-1.0.2005_03_31_2350
+MY_P="${PN}-1.0.${PV:0:4}_${PV:4:2}_${PV:6:2}_${PV/*_p/}"
+
+DESCRIPTION="Converts (La)TeX to (X)HTML, XML and OO.org"
+HOMEPAGE="http://www.cse.ohio-state.edu/~gurari/TeX4ht/
+ http://www.cse.ohio-state.edu/~gurari/TeX4ht/bugfixes.html"
+SRC_URI="http://www.cse.ohio-state.edu/~gurari/TeX4ht/fix/${MY_P}.tar.gz"
+
+LICENSE="LPPL-1.2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+SLOT="0"
+
+DEPEND=">=sys-apps/sed-4
+ java? ( >=virtual/jdk-1.5 )"
+
+RDEPEND="virtual/ghostscript
+ media-gfx/imagemagick
+ java? ( >=virtual/jre-1.5 )"
+
+IUSE="java"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}/texmf/tex4ht/base/unix"
+ sed -i -e \
+ 's#~/tex4ht.dir#/usr/share#' tex4ht.env || die
+ sed -i -e \
+ 's#tpath/tex/texmf/fonts/tfm/!#t/usr/share/texmf/fonts/tfm/!\nt/usr/local/share/texmf/fonts/tfm/!\nt/var/cache/fonts/tfm/!#' tex4ht.env || die
+ sed -i -e \
+ 's#%%~/texmf-dist#/usr/share/texmf#g' tex4ht.env || die
+
+ einfo "Removing precompiled java stuff"
+ find "${S}" '(' -name '*.class' -o -name '*.jar' ')' -print -delete
+
+ # Rename ht script to avoid collisions with app-editors/hteditor
+ # Bug #197213
+ mv "${S}/bin/ht/unix/ht" "${S}/bin/ht/unix/ht.tex4ht" || die
+}
+
+src_compile() {
+ cd "${S}/src/"
+ einfo "Compiling postprocessor sources..."
+ for f in tex4ht t4ht htcmd ; do
+ $(tc-getCC) ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} -o $f $f.c \
+ -DENVFILE='"/usr/share/texmf/tex4ht/base/tex4ht.env"' \
+ -DHAVE_DIRENT_H -DKPATHSEA -lkpathsea \
+ || die "Compiling $f failed"
+ done
+ if use java; then
+ einfo "Compiling java files..."
+ cd java
+ ejavac *.java */*.java */*/*.java -d ../../texmf/tex4ht/bin
+ cd "${S}/texmf/tex4ht/bin"
+ # Create the jar needed by oolatex
+ jar -cf "${S}/${PN}.jar" * || die "failed to create jar"
+ fi
+}
+
+src_install () {
+ # install the binaries
+ dobin "${S}/src/tex4ht" "${S}/src/t4ht" "${S}/src/htcmd"
+ # install the scripts
+ if ! use java; then
+ rm -f "${S}"/bin/unix/oo*
+ rm -f "${S}"/bin/unix/jh*
+ fi
+ dobin "${S}"/bin/ht/unix/* || die
+ dobin "${S}"/bin/unix/mk4ht || die
+
+ # install the .4ht scripts
+ insinto /usr/share/texmf/tex/generic/tex4ht
+ doins "${S}"/texmf/tex/generic/tex4ht/* || die
+
+ # install the special htf fonts
+ insinto /usr/share/texmf/tex4ht
+ doins -r "${S}/texmf/tex4ht/ht-fonts" || die
+
+ if use java; then
+ # install the java files
+ doins -r "${S}/texmf/tex4ht/bin"
+ java-pkg_jarinto /usr/share/texmf/tex4ht/bin
+ java-pkg_dojar "${S}/${PN}.jar"
+ fi
+
+ # install the .4xt files
+ doins -r "${S}/texmf/tex4ht/xtpipes" || die
+
+ # install the env file
+ insinto /usr/share/texmf/tex4ht/base
+ newins "${S}/texmf/tex4ht/base/unix/tex4ht.env" tex4ht.env || die
+
+ if latex-package_has_tetex_3 ; then
+ insinto /etc/texmf/texmf.d
+ doins "${FILESDIR}/50tex4ht.cnf" || die
+ fi
+}
+
+pkg_postinst() {
+ use java || elog 'ODF converters (oolatex & friends) require the java use flag'
+ latex-package_pkg_postinst
+ elog "In order to avoid collisions with app-editors/hteditor"
+ elog "The helper script 'ht' has been renamed to 'ht.tex4ht'"
+}