summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-01-02 22:19:08 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-01-02 22:19:08 +0000
commit869b9123f0da08b500b568a8ad46e1a4bc79f47f (patch)
tree1ea03a22621a0355901ae848b923c03ec13a35a7 /dev-tex
parentcopy paste... (diff)
downloadgentoo-2-869b9123f0da08b500b568a8ad46e1a4bc79f47f.tar.gz
gentoo-2-869b9123f0da08b500b568a8ad46e1a4bc79f47f.tar.bz2
gentoo-2-869b9123f0da08b500b568a8ad46e1a4bc79f47f.zip
Version bump and add support to not build with ocamlopt
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'dev-tex')
-rw-r--r--dev-tex/hevea/ChangeLog9
-rw-r--r--dev-tex/hevea/files/digest-hevea-1.103
-rw-r--r--dev-tex/hevea/hevea-1.10.ebuild50
3 files changed, 60 insertions, 2 deletions
diff --git a/dev-tex/hevea/ChangeLog b/dev-tex/hevea/ChangeLog
index 28542bd7616f..428ae107d808 100644
--- a/dev-tex/hevea/ChangeLog
+++ b/dev-tex/hevea/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-tex/hevea
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/hevea/ChangeLog,v 1.14 2007/08/30 13:30:59 phreak Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/hevea/ChangeLog,v 1.15 2008/01/02 22:19:08 aballier Exp $
+
+*hevea-1.10 (02 Jan 2008)
+
+ 02 Jan 2008; Alexis Ballier <aballier@gentoo.org> +hevea-1.10.ebuild:
+ Version bump and add support to not build with ocamlopt
30 Aug 2007; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing mattam from metadata due to his retirement (see #30021 for reference).
diff --git a/dev-tex/hevea/files/digest-hevea-1.10 b/dev-tex/hevea/files/digest-hevea-1.10
new file mode 100644
index 000000000000..ec270804b9ee
--- /dev/null
+++ b/dev-tex/hevea/files/digest-hevea-1.10
@@ -0,0 +1,3 @@
+MD5 24a631570bee3cc4b8350e9db39be62b hevea-1.10.tar.gz 305269
+RMD160 651e8799bc4e8ca0c893cf7668df4ff1bf15d9d7 hevea-1.10.tar.gz 305269
+SHA256 c2005c2737a20420e5aec535f27820e20f2d36f9a81d2b507c93737fe1e76ff3 hevea-1.10.tar.gz 305269
diff --git a/dev-tex/hevea/hevea-1.10.ebuild b/dev-tex/hevea/hevea-1.10.ebuild
new file mode 100644
index 000000000000..e6cee12c593b
--- /dev/null
+++ b/dev-tex/hevea/hevea-1.10.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/hevea/hevea-1.10.ebuild,v 1.1 2008/01/02 22:19:08 aballier Exp $
+
+inherit eutils multilib
+
+EAPI="1"
+
+IUSE="+ocamlopt"
+
+DESCRIPTION="HeVeA is a quite complete and fast LaTeX to HTML translator"
+HOMEPAGE="http://pauillac.inria.fr/~maranget/hevea/"
+SRC_URI="ftp://ftp.inria.fr/INRIA/moscova/hevea/${P}.tar.gz"
+
+LICENSE="QPL"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND=">=dev-lang/ocaml-3.07"
+
+pkg_setup() {
+ if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
+ eerror "In order to build ${PN} with native code support from ocaml"
+ eerror "You first need to have a native code ocaml compiler."
+ eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
+ die "Please install ocaml with ocamlopt useflag"
+ fi
+}
+
+src_compile() {
+ rm -f config.sh
+ emake PREFIX=/usr DESTDIR="${D}" LIBDIR="/usr/$(get_libdir)/hevea" LATEXLIBDIR="/usr/$(get_libdir)/hevea" config.sh || die "Failed to create config.sh"
+ if use ocamlopt; then
+ emake PREFIX=/usr || die "Failed to build native code binaries"
+ else
+ emake PREFIX=/usr TARGET=byte || die "Failed to build bytecode binaries"
+ fi
+}
+
+src_install() {
+ if use ocamlopt; then
+ emake DESTDIR="${D}" PREFIX=/usr install || die "Install failed"
+ else
+ emake DESTDIR="${D}" PREFIX=/usr TARGET=byte install || die "Install failed"
+ fi
+
+ doenvd "${FILESDIR}"/99hevea
+
+ dodoc README CHANGES
+}