summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-12-26 14:16:22 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-12-26 14:16:22 +0000
commit52131205d3bf423a01873820a2813d93063d33d9 (patch)
tree865ad4fe2a220ca16c86bdac144e20050b2bc8e6 /dev-tex
parentStable on amd64 wrt bug #281819 (diff)
downloadgentoo-2-52131205d3bf423a01873820a2813d93063d33d9.tar.gz
gentoo-2-52131205d3bf423a01873820a2813d93063d33d9.tar.bz2
gentoo-2-52131205d3bf423a01873820a2813d93063d33d9.zip
version bump
(Portage version: 2.2.0_alpha10/cvs/Linux x86_64)
Diffstat (limited to 'dev-tex')
-rw-r--r--dev-tex/bibtex2html/ChangeLog7
-rw-r--r--dev-tex/bibtex2html/bibtex2html-1.96.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/dev-tex/bibtex2html/ChangeLog b/dev-tex/bibtex2html/ChangeLog
index ec2b95366d7e..74b53768c27b 100644
--- a/dev-tex/bibtex2html/ChangeLog
+++ b/dev-tex/bibtex2html/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-tex/bibtex2html
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/bibtex2html/ChangeLog,v 1.20 2010/08/04 07:38:39 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/bibtex2html/ChangeLog,v 1.21 2010/12/26 14:16:22 aballier Exp $
+
+*bibtex2html-1.96 (26 Dec 2010)
+
+ 26 Dec 2010; Alexis Ballier <aballier@gentoo.org> +bibtex2html-1.96.ebuild:
+ version bump
*bibtex2html-1.95 (04 Aug 2010)
diff --git a/dev-tex/bibtex2html/bibtex2html-1.96.ebuild b/dev-tex/bibtex2html/bibtex2html-1.96.ebuild
new file mode 100644
index 000000000000..9b4e7a41fa68
--- /dev/null
+++ b/dev-tex/bibtex2html/bibtex2html-1.96.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/bibtex2html/bibtex2html-1.96.ebuild,v 1.1 2010/12/26 14:16:22 aballier Exp $
+
+EAPI=2
+
+inherit eutils
+
+IUSE="doc +ocamlopt"
+
+DESCRIPTION="A bibtex to HTML converter"
+SRC_URI="http://www.lri.fr/~filliatr/ftp/bibtex2html/${P}.tar.gz"
+HOMEPAGE="http://www.lri.fr/~filliatr/bibtex2html/"
+
+SLOT="0"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+RESTRICT="test"
+
+# With use doc we need a latex compiler to generate manual.pdf
+# hevea is used for manual.html
+# manual.tex needs fullpage.sty
+DEPEND=">=dev-lang/ocaml-3.10[ocamlopt?]
+ doc? ( virtual/latex-base
+ || ( dev-texlive/texlive-latexextra app-text/ptex )
+ dev-tex/hevea )"
+# We need tex-base for bibtex but also some bibtex styles, so we use latex-base
+RDEPEND="virtual/latex-base"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.88-destdir.patch"
+ # Avoid pre-stripped files
+ sed -i -e "s/strip/true/" Makefile.in
+ # Fix build with ocaml 3.12, bug #331081
+ has_version '>=dev-lang/ocaml-3.12' && sed -i 's/lstr/lcamlstr/' Makefile.in
+ # For make install
+ use ocamlopt || sed -i 's/= opt /= noopt /' Makefile.in
+}
+
+src_compile() {
+ export VARTEXFONTS="${T}/fonts"
+ if use ocamlopt ; then
+ emake opt || die
+ else
+ emake byte || die
+ fi
+ if use doc; then
+ emake doc || die "failed to create doc"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "failed to install"
+ dodoc README CHANGES
+ if use doc; then
+ dodoc manual.pdf
+ dohtml manual.html
+ fi
+}