summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-01-15 21:21:20 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-01-15 21:21:20 +0000
commit4556fed1815bcb0618e2d3e0574ac53eba240815 (patch)
tree218ce5ee7c447ed829d2bc1ffc38e0fb0febfd23 /dev-tex
parentRemove myself from metadata (diff)
downloadgentoo-2-4556fed1815bcb0618e2d3e0574ac53eba240815.tar.gz
gentoo-2-4556fed1815bcb0618e2d3e0574ac53eba240815.tar.bz2
gentoo-2-4556fed1815bcb0618e2d3e0574ac53eba240815.zip
version bump
(Portage version: 2.2.0_alpha153/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-tex')
-rw-r--r--dev-tex/luatex/ChangeLog8
-rw-r--r--dev-tex/luatex/files/includes.patch25
-rw-r--r--dev-tex/luatex/luatex-0.74.0.ebuild102
3 files changed, 134 insertions, 1 deletions
diff --git a/dev-tex/luatex/ChangeLog b/dev-tex/luatex/ChangeLog
index ab37c8924413..012ff0c3f2c1 100644
--- a/dev-tex/luatex/ChangeLog
+++ b/dev-tex/luatex/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-tex/luatex
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/luatex/ChangeLog,v 1.107 2013/01/15 10:40:02 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/luatex/ChangeLog,v 1.108 2013/01/15 21:21:20 aballier Exp $
+
+*luatex-0.74.0 (15 Jan 2013)
+
+ 15 Jan 2013; Alexis Ballier <aballier@gentoo.org> +luatex-0.74.0.ebuild,
+ +files/includes.patch:
+ version bump
15 Jan 2013; Agostino Sarubbo <ago@gentoo.org> luatex-0.70.1-r1.ebuild:
Stable for amd64, wrt bug #452018
diff --git a/dev-tex/luatex/files/includes.patch b/dev-tex/luatex/files/includes.patch
new file mode 100644
index 000000000000..f93c7312b315
--- /dev/null
+++ b/dev-tex/luatex/files/includes.patch
@@ -0,0 +1,25 @@
+Index: source/texk/web2c/luatexdir/image/pdftoepdf.w
+===================================================================
+--- source.orig/texk/web2c/luatexdir/image/pdftoepdf.w
++++ source/texk/web2c/luatexdir/image/pdftoepdf.w
+@@ -26,6 +26,8 @@ static const char _svn_version[] =
+ // define DEBUG
+ #define __STDC_FORMAT_MACROS /* for PRId64 etc. */
+
++#include <stdint.h>
++#include <inttypes.h>
+ #include "image/epdf.h"
+
+ // This file is mostly C and not very much C++; it's just used to interface
+Index: source/texk/web2c/luatexdir/image/writejp2.w
+===================================================================
+--- source.orig/texk/web2c/luatexdir/image/writejp2.w
++++ source/texk/web2c/luatexdir/image/writejp2.w
+@@ -30,6 +30,7 @@ ISO/IEC 15444-1, Second edition, 2004-09
+ @c
+ #include <math.h>
+ #include <assert.h>
++#include <stdint.h>
+ #include "ptexlib.h"
+ #include "image/image.h"
+ #include "image/writejp2.h"
diff --git a/dev-tex/luatex/luatex-0.74.0.ebuild b/dev-tex/luatex/luatex-0.74.0.ebuild
new file mode 100644
index 000000000000..f9ab5b99ffbd
--- /dev/null
+++ b/dev-tex/luatex/luatex-0.74.0.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/luatex/luatex-0.74.0.ebuild,v 1.1 2013/01/15 21:21:20 aballier Exp $
+
+EAPI=4
+
+inherit libtool eutils texlive-common
+
+MY_P=${PN}-beta-${PV}
+DESCRIPTION="An extended version of pdfTeX using Lua as an embedded scripting language."
+HOMEPAGE="http://www.luatex.org/"
+SRC_URI="http://foundry.supelec.fr/gf/download/frsrelease/396/1876/${MY_P}-source.tar.bz2
+ http://foundry.supelec.fr/gf/download/frsrelease/396/1878/${MY_P}-doc.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc"
+
+RDEPEND="dev-libs/zziplib
+ >=media-libs/libpng-1.4
+ x11-libs/cairo
+ x11-libs/pixman
+ >=app-text/poppler-0.12.3-r3[xpdf-headers(+)]
+ sys-libs/zlib
+ >=dev-libs/kpathsea-6.0.1_p20110627"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}/source"
+
+src_prepare() {
+ epatch "${FILESDIR}/remove-zlib-version-check.patch" \
+ "${FILESDIR}/includes.patch"
+ S="${S}/build-aux" elibtoolize --shallow
+}
+
+src_configure() {
+ # Too many regexps use A-Z a-z constructs, what causes problems with locales
+ # that don't have the same alphabetical order than ascii. Bug #244619
+ # So we set LC_ALL to C in order to avoid problems.
+ export LC_ALL=C
+
+ cd "${S}/texk/web2c"
+ econf \
+ --disable-cxx-runtime-hack \
+ --disable-all-pkgs \
+ --disable-mp \
+ --disable-ptex \
+ --disable-tex \
+ --disable-mf \
+ --disable-largefile \
+ --disable-ipc \
+ --disable-shared \
+ --enable-luatex \
+ --enable-dump-share \
+ --without-mf-x-toolkit \
+ --without-x \
+ --with-system-kpathsea \
+ --with-kpathsea-includes="${EPREFIX}"/usr/include \
+ --with-system-cairo \
+ --with-system-pixman \
+ --with-system-gd \
+ --with-system-libpng \
+ --with-system-teckit \
+ --with-system-zlib \
+ --with-system-t1lib \
+ --with-system-xpdf \
+ --with-system-poppler \
+ --with-system-zziplib \
+ --with-system-ptexenc \
+ --disable-multiplatform
+}
+
+src_compile() {
+ texk/web2c/luatexdir/getluatexsvnversion.sh || die
+ cd "${WORKDIR}/${MY_P}/source/texk/web2c"
+ emake luatex
+}
+
+src_install() {
+ cd "${WORKDIR}/${MY_P}/source/texk/web2c"
+ emake DESTDIR="${D}" bin_PROGRAMS="luatex" SUBDIRS="" nodist_man_MANS="" \
+ install-exec-am
+
+ dodoc "${WORKDIR}/${MY_P}/README" luatexdir/NEWS
+ cp source/texk/web2c/man
+ cp man/luatex.man "${T}/luatex.1"
+ doman "${T}/luatex.1"
+ use doc && dodoc "${WORKDIR}/${MY_P}/manual/"*.pdf
+}
+
+pkg_postinst() {
+ if ! has_version '>=dev-texlive/texlive-basic-2008' ; then
+ elog "Note that this package does not install many files, mainly just the"
+ elog "${PN} executable, which needs other files in order to be"
+ elog "useful. Please consider installing a recent TeX distribution such as"
+ elog "TeX Live 2008 or later to take advantage of the full power of"
+ elog "${PN} ."
+ fi
+ efmtutil-sys
+}