summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-08-29 16:17:37 +0000
committerIan Delaney <idella4@gentoo.org>2013-08-29 16:17:37 +0000
commit362afb1b59644ba00d2a435058695f7da2017627 (patch)
tree3092323d46d78d94eab2735754c6f49f1519fdd0 /dev-tex
parentFix Manifest for source tarball clean up upstream. (diff)
downloadgentoo-2-362afb1b59644ba00d2a435058695f7da2017627.tar.gz
gentoo-2-362afb1b59644ba00d2a435058695f7da2017627.tar.bz2
gentoo-2-362afb1b59644ba00d2a435058695f7da2017627.zip
revbump -> EAPI 5
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-tex')
-rw-r--r--dev-tex/html2latex/ChangeLog10
-rw-r--r--dev-tex/html2latex/html2latex-1.1-r1.ebuild41
2 files changed, 48 insertions, 3 deletions
diff --git a/dev-tex/html2latex/ChangeLog b/dev-tex/html2latex/ChangeLog
index 0e986b7ffa47..d92f0ab40466 100644
--- a/dev-tex/html2latex/ChangeLog
+++ b/dev-tex/html2latex/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-tex/html2latex
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/html2latex/ChangeLog,v 1.16 2009/09/06 20:47:06 ranger Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/html2latex/ChangeLog,v 1.17 2013/08/29 16:17:37 idella4 Exp $
+
+*html2latex-1.1-r1 (29 Aug 2013)
+
+ 29 Aug 2013; Ian Delaney <idella4@gentoo.org> +html2latex-1.1-r1.ebuild:
+ revbump -> EAPI 5
06 Sep 2009; Brent Baude <ranger@gentoo.org> html2latex-1.1.ebuild:
Marking html2latex-1.1 ppc64 stable for bug 276990
@@ -53,4 +58,3 @@
16 Feb 2005; Mamoru KOMACHI <usata@gentoo.org> +html2latex-1.1.ebuild:
Initial import. Ebuild submitted by Samuel Robyr <samuel.robyr@gmail.com>;
bug #73407.
-
diff --git a/dev-tex/html2latex/html2latex-1.1-r1.ebuild b/dev-tex/html2latex/html2latex-1.1-r1.ebuild
new file mode 100644
index 000000000000..edd5fd8df23b
--- /dev/null
+++ b/dev-tex/html2latex/html2latex-1.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/html2latex/html2latex-1.1-r1.ebuild,v 1.1 2013/08/29 16:17:37 idella4 Exp $
+
+EAPI=5
+
+inherit perl-module
+
+DESCRIPTION="Perl script to convert HTML files into formatted LaTeX"
+HOMEPAGE="http://html2latex.sourceforge.net/"
+SRC_URI="mirror://sourceforge/html2latex/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="imagemagick libwww"
+
+DEPEND="dev-perl/HTML-Tree
+ dev-perl/XML-Simple
+ imagemagick? ( media-gfx/imagemagick )
+ libwww? ( dev-perl/libwww-perl )"
+
+src_compile() {
+ # HTML::LaTex
+ cd HTML
+ perl-module_src_prep
+ perl-module_src_compile
+}
+
+src_install() {
+ dobin html2latex
+ doman html2latex.1
+ dodoc README TODO
+
+ # HTML::LaTex
+ cd HTML
+ perl-module_src_install
+ rm unwanted README.win
+ rm $(find "${D}" -name README.win.txt) || die
+}